Page 1 of 2

RPF Chromium Browser "sign into chromium" (SOLVED)

Posted: Wed Sep 28, 2016 3:01 pm
by fruitoftheloom
Undertook a fresh install of Raspbian - Pixel today on my RPi0 and the "sign into Chromium" does not function, keep getting "service unavailable"

Though I can actually sign in to other Google Services without issue, would be handy to synch my information across Devices.

Chromium Version 51.0.2704.91 Built on Ubuntu 14.04, running on Raspbian 8.0

Linux raspberrypi 4.4.21+ #911 Thu Sep 15 14:17:52 BST 2016 armv6l GNU/Linux

Anyone have any ideas why this is still borked ????

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Wed Sep 28, 2016 3:19 pm
by kusti8
I've seen this issue and I'll look into it when I have time.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Wed Sep 28, 2016 3:22 pm
by fruitoftheloom
kusti8 wrote:I've seen this issue and I'll look into it when I have time.
Thank you yet again for all the work you put into Chromium, this issue happened with the previous BETA version as well :shock:

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 6:25 am
by Malman35
I am having a similar issue. I installed Chromium 51 using the instructions here.
viewtopic.php?f=63&t=121195
But I couldn't sign in to Chromium (see image below)
Image
Please fix this! Thank you for all you've done to make this possible!

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 7:07 am
by fruitoftheloom
Malman35 the Chromium you downloaded has been replaced by the Official RPF version:

https://www.raspberrypi.org/blog/introducing-pixel

Though in both versions had the issue you and I are experiecing...........

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 7:34 am
by cjan
confused me,
official = beta = 51.7000
inspector = 53
l10n = 53
source = 53

what's behind the scene ?

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 8:58 am
by Malman35
fruitoftheloom wrote:Malman35 the Chromium you downloaded has been replaced by the Official RPF version:

https://www.raspberrypi.org/blog/introducing-pixel

Though in both versions had the issue you and I are experiecing...........
I realize that but after trying the RPF version and it having that issue I tried the version I used before (the one in the link) and as you said it unfortunately had the same problem.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 6:20 pm
by mcfl33go
Same problem here..."Uh-oh! Service unavailable; try again later."

Other than that, Chromium is working great on RPi3!

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 9:44 pm
by LucidEye
Same issue here... can't sign into Chromium with any of my google accounts. This is only happening on this new install, not on any of my other machines.
Get the "Uh-oh! Service unavailable, try again later" error.
I tried all of the recommendations that the "see more" page offers and nothing fixed the problem.
So... is this yet another broken fork of the Chromium browser? There have been so many broken forks/builds in an attempt to make it work on the Pi I can't keep track of them all.
Will this latest build of Chromium update when I run apt-get update... or will we again be left with an outdated/vulnerable browser in a couple of weeks that will stop working when manually updated?
Like thousands of other Pi users... the main thing keeping me from using it as an energy-saving alternative to my desktop is the complete lack of a decent web browser.
I really don't understand why it's been so hard for the devs to get Chromium working on the Pi... and I still don't want to use Firefox/Iceweasle as it is still a memory hog and prone to crashing.... and still not as secure as Chrome/Chromium from what I've read... so I use Chrome on all my machines.
And Chrome/Chromium is pretty much worthless without the ability to sync all my bookmarks and settings across all my devices at home and work.
So... how many more years are we supposed to wait to get a fully functional working browser for the Pi? Seriously, it's gone far beyond frustrating at this point.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 10:10 pm
by lebeauc
I'm also seeing the same issue. Started seeing it last night after doing a dist-upgrade, then trying to print to my google cloud printer that was being hosted on my Pi. The printer was showing as offline. When I tried to re-log into Chromium (due to expired credentials) I found this issue. Spent a good majority of last night trying to figure it out, with no luck. I decided to do another google search tonight and came up with this thread. Glad to see it wasn't just me, but not glad that it seems there is currently no fix.

Hopefully someone figures it out soon.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Thu Sep 29, 2016 10:49 pm
by Malman35
LucidEye wrote: So... how many more years are we supposed to wait to get a fully functional working browser for the Pi? Seriously, it's gone far beyond frustrating at this point.
Settle down. :) I trust that the people behind this project will update it and fix it. I can say that because I started using this quite a while ago when it was still on chromium 48 and it has been updated quite a few times. Oh and the bookmark sync thing always worked before so I think it is just an issue with the new version.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Fri Sep 30, 2016 6:50 am
by gkreidl
LucidEye wrote:Same issue here... can't sign into Chromium with any of my google accounts. This is only happening on this new install, not on any of my other machines.
Get the "Uh-oh! Service unavailable, try again later" error.
I tried all of the recommendations that the "see more" page offers and nothing fixed the problem.
So... is this yet another broken fork of the Chromium browser? There have been so many broken forks/builds in an attempt to make it work on the Pi I can't keep track of them all.
Will this latest build of Chromium update when I run apt-get update... or will we again be left with an outdated/vulnerable browser in a couple of weeks that will stop working when manually updated?
Like thousands of other Pi users... the main thing keeping me from using it as an energy-saving alternative to my desktop is the complete lack of a decent web browser.
I really don't understand why it's been so hard for the devs to get Chromium working on the Pi... and I still don't want to use Firefox/Iceweasle as it is still a memory hog and prone to crashing.... and still not as secure as Chrome/Chromium from what I've read... so I use Chrome on all my machines.
And Chrome/Chromium is pretty much worthless without the ability to sync all my bookmarks and settings across all my devices at home and work.
So... how many more years are we supposed to wait to get a fully functional working browser for the Pi? Seriously, it's gone far beyond frustrating at this point.
Some of your arguments are simply wrong, e. g.
"Firefox is a memory hog". I've tested almost all available browsers on the Pi and that includes memory consumption. The full blown browsers need approximately the same amount of memory when opening the same pages, with one exception: chromium needs quite a bit more.
And there are other features where Firefox performs better, too (Javascript benchmarks). Video inside a web page is useless in Firefox. That's where Chromium is better and still more with the new video HW acceleration.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Fri Sep 30, 2016 9:07 am
by fruitoftheloom
UPDATE to the sign in issue:

I have checked My Devices List at Google Accounts and it states I have signed in to "Chrome 51", so definitely a bug ??

https://myaccount.google.com/intro/security

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Fri Sep 30, 2016 1:22 pm
by Malman35
fruitoftheloom wrote:UPDATE to the sign in issue:

I have checked My Devices List at Google Accounts and it states I have signed in to "Chrome 51", so definitely a bug ??

https://myaccount.google.com/intro/security
Yeah! Same here.
Image
Edit: I just realized that this is probably referring to signing into Google not chromium because the safari entry I think is referring to when I signed into my google account (YouTube, GMail, Etc.) in KWeb. If you are signed into Chrome (or Chromium) on a different computer and then go to history (of the browser, not your google account) you can see the activity of different computes that you have signed into Chrome (or Chromium) on. My Rpi username does not show up. Just my Phone.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Fri Sep 30, 2016 1:42 pm
by Dis93
I'm wondering if this is an upstream issue with Chromium. My Debian box also displays this issue with the latest Chromium, yet Chrome on said box is fine.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Fri Sep 30, 2016 1:43 pm
by fruitoftheloom
Clarification: I signed into Chromium Browser only, not gmail, YouTube etal.......

Yes it does appear to only happen with Chromium Browser and Googling gives lots of hits............

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Fri Sep 30, 2016 6:24 pm
by Kratos
Same problem here. It seemed so trivial to mention since the new version is awesome!

Kratos

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Sat Oct 01, 2016 1:13 pm
by jtmoderate876
Like others, I just tested the latest 2016-09-23 build of raspbian jessie running on raspberry pi from raspberrypi.org and it's version of Chromium also has "Uh-Oh! Service unavailable; Try again later" when trying to sign in to Chromium with a google account.

It looks like this might be related to the need to compile Chromium with an API key.
See :
https://bugs.chromium.org/p/chromium/is ... ?id=560551

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Sun Oct 02, 2016 2:58 am
by LucidEye
Sorry about my rant... just so darn frustrating to still not have a browser :-P

Just out of curiosity, can someone please provide the CLI code and PPAs (if any) for doing an apt-get install of this particular version of Chromium that has been packaged with PIXEL Raspbian.
I want to see if I can do a stand-alone install of it in a different desktop environment.
Thanks

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Sun Oct 02, 2016 11:11 am
by kusti8
LucidEye wrote:Sorry about my rant... just so darn frustrating to still not have a browser :-P

Just out of curiosity, can someone please provide the CLI code and PPAs (if any) for doing an apt-get install of this particular version of Chromium that has been packaged with PIXEL Raspbian.
I want to see if I can do a stand-alone install of it in a different desktop environment.
Thanks
It's in the raspberry pi archive, something with raspberrypi.org. Remember that it will only work on ARM systems.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Mon Oct 03, 2016 10:01 am
by SvenVT85
The "sign in" issue started on my raspberry PI on monday 26 september. Before that date, it worked fine.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Mon Oct 03, 2016 12:54 pm
by DougieLawson
SvenVT85 wrote:The "sign in" issue started on my raspberry PI on monday 26 september. Before that date, it worked fine.
That tends to point towards it being a root certificate expiry, invalid root cert or revoked root cert or something like that.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Mon Oct 03, 2016 1:11 pm
by kusti8
DougieLawson wrote:
SvenVT85 wrote:The "sign in" issue started on my raspberry PI on monday 26 september. Before that date, it worked fine.
That tends to point towards it being a root certificate expiry, invalid root cert or revoked root cert or something like that.
It's an issue with the API keys that got overloaded and disabled. A new release is coming soon.

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Tue Oct 04, 2016 8:06 am
by SvenVT85
kusti8 wrote:
DougieLawson wrote:
SvenVT85 wrote:The "sign in" issue started on my raspberry PI on monday 26 september. Before that date, it worked fine.
That tends to point towards it being a root certificate expiry, invalid root cert or revoked root cert or something like that.
It's an issue with the API keys that got overloaded and disabled. A new release is coming soon.
Thanks!

Re: RPF Chromium Browser "sign into chromium" not working

Posted: Tue Oct 04, 2016 9:34 am
by aworan
kusti8 wrote: It's an issue with the API keys that got overloaded and disabled. A new release is coming soon.
Is the source code will be publish by the RPF ?
Thank you