pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

RPi3 jessie - NPTD does not work

Sun May 22, 2016 3:58 pm

Hello,

I have bought RPi3 about two months ago and installed original Rasbian Jessie three times since and time has never updated. Not even once. RPi3 is connected to Internet via WiFi and I never noticed any other problem with connection. There is no problem with Firewall because NPT update on the Windows machine on the same LAN works seamless. Time zone on RPi3 is properly set. I tried different forums, most notably this

http://raspberrypi.stackexchange.com/qu ... pdate-time

with no solution.

After typing

Code: Select all

sudo ntpd -q -g
the program freezes and the last message in /var/log/syslog is

Code: Select all

listening on routing socket on fd #22 for interface updates
I wonder why nobody else reported this error so far? Since I am talking about fresh original Raspbian the same problem should be present everywhere.

broe23
Posts: 903
Joined: Thu Jan 28, 2016 9:35 pm
Location: Central IL
Contact: Website

Re: RPi3 jessie - NPTD does not work

Sun May 22, 2016 4:14 pm

Time is actually faked through the fwclock file in /etc. If your firewall is blocking the port that is used to ping the NTP servers. Or there is no network connection. The unit will never be able to update.

Remember that there is no Real Time Clock of Bios on these units.
Ren: Now listen, Cadet. I've got a job for you. See this button? Ren: Don't touch it! It's the History Eraser button, you fool! Stimpy: So what'll happen? Ren: That's just it. We don't know. Maybe something bad, maybe something good.

epoch1970
Posts: 3781
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi3 jessie - NPTD does not work

Sun May 22, 2016 5:38 pm

Ntpdate is "deprecated", it was working but you had to invoke it as ntpdate-debian; In case your Pi has been sitting offline for a long time, the time jump it would cause could disrupt the machine to some degree.
I'm not sure it still works so well on jessie, I think it's better to use ntpd only, and let it adjust the time progressively. In my experience ntpd works fine on raspbian (no worse than standard debian/x86: from time to time it quits on me...)

Great news: systemd is futzing with NTP too. If you have installed the ntp package and wonder wtf are those unknown servers among your peers, just look at /etc/systemd/timesyncd.conf.
I have disabled the systemd-timesyncd service and now my list of peers is the one I've set in ntp.conf. (really this is appalling.)

What's missing from your post is your ntp.conf file... This is what I use for servers:

Code: Select all

server refclock.lan1 iburst
server ntp.lan2 iburst
server some.reputable.public.ntp.server.on.the.internet
server 127.127.1.1  		# Local LCL clock 
fudge  127.127.1.1 stratum 6	# Local clock policy:
# 1. Do not void time from our selected servers (stratum 1 or 2), but 
# 2. do not trust broadcasted time or random stratum 15 hosts
(I'm not sure about the use of iburst. I wonder if it is not the cause of ntp quitting from time to time, but it's in this file and this ntpd doesn't behave worse than others on my network.)
and this is my peers list:

Code: Select all

# ntpq --peers
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*refclock.lan1 .DCFa.           1 b   40   64   77    1.121   -3.262   1.407
+ntp.lan2        192.168.0.1      2 b   29   64  177    1.055   -3.266   1.405
+some.reputa xxx.xxx.xxx.xxx   2 u   37   64  377    6.518    2.631   2.256
 LOCAL(1)        .LOCL.           6 l  503   64  200    0.000    0.000   0.000
 172.16.255.255  .BCST.          16 b    -   64    0    0.000    0.000   0.000
NTP uses port 123/udp. Make sure your firewall lets it through.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Sun May 22, 2016 6:05 pm

Thank you for your responses. What I did in meantime (on suggestion from someone else) is to install ntpdate and after issuing command

Code: Select all

ntpdate 0.si.pool.ntp.org
time was finally updated. So commands ntpdate and ntpd are commands from two different packages??!

Contents of ntp.conf are

Code: Select all

driftfile /var/lib/ntp/ntp.drift

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

server 0.debian.pool.ntp.org iburst
server 1.debian.pool.ntp.org iburst
server 2.debian.pool.ntp.org iburst
server 3.debian.pool.ntp.org iburst

restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

restrict 127.0.0.1
restrict ::1
and

Code: Select all

ntpq --peers
returns

Code: Select all

ntpq: read: Connection refused
I didn't understand the rest, please not I am Linux novice.

broe23
Posts: 903
Joined: Thu Jan 28, 2016 9:35 pm
Location: Central IL
Contact: Website

Re: RPi3 jessie - NPTD does not work

Sun May 22, 2016 8:41 pm

There are different packages, depending on the CPU. NTPD is a standard package that is used with all Linux Ditro's. Just different time servers are used in each distro.

NTP.org sets the standards. Archlinux wiki has a lot of resources that are very helpful. Also Linux Document Project tldp.org is a good resource.
Ren: Now listen, Cadet. I've got a job for you. See this button? Ren: Don't touch it! It's the History Eraser button, you fool! Stimpy: So what'll happen? Ren: That's just it. We don't know. Maybe something bad, maybe something good.

epoch1970
Posts: 3781
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi3 jessie - NPTD does not work

Sun May 22, 2016 9:09 pm

pygmalion wrote:please not I am Linux novice.
Do you really need the ntpdate and ntpd programs?
If your need really is "I want network time" then the answer is:

1) remove ntpdate and ntpd. You will be using the stock systemd-timesyncd service that can provide the same.
2) type the command "timedatectl status" and if it says "Network time on: no", then type "timedatectl set-ntp true". Re-run "timedatectl status" and it should say "yes".
The NTP servers used will be the ones in file "/etc/systemd/timesyncd.conf". They are, AFAIK, the same as the ones used on a stock ntp.conf file, i.e a bunch of debian.pool.ntp.org servers.

HTH
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

User avatar
DougieLawson
Posts: 36306
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: RPi3 jessie - NPTD does not work

Sun May 22, 2016 10:50 pm

If you can't get ntpd to run take a look at htpdate. http://www.vervest.org/htp/ which doesn't use any special ports, it gets the time over regular http (port 80).

That's available to install using sudo apt-get update; sudo apt-get install htpdate
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 6:44 am

I actually tried both of those suggestions, unsuccessfully. As far as timesyncd is concerned here is my post about that:

Code: Select all

http://unix.stackexchange.com/questions/284354/problems-with-timesyncd-or-networkd
As far as ntpdate is concerned my experiences are as follows:

Just after fresh installation of ntpdate I wrote

Code: Select all

ntpdate server.name
and time was updated!!! However ntpdate registered itself as a system service and after restarting RPi3 it
  1. no longer updates time
  2. by issuing it manually using the command above I get error

Code: Select all

NTP socket is in use, exiting
It seems that the time update is not problem per se, but automatization / interaction with internet services is.

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 7:18 am

After losing 50 hours of my time on this petty problem and talking to a dozen of Linux/Raspberry experts, the time has run out on me.

My firm belief is that the only way to solve this problem is that Raspbian developers actually buy one Raspberry Pi 3 and test it themselves. If anyone knows one, please let him now about that problem.

Software time update without official Raspbian solution is IMHO hopeless. I already ordered DS3231 hardware time keeping module, but I will keep in touch to see if this thing was solved and I will no longer need it.

Best regards!

Marko

broe23
Posts: 903
Joined: Thu Jan 28, 2016 9:35 pm
Location: Central IL
Contact: Website

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 7:31 am

Marko you do realize that they test the units in the labs at Raspberry Pi HQ. There is something blocking the update. Either IPTables is messed up, or you have not gone through Raspi-Config. No one has had any issues with Time Updates on their Pi. If you are going to show everything that your machine is having issues, you need to post the Log file or send it to the developers at Raspberry Pi, so that they can look at your logs.
Ren: Now listen, Cadet. I've got a job for you. See this button? Ren: Don't touch it! It's the History Eraser button, you fool! Stimpy: So what'll happen? Ren: That's just it. We don't know. Maybe something bad, maybe something good.

texy
Forum Moderator
Forum Moderator
Posts: 5160
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 7:38 am

The forums are not full of people complaining about this. I have never seen a problem with the pi picking up the correct time/date when networked at home or at my work place in 4 years of pi ownership. Perhaps I was just lucky.....
Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

epoch1970
Posts: 3781
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 7:52 am

pygmalion wrote:It seems that the time update is not problem per se, but automatization / interaction with internet services is.
As far as ntpdate is concerned, what happens with the "socket in use" message is that ntpd (I guess) is listening on 123/udp. The socket is in use.
Stop ntpd, run ntpdate, start ntpd. You wont see the message.

Ntpdate was designed to be called once, early at boot time. ntpdate-debian does the same as ntpdate but uses the servers you've configured in /etc/ntp.conf, it's simpler to use.
Systemd does what ntpdate was designed for.

Clearly the is or was an issue with firewalling 123/udp, on your router or on a firewall running on the Pi. Chasing the problem in a myriad of ntp client or server implementations will not change anything to that fact.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

epoch1970
Posts: 3781
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 7:57 am

broe23 wrote:If you are going to show everything that your machine is having issues, you need to post the Log file or send it to the developers at Raspberry Pi, so that they can look at your logs.
I surely hope they don't!
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:01 am

Of course I did raspi-config setting time zone, checked firewall and followed dozens of other advices from Linux/Raspberry experts, to no avail. Maybe my Rasberry Pi 3 has hardware error or is somehow un-standard, in which case the hardware module is the only solution. However, as you can read above, I did succeed to update time under very special conditions, which suggests it is software error after all.

I can post log file, if you tell me how.
Last edited by pygmalion on Mon May 23, 2016 8:17 am, edited 1 time in total.

epoch1970
Posts: 3781
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:03 am

You need to read man pages, you know.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:15 am

epoch1970 wrote:
pygmalion wrote:It seems that the time update is not problem per se, but automatization / interaction with internet services is.
As far as ntpdate is concerned, what happens with the "socket in use" message is that ntpd (I guess) is listening on 123/udp. The socket is in use.
Stop ntpd, run ntpdate, start ntpd. You wont see the message.

Ntpdate was designed to be called once, early at boot time. ntpdate-debian does the same as ntpdate but uses the servers you've configured in /etc/ntp.conf, it's simpler to use.
Systemd does what ntpdate was designed for.

Clearly the is or was an issue with firewalling 123/udp, on your router or on a firewall running on the Pi. Chasing the problem in a myriad of ntp client or server implementations will not change anything to that fact.
Hm, I just checked your suggestion and what I found is that momentarily I can update time using ntpdate even if I don't turn ntpd off. But neither ntpdate nor ntpd update time automatically.

I want to point out that we are talking about a fresh Raspbian installation, I haven't put or set any firewall, ntpd was installed by default and never worked.

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:26 am

epoch1970 wrote:You need to read man pages, you know.
I must disappoint you, but my experiences with Unix/Linux is that I used the former for a while in the previous century, and now Linux since I got RPi3. I actually know the man command, as well as ls, cp, chmod..., but that's all. I just want to do some Python with peripherals and I need real time. I am not Linux enthusiast, I am sorry.

epoch1970
Posts: 3781
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:33 am

pygmalion wrote:what I found is that momentarily I can update time using ntpdate even if I don't turn ntpd off.
No, you can't.
This is a machine, it's not magic. You don't order it around and bend it to your will. You learn how to make it do what you want.

If you were able to run ntpdate without message it means port 123/udp was *not* in use. No other software was listening on 123/udp at that time, on the interface that ntpdate used.
Look at your processes with "ps waxu", "service" has a way of failing silently to launch daemons. Look at your network setup and look at "netstat -an | grep :123" there might be an interface that doesn't listen on 123/udp.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:45 am

epoch1970 wrote:
pygmalion wrote:what I found is that momentarily I can update time using ntpdate even if I don't turn ntpd off.
No, you can't.
This is a machine, it's not magic. You don't order it around and bend it to your will. You learn how to make it do what you want.

If you were able to run ntpdate without message it means port 123/udp was *not* in use. No other software was listening on 123/udp at that time, on the interface that ntpdate used.
Look at your processes with "ps waxu", "service" has a way of failing silently to launch daemons. Look at your network setup and look at "netstat -an | grep :123" there might be an interface that doesn't listen on 123/udp.
"ps waxu": "error: conflicting format options
"netstat -an | grep :123" you are right, nobody is listening to 123. If I do this in another terminal just after I started "nstpdate address.name", then there is "udp 0 0 0.0.0.0:123 0.0.0.0:*" and "udp6 0 0 ::123 :::*"

On the other hand, if I do "ntpd -q -g" I get bunch ot "udp"s and "udp6"s and time update fails.

Anyways, obviously there is no problem with time update per se, nor with firewalls.

User avatar
0xFF
Posts: 202
Joined: Tue Nov 20, 2012 7:52 pm
Location: Poland

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:48 am

I have 2 PI's in the same network:
1. RPI-1B Raspbian GNU/Linux 7 (wheezy) connected via Ethernet
2. RPI-3 Raspbian GNU/Linux 8 (jessie) connected via WiFi

The first one keeps time w/o problem.
The second is out of the sync (few minutes).

NTPD configuration seems to be ok:

Code: Select all

 /etc/init.d/ntp status
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp)
   Active: active (running) since Mon 2016-05-23 10:34:21 CEST; 1min 21s ago
  Process: 599 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─644 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 107:112

May 23 10:34:24 pi3 ntpd[644]: peers refreshed
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 0.debian.pool.ntp.org
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 1.debian.pool.ntp.org
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 2.debian.pool.ntp.org
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 3.debian.pool.ntp.org
May 23 10:34:33 pi3 ntpd[644]: Listen normally on 5 wlan0 192.168.1.111 UDP 123
May 23 10:34:33 pi3 ntpd[644]: peers refreshed
May 23 10:34:35 pi3 ntpd_intres[686]: DNS 0.debian.pool.ntp.org -> 193.25.222.240
May 23 10:34:35 pi3 ntpd_intres[686]: DNS 1.debian.pool.ntp.org -> 193.219.28.2
May 23 10:34:35 pi3 ntpd_intres[686]: DNS 2.debian.pool.ntp.org -> 194.29.130.252
Any tips how to check where is the problem?

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Mon May 23, 2016 8:58 am

0xFF wrote:I have 2 PI's in the same network:
1. RPI-1B Raspbian GNU/Linux 7 (wheezy) connected via Ethernet
2. RPI-3 Raspbian GNU/Linux 8 (jessie) connected via WiFi

The first one keeps time w/o problem.
The second is out of the sync (few minutes).

NTPD configuration seems to be ok:

Code: Select all

 /etc/init.d/ntp status
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp)
   Active: active (running) since Mon 2016-05-23 10:34:21 CEST; 1min 21s ago
  Process: 599 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─644 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 107:112

May 23 10:34:24 pi3 ntpd[644]: peers refreshed
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 0.debian.pool.ntp.org
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 1.debian.pool.ntp.org
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 2.debian.pool.ntp.org
May 23 10:34:26 pi3 ntpd_intres[686]: host name not found: 3.debian.pool.ntp.org
May 23 10:34:33 pi3 ntpd[644]: Listen normally on 5 wlan0 192.168.1.111 UDP 123
May 23 10:34:33 pi3 ntpd[644]: peers refreshed
May 23 10:34:35 pi3 ntpd_intres[686]: DNS 0.debian.pool.ntp.org -> 193.25.222.240
May 23 10:34:35 pi3 ntpd_intres[686]: DNS 1.debian.pool.ntp.org -> 193.219.28.2
May 23 10:34:35 pi3 ntpd_intres[686]: DNS 2.debian.pool.ntp.org -> 194.29.130.252
Any tips how to check where is the problem?
Hallelujah, I am not the only one. In my case it is like this:

Code: Select all

 /etc/init.d/ntp status
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp)
   Active: active (running) since Mon 2016-05-23 10:52:29 CEST; 7s ago
  Process: 1672 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─1683 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 106:111

May 23 10:52:29 raspberrypi ntpd[1683]: Listen and drop on 0 v4wildcard 0.0....3
May 23 10:52:29 raspberrypi ntp[1672]: Starting NTP server: ntpd.
May 23 10:52:29 raspberrypi ntpd[1683]: Listen and drop on 1 v6wildcard :: U...3
May 23 10:52:29 raspberrypi ntpd[1683]: Listen normally on 2 lo 127.0.0.1 UD...3
May 23 10:52:29 raspberrypi ntpd[1683]: Listen normally on 3 wlan0 192.168.0...3
May 23 10:52:29 raspberrypi ntpd[1683]: Listen normally on 4 lo ::1 UDP 123
May 23 10:52:29 raspberrypi ntpd[1683]: Listen normally on 5 wlan0 fe80::d51...3
May 23 10:52:29 raspberrypi ntpd[1683]: peers refreshed
May 23 10:52:29 raspberrypi ntpd[1683]: Listening on routing socket on fd #2...s
May 23 10:52:29 raspberrypi systemd[1]: Started LSB: Start NTP daemon.
Hint: Some lines were ellipsized, use -l to show in full.

Code: Select all

Listening on routing socket on fd #22 for interface updates
is suspicious but I have no idea what this means.

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Wed Jun 01, 2016 3:19 pm

I found solution to ntpd problem on this thread: viewtopic.php?f=28&t=141454.

Obviously, this is global error. Too bad I lost several days trying different stuff before finding it. It is a shame that Raspberry Pi consortium missed such a basic mistake.

I still don't know how to make update automatic. If I stop and start service, time is updated, but no update happens at boot. Perhaps service is on before internet connection is. If anyone has any suggestions, please let me know.

Heater
Posts: 13600
Joined: Tue Jul 17, 2012 3:02 pm

Re: RPi3 jessie - NPTD does not work

Wed Jun 01, 2016 6:32 pm

pygmalion,
Obviously, this is global error. Too bad I lost several days trying different stuff before finding it. It is a shame that Raspberry Pi consortium missed such a basic mistake.
I sympathise with your frustration.

On the other hand, welcome to the reality of modern software and hardware.

There is no "consortium" behind the Pi. It's a charitable foundation. A non-profit. A little bunch of guys in Cambridge. Doing the best they can. Which is pretty amazing actually.

With a billion lines of software in the Raspbian operating system, and a huge variety of hardware out there, it's impossible to test for everything.

Not to mention that Raspbian is not created by the Pi Foundation anyway.

Looking at the bigger picture, isn't it our responsibility, we the users of all this Free and Open Source software, to check things out, get a bit frustrated, file bug reports and so on?

Or should we expect everything to work, for free, like magic?

Even billion dollar companies like MS and Samsung cannot get everything working: http://www.theregister.co.uk/2016/05/31 ... sung_fail/
despite the huge number of people they have working for them.
Memory in C++ is a leaky abstraction .

pygmalion
Posts: 26
Joined: Sat Jul 18, 2015 4:44 pm

Re: RPi3 jessie - NPTD does not work

Thu Jun 02, 2016 7:37 am

Heater,
There is no "consortium" behind the Pi. It's a charitable foundation. A non-profit. A little bunch of guys in Cambridge. Doing the best they can. Which is pretty amazing actually.

With a billion lines of software in the Raspbian operating system, and a huge variety of hardware out there, it's impossible to test for everything.

Not to mention that Raspbian is not created by the Pi Foundation anyway.

Looking at the bigger picture, isn't it our responsibility, we the users of all this Free and Open Source software, to check things out, get a bit frustrated, file bug reports and so on?
Of course, my criticism sounds too harsh. I know that one should never look a gift horse in the mouth. My post was more like a cry of disappointment.

1. There are many other free projects, which work much better, especially in terms of support and de-bugging. We are talking about evident error that appeared at least three months ago with no official solution in sight.

2. It is infinitely more difficult to provide operating system that works on zillion different hardware configurations than operating system that works on only five hardware configurations.

3. I have many friends that tell me how Linux is a good alternative to Windows or IOS. Well, I am using former for few months and I used immense quantity of time solving very basic problems that I never came across using latter. It seems that one has to be computer specialist in order to use Linux these days.

texy
Forum Moderator
Forum Moderator
Posts: 5160
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: RPi3 jessie - NPTD does not work

Thu Jun 02, 2016 8:07 am

pygmalion wrote: Of course, my criticism sounds too harsh. I know that one should never look a gift horse in the mouth. My post was more like a cry of disappointment.
[snip]
3. I have many friends that tell me how Linux is a good alternative to Windows or IOS. Well, I am using former for few months and I used immense quantity of time solving very basic problems that I never came across using latter. It seems that one has to be computer specialist in order to use Linux these days.
So there was no disappointment for the first 'few months' of using Windows for the first time? It's all part of the learning curve - no gain without pain and all that. Think how boring it would be, and how much you would of learned, if it all just 'worked'. I guess it's all down to expectations......
Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

Return to “General discussion”