Duhjoker
Posts: 385
Joined: Fri Feb 05, 2016 8:57 am
Location: Where palm trees grow

How do I get the ~ character raspbian jessie

Sat May 21, 2016 3:48 am

I'm trying to find this character ~~~~~

I'm using a lil 2.4gz thumb keyboard and I have tried to set it in several different ways but all I get is the same character but raised higher and that just won't do.

My local settings are US generic 101 keyboard

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 7:22 am

A very good question.

I even have a "~" on my keyboard. Problem is I have to press "Alt-Gr + ~" twice to get one "~" out.
Memory in C++ is a leaky abstraction .

java
Posts: 226
Joined: Mon Jul 21, 2014 9:41 am

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 7:33 am

Use the keyboard localisation map that matches your key board. This usually works, but all keyboards do not stick to the standard properly. So you may still have problems. Keyboards made for other devices might not have all symbols implemented, as the makers deemed it not needed for that particular device.

User avatar
Cancelor
Posts: 757
Joined: Wed Aug 28, 2013 4:09 pm
Location: UK

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 7:41 am

Copy and paste it from the terminal prompt! :lol:

Code: Select all

pi@raspberry ~ $ 
Or try the following:-

Press and hold Shift+Ctrl+U then release, then type 007E

007E is the Unicode value for the Tilde character ~
Can't find the thread you want? Try googling : YourSearchHere site:raspberrypi.org

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 11:36 am

"Press and hold Shift+Ctrl+U then release, then type 007E"

In this text box I get:

~

That's good. In a frame buffer terminal I get

"BEEP" and "007E"

That's bad. In a console window under X I get

007E.

That's bad. In Visual Studio Code I get:

~

That's good.

This kind of thing can drive you crazy....
Memory in C++ is a leaky abstraction .

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12338
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 11:42 am

its called a tilde!
https://en.wikipedia.org/wiki/Tilde
if your keyboard language setting is okay and your keyboard supports it it should, "just work".

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 11:51 am

It might help if the raspi-config actually had a keyboard language configuration facility.
Memory in C++ is a leaky abstraction .

User avatar
Cancelor
Posts: 757
Joined: Wed Aug 28, 2013 4:09 pm
Location: UK

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 12:16 pm

Yes but, is it a small tilde (U+02DC ˜ ), a tilde operator (U+007E ~), a combining tilde (U+0303 x ̃ ) , a swung dash (U+2053 ⁓ ) ,a reverse tilde (U+223D ∽) ..... to list a few

but not almost equal to a tilde (U+2248 ≈ ) :lol:
Can't find the thread you want? Try googling : YourSearchHere site:raspberrypi.org

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12338
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 12:25 pm

Heater wrote:It might help if the raspi-config actually had a keyboard language configuration facility.
its called "change keyboard layout"
INTERNATIONALISATION OPTIONS

Select Internationalisation Options and press Enter to be taken to a sub-menu containing the following options:


CHANGE LOCALE

Select a locale, for example en_GB.UTF-8 UTF-8.


CHANGE TIMEZONE

Select your local timezone, starting with the region such as Europe, then selecting a city, for example London. Type a letter to skip down the list to that point in the alphabet.


CHANGE KEYBOARD LAYOUT

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 1:20 pm

Yup. You need to change the config for what the Pi thinks the keyboard is. Used to drive me crazy as well... :D Going from memory, I believe it is somewhere in the Raspberry Pi Configuration tool under Preferences.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 1:52 pm

mahjongg,
its called "change keyboard layout"
Yes, except it does not do that.

Code: Select all

$ sudo raspi-config
Check.

Select INTERNATIONALISATION OPTIONS

Check.

Select CHANGE LOCALE

Check.

Select en_GB.UTF-8 UTF-8

Check.

Select CHANGE TIMEZONE

Check.

Select "Europe -> Helsinki"

Check.

Select CHANGE KEYBOARD LAYOUT

FAIL.

I'm presented with a list of keyboard models. There is no "Finnish language layout". Or indeed any other language.

Quit raspi-config.

Install vim.

Code: Select all

$ sudo apt-get install vim
$ sudo vim /etc/default/keyboard
Change XKBLAYOUT to

XKBLAYOUT="fi"

This is very annoying. And only sort of works. The "~" key stil needs pressing Alt-Gr and "~" twice.

Still, I have had this problem with all Debian systems since forever....
Memory in C++ is a leaky abstraction .

JimmyN
Posts: 1109
Joined: Wed Mar 18, 2015 7:05 pm
Location: Virginia, USA

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 2:55 pm

If you're running raspi-config, using Putty or something with no keyboard plugged into the RPi, the "I3 Change Keyboard Layout" will fail. The menu will disappear for a second then return, and it will do that each time you select to change the keyboard layout. When you exit raspi-config you'll probably see these messages left behind on the terminal screen

Code: Select all

sudo raspi-config
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Reloading keymap. This may take a short while
So if you don't have a keyboard physically plugged into the RPi that may be why attempts to set the keyboard are failing.

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 3:23 pm

Just for the sake of this thread I hooked up my Pi to a screen, keyboard and mouse.

I get that error anyway:
pi@raspberrypi3:~ $ sudo raspi-config
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Reloading keymap. This may take a short while
Same if I do it from a terminal in X Windows or hit Ctrl-Alt and F1 and do it directly.
Memory in C++ is a leaky abstraction .

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 3:37 pm

Cancelor wrote:Copy and paste it from the terminal prompt! :lol:

Code: Select all

pi@raspberry ~ $ 
Probably the best solution. :D

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

noggin
Posts: 98
Joined: Sun Feb 21, 2016 1:55 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 4:25 pm

What happens if you add a Finnish locale in addition to the EN.GB one?

AIUI on some OSs Finnish and Swedish keyboards are merged too?

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 5:01 pm

No idea.

As far as I know "locale" is nothing to do with keyboards or whatever I/O device. locale is to do with preferences for formatting of numbers, dates, etc. etc.

Some times my mind boggles at this. We have had computers available to the general populace since 1976 or so. But still, getting keyboards interpreted correctly is a pain.

This whole unicode thing just makes it worse.
Memory in C++ is a leaky abstraction .

klricks
Posts: 6609
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 11:21 pm

Heater wrote:....I'm presented with a list of keyboard models. There is no "Finnish language layout". Or indeed any other language....
Choosing a keyboard from the list doesn't change the language... I just choose one of the generic 105 etc.
It is the next menu that does the language setting. The default country of origin here is of course UK..... But here is what a lot of people miss... You need to scroll down to the bottom of the UK list and choose [Other] in order to move back into the country of origin menu. From there you choose the country, and Finnish is on that list with about 100 other countries.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

Heater
Posts: 13617
Joined: Tue Jul 17, 2012 3:02 pm

Re: How do I get the ~ character raspbian jessie

Sat May 21, 2016 11:42 pm

klricks,
It is the next menu that does the language setting. The default country of origin here is of course UK..... But here is what a lot of people miss... You need to scroll down to the bottom of the UK list and choose [Other] in order to move back into the country of origin menu. From there you choose the country, and Finnish is on that list with about 100 other countries.
So in other words the easy to use GUI interface does not work.

I think at some point I did coax the thing into showing me a list language layouts, I suspect it involved actually selecting a keyboard model rather than accepting the default.

Whatever, at some point it's quicker to hack the config files than mess with a GUI.
Memory in C++ is a leaky abstraction .

Duhjoker
Posts: 385
Joined: Fri Feb 05, 2016 8:57 am
Location: Where palm trees grow

Re: How do I get the ~ character raspbian jessie

Sun May 22, 2016 4:33 am

I've tried all kinds of keyboard layouts from the internationalization menu but none seem to match plus rebooting is a pain.

When I first started on my Pi last year I ran up against this problem. It was as simple as typing a command but I've lost that page telling me what the command was and it wasn't my thread.

Something like sudo keyboard UK.

Ive also tried to copy and paste the command into the terminal window but it won't paste for some reason

User avatar
DougieLawson
Posts: 36312
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: How do I get the ~ character raspbian jessie

Sun May 22, 2016 11:13 am

sudo dpkg-reconfigure keyboard-configuration
You MUST have your USB keyboard connected or it does nothing. That's precisely the same command that raspi-config uses.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

janpihlgren
Posts: 61
Joined: Thu Jul 26, 2012 4:00 am

Re: How do I get the ~ character raspbian jessie

Fri Aug 26, 2016 9:13 am

I have big problem to install keymap SE.
I use Rasberry Pi 3 with Raspbian Jessie - Linux Cnaeus 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv7l GNU/Linux
I have tried runing raspi-config to get the right keymap. I get the following respons:
pi@Cnaeus:~ $ sudo raspi-config
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: warning: script 'K01tightvncserver' missing LSB tags and overrides
insserv: warning: script 'tightvncserver' missing LSB tags and overrides
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: warning: script 'K01tightvncserver' missing LSB tags and overrides
insserv: warning: script 'tightvncserver' missing LSB tags and overrides
Reloading keymap. This may take a short while
pi@Cnaeus:~ $
I don't get the window where I can choose my keyboardmap.
I have also tried
sudo dpkg-reconfigure keyboard-configuration
with no luck.
So how to continue?

Duhjoker
Posts: 385
Joined: Fri Feb 05, 2016 8:57 am
Location: Where palm trees grow

Re: How do I get the ~ character raspbian jessie

Fri Aug 26, 2016 9:24 am

Yes but trying to figure out which keyboard option has the right character you need is the problem.

I went through at least twenty before eventually just emailing the lines i needed to use.

It would make things easier to have a set keyboard layout that has all the (correct) characters you will need to program your pi already there.

I mean really that would make better since than keyboard layout that only has some of what you actually need to fully program your pi.

Or make it an option you can choose by a CL command so when you are in program mode the characters are there.

Not trolling, i love my pi's but this is a problem i run into in a regular basis and a real pain.

And im not the only person. Ive checked the forum and there are several threads that contain the same problem.

klricks
Posts: 6609
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: How do I get the ~ character raspbian jessie

Fri Aug 26, 2016 12:53 pm

janpihlgren wrote:I have big problem to install keymap SE.
I use Rasberry Pi 3 with Raspbian Jessie - Linux Cnaeus 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv7l GNU/Linux
I have tried runing raspi-config to get the right keymap. I get the following respons:
pi@Cnaeus:~ $ sudo raspi-config
update-rc.d: ............
I don't get the window where I can choose my keyboardmap.
I have also tried
sudo dpkg-reconfigure keyboard-configuration
with no luck.
So how to continue?
As already mentioned in this thread, a USB keyboard MUST be attached to the RPI. If not the keyboard setting will not work.
The keyboard setting is only for the connected keyboard and does NOT fix issues with remote keyboards via SSH, VNC etc.
Ignore the warning messages.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

Duhjoker
Posts: 385
Joined: Fri Feb 05, 2016 8:57 am
Location: Where palm trees grow

Re: How do I get the ~ character raspbian jessie

Fri Aug 26, 2016 7:55 pm

Happens to me wether i use my wireless keyboard or my old fashioned USB keyboard.

Either way you dont get all the characters needed to fully program a
Pi on one layout.

One layout may have a few characters you need but then you have to go through the process again to get other characters.

wh7qq
Posts: 1339
Joined: Thu Oct 09, 2014 2:50 am

[SOLVED]Re: How do I get the ~ character raspbian jessie

Wed Aug 31, 2016 6:46 pm

I found that installing with Noobs and making sure to select the proper keyboard from the panel at the bottom of the screen gets the desired character set (US in my case). Installing Raspbian by itself does not. I always get the gb characters and it is problematic...for example no "|" or "@" characters. Oddly enough, the Desktop and its console have the correct (selected in Preferences>Localization>Keyboard) characters but booting into the cli gets the default "gb" character set. I am going to try the following:

Code: Select all

sudo nano /etc/default/keyboard
and replace

Code: Select all

XKBLAYOUT="gb"
with

Code: Select all

XKBLAYOUT="us"
. I will edit this post with the result.

Edit: 9/1/16. Works great! ~|@# all where they belong on the us layout. I expect it will work the same for other layouts.

Return to “General discussion”