Page 3 of 3

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Sun Mar 27, 2016 8:55 pm
by fruitoftheloom
typxxi wrote:PROBLEM: I started installing chromium today on 2 different systems (2B + 3B) in 2 ways.

Thx
Surely this should be in the Chromium Thread ??????????

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Sun Mar 27, 2016 10:38 pm
by kusti8
Yes it should be in the Chromium thread. I would also suggest connecting your Pi to the display. I don't really understand your post as well. Can you make it more clear?

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Mon Mar 28, 2016 7:58 am
by typxxi
#1 the problem occurs after first reboot

#2 I am sure to isolate the problem to this installation because the other way is still working on the Pi3B and I did that already twice yesterday.

#3 I took my nightly back up, added the cups installation and even after reboot everything worked fine. But after the installation procedure that is mentioned here in this OP the reboot is not able to start a few services and the graphic ui. There it stops.

Now I will do the same as yesterday but I will try the other way with more steps to where I linked above. Let's wait and see.
thx

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Mon Mar 28, 2016 9:22 am
by fruitoftheloom
typxxi wrote:#1 the problem occurs after first reboot

#2 I am sure to isolate the problem to this installation because the other way is still working on the Pi3B and I did that already twice yesterday.

#3 I took my nightly back up, added the cups installation and even after reboot everything worked fine. But after the installation procedure that is mentioned here in this OP the reboot is not able to start a few services and the graphic ui. There it stops.

Now I will do the same as yesterday but I will try the other way with more steps to where I linked above. Let's wait and see.
thx
You are posting in the wrong place this thread is not about installing Chromium

This the Chromium thread: viewtopic.php?f=63&t=121195

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Mon Mar 28, 2016 1:11 pm
by kusti8
What is the output when you install it?

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Fri Apr 01, 2016 4:13 am
by Higgs
Wow - great work!

The ability to play a YouTube video so easily (smoothly) in OMXPlayer surmounts one of the biggest usability problems I had with the RPi.

When I taught myself about Arduino, I would go to my PC and watch YouTube videos that helped me learn about it.

Later, when I got my RPi2 - I would go to my PC and watch YouTube videos to help me learn about it.

With the RPi, something always seemed wrong with having to do that....

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Fri Apr 01, 2016 5:11 am
by gkreidl
Higgs wrote:Wow - great work!

The ability to play a YouTube video so easily (smoothly) in OMXPlayer surmounts one of the biggest usability problems I had with the RPi.

When I taught myself about Arduino, I would go to my PC and watch YouTube videos that helped me learn about it.

Later, when I got my RPi2 - I would go to my PC and watch YouTube videos to help me learn about it.

With the RPi, something always seemed wrong with having to do that....
You could have done the same with kweb even on a RPiB three years ago. This extension adds the same functionality to chromium-browser now.

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Tue May 03, 2016 7:42 pm
by Conork
Hi, ive installed chrome on the pi and the extention, to watch youtube videos, but i cant seem to hear anything? ive tried with the volume and im using HDMI on the Pi 2 B.

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Wed May 04, 2016 6:54 am
by gkreidl
Conork wrote:Hi, ive installed chrome on the pi and the extention, to watch youtube videos, but i cant seem to hear anything? ive tried with the volume and im using HDMI on the Pi 2 B.
check with omxplayer alone and some audio or video file. Do you get sound?

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Thu Oct 13, 2016 8:55 pm
by senten
This was working perfectly for me with Chromium 50 and before updating to Pixel.

But after the update (and on Chromium 51), clicking the rpi-youtube button in the browser does nothing. I tried on youtube and vimeo.

I have the latest omxplayer, youtube-dl and did the git clone and install.sh again also, but no difference.

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Fri Oct 14, 2016 2:37 am
by gkreidl
senten wrote:This was working perfectly for me with Chromium 50 and before updating to Pixel.

But after the update (and on Chromium 51), clicking the rpi-youtube button in the browser does nothing. I tried on youtube and vimeo.

I have the latest omxplayer, youtube-dl and did the git clone and install.sh again also, but no difference.
It's currently broken with the RPF chromium release and I hope kusti8 will manage to fix it.

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Fri Oct 14, 2016 7:18 pm
by lumsdot
is it possible to install omxplayergui on its own

then using xsel and youtube dl it is very easy to watch youtube vids, using any browser

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Sat Oct 15, 2016 1:19 pm
by senten
Yeah as a work-around, this works fine from the command line:

omxplayer -b `youtube-dl -g -f best https://www.youtube.com/watch?v=ZFkwdx5Y6J0`

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Sat Oct 15, 2016 1:38 pm
by lumsdot
the post below gives an easy way to play youtube vids , just by copying the video link from chromium and then clicking on a new icon on the top rasbian/pixel launch bar

viewtopic.php?f=63&t=162850

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Sat Oct 15, 2016 3:43 pm
by gkreidl
If you have installed the kweb suite (omxplayerGUI is needed for rpi-youtube), you have lots of other ways:
1) Copy the URL into the omxplayerGUI frontend and click extract.
2) Run the ytdl-server, open its front page, copy the URL into the first entry field and click the button.
3) From the command line: omxplayergui ytdl URL

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Sat Oct 15, 2016 5:48 pm
by lumsdot
video here of youtube mod in action

https://www.youtube.com/watch?v=3IxEssq_h-A


(had to fake part of it, since my internet connection is so slow i cant play 720p unless I wait for buffer to fill)

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Mon Oct 17, 2016 9:32 am
by gkreidl
As long as kusti8's extension is not working, here's another similar solution:
viewtopic.php?f=66&t=163018

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Fri Dec 01, 2017 12:07 am
by CoWinkKeyDinkInc
When I try typing

Code: Select all

 sudo apt-get install rpi-youtube
, it says that it is unable to find the package so it doesn't install. I have the extension installed on Chrominum, which was preinstalled. What am I missing here?

Re: RPi-youtube, smooth youtube videos on Chromium

Posted: Fri Dec 01, 2017 4:19 am
by gkreidl
CoWinkKeyDinkInc wrote:
Fri Dec 01, 2017 12:07 am
When I try typing

Code: Select all

 sudo apt-get install rpi-youtube
, it says that it is unable to find the package so it doesn't install. I have the extension installed on Chrominum, which was preinstalled. What am I missing here?
This is not supported any more. For a solution that works in any browser, look here: viewtopic.php?f=66&t=193811