Page 1 of 1

A ?rant? about CUPS

Posted: Thu Feb 26, 2015 6:33 pm
by liderbug
So I bring up cups - lh:631
"Here's the printer(s) I see on a USB port"
ah.. yup. that one [Click]
"What driver do you want?"
that one on top [click]
"Go get a cup of coffee, take a nap - because I'm going to load 17,247 driver options from some server on Mars at 19.2" (ya-all have a nice day now)

Grrrrrrrrrrrrrrrrrrrrrrrrrr
And I'm still waiting....

Re: A ?rant? about CUPS

Posted: Fri Feb 27, 2015 6:35 pm
by mrpi64
Bad luck :D .
What printer is it?

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 2:48 am
by liderbug
> What printer?
I've tried: Hp1200, Hp2310, Epson 3540. Cups seems to run at a reasonable speed (click button... new screen). Until it gets to Name:
Model no: etc and is going to list every driver in the world for that manuf. And when I pull the scroll bar down, it pops right back to the top until, 10-15 minutes later the "Select" button shows up. On my laptop or my desktop we're talking 5-10 seconds.

Any help - well once working I won't need to pick a new driver. It's just that this project..... (dont' ask).
cal

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 6:54 am
by fruitoftheloom
liderbug wrote:> What printer?
I've tried: Hp1200, Hp2310, Epson 3540. Cups seems to run at a reasonable speed (click button... new screen). Until it gets to Name:
Model no: etc and is going to list every driver in the world for that manuf. And when I pull the scroll bar down, it pops right back to the top until, 10-15 minutes later the "Select" button shows up. On my laptop or my desktop we're talking 5-10 seconds.

Any help - well once working I won't need to pick a new driver. It's just that this project..... (dont' ask).
cal
You have never stated what Printer you are trying to install, you never stated what Operating System, rather than venting ask for help as CUPS may need additional "Drivers" :roll:

Have you full updated Operating System ?

HP, one can use HPLIP Software instead of CUPS

Canon, Epson, Lexmark, Sony, Olympus, and PCL printers may require Gutenprint

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 12:10 pm
by liderbug
I did state 3 different printers I tried (> What printer?
I've tried: Hp1200, Hp2310, Epson 3540.). The system is 2015-Rasbarian, updated&upgraded. (sorry for not stating that before). Again, when CUPS, at least on my system, says "I see a HP-1200 printer" and proceeds to display drivers for 2805 options (I counted them). Now on my Linux desktop it takes maybe 1 second to create the html code for the "select, option, option, option......" part of the web page. On my RasPi it takes 10 minutes - I timed it - before it finishes and I can "select". Is it just "my" system? or does this happen to others?

Thanks

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 12:16 pm
by DougieLawson
sudo apt-get install hpijs hplip
Those work with my ancient HP6840 wireless printer

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 12:23 pm
by fruitoftheloom
liderbug wrote:I did state 3 different printers I tried (> What printer?
I've tried: Hp1200, Hp2310, Epson 3540.). The system is 2015-Rasbarian, updated&upgraded. (sorry for not stating that before). Again, when CUPS, at least on my system, says "I see a HP-1200 printer" and proceeds to display drivers for 2805 options (I counted them). Now on my Linux desktop it takes maybe 1 second to create the html code for the "select, option, option, option......" part of the web page. On my RasPi it takes 10 minutes - I timed it - before it finishes and I can "select". Is it just "my" system? or does this happen to others?

Thanks
The reason for queerying printer is you have missed out the full name of the printer, it may be why you have many options..

I personally have used HPLIP and CUPS without error, though it is not as speedy as a desktop PC it is "usable", the RPi2 B is a great improvement

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 12:29 pm
by fruitoftheloom
DougieLawson wrote:sudo apt-get install hpijs hplip
Those work with my ancient HP6840 wireless printer
HP Deskjet 6840 :?:

Re: A ?rant? about CUPS

Posted: Sat Feb 28, 2015 1:24 pm
by DougieLawson
fruitoftheloom wrote:
DougieLawson wrote:sudo apt-get install hpijs hplip
Those work with my ancient HP6840 wireless printer
HP Deskjet 6840 :?:
Yes. It's old (15,000 pages on the clock), it's clunky, it doesn't do WPA2, but it spits out double-sided pieces of paper with multi-coloured marks that resemble the documents that I'm trying to print.

It's a ten year old printer.
http://www.cnet.com/uk/products/hp-deskjet-6840/