xxxxxxyxxx
Posts: 3
Joined: Thu Jun 07, 2018 6:51 pm

[Go Ethereum - Geth] Unable to apt-get update and install packages (404)

Thu Jun 07, 2018 7:05 pm

Hey, how are you guys?

I recently started running an Ethereum node (Geth) on a Raspberry Pi 2 following the tutorials provided by Ethembedded.com.

They provide a Raspi2/3 Geth (Go Ethereum) 1.4.10 image. It's an adapted version of Ubuntu Mate and runs fine. I can run the node, interact with it, create accounts, send transactions, etc. Works fine.

But I am experiencing an error everytime I try to apt-get update or install new packages, such as Node.js or Npm. When I try to apt-get update it will wait a long time for headers and in the end it shows me a lot of 404 errors, so I'm unable to update. When I try to install node or npm, it will suggest me to run apt-get update --fix-missing, but the command line returns the same 404 errors, failing to fetch. What am I doing wrong?

There is an old topic about this here in the forum, but I couldn't find a solution there. viewtopic.php?t=18246

Would someone here be able to quickly help me solving this problem?

Best,

User avatar
bob_binz
Posts: 441
Joined: Thu Feb 02, 2012 7:58 pm
Location: Stockport, UK

Re: Unable to apt-get update and install packages (404)

Thu Jun 07, 2018 8:21 pm

With this being a custom image, you're likely to get more relevant assistance on their forum (if they have one).

However, what are the contents of your apt sources file? e.g.

Code: Select all

cat /etc/apt/sources.list

--
BBz

xxxxxxyxxx
Posts: 3
Joined: Thu Jun 07, 2018 6:51 pm

Re: Unable to apt-get update and install packages (404)

Thu Jun 07, 2018 9:08 pm

Hey Bob, how are you? I've posted on the Ethereum Stack Exchange as well, but I don't think there are many people out there running nodes on Rpis. Not a lot of information about this error, at least.

The contents of apt-source:

deb http://ports.ubuntu.com/ wily main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily main restricted universe multiverse

deb http://ports.ubuntu.com/ wily-updates main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily-updates main restricted universe multiverse

deb http://ports.ubuntu.com/ wily-security main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily-security main restricted universe multiverse

deb http://ports.ubuntu.com/ wily-backports main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily-backports main restricted universe multiverse

buteman
Posts: 132
Joined: Tue Jul 03, 2012 9:06 am
Location: Barrow upon Humber

Re: Unable to apt-get update and install packages (404)

Thu Jun 07, 2018 9:09 pm

It may be irrelevant but are you running

Code: Select all

apt-get update
or

Code: Select all

sudo apt-get update
There are few rewards greater than accomplishing a difficult task. Just because something doesn't cost money doesn't mean there is no cost. Every success makes the next one easier. Of course that takes determination and patience.

xxxxxxyxxx
Posts: 3
Joined: Thu Jun 07, 2018 6:51 pm

Re: Unable to apt-get update and install packages (404)

Thu Jun 07, 2018 9:18 pm

Code: Select all

sudo apt-get update

feelslikeautumn
Posts: 307
Joined: Wed Aug 09, 2017 9:51 pm

Re: Unable to apt-get update and install packages (404)

Sat Jun 09, 2018 12:01 pm

xxxxxxyxxx wrote:
Thu Jun 07, 2018 9:08 pm
Hey Bob, how are you? I've posted on the Ethereum Stack Exchange as well, but I don't think there are many people out there running nodes on Rpis. Not a lot of information about this error, at least.

The contents of apt-source:

deb http://ports.ubuntu.com/ wily main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily main restricted universe multiverse

deb http://ports.ubuntu.com/ wily-updates main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily-updates main restricted universe multiverse

deb http://ports.ubuntu.com/ wily-security main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily-security main restricted universe multiverse

deb http://ports.ubuntu.com/ wily-backports main restricted universe multiverse
deb-src http://ports.ubuntu.com/ wily-backports main restricted universe multiverse
Wily (15.10) is not supported any more. That is why you are getting 404 errors.

Return to “Other”