User avatar
teh_orph
Posts: 346
Joined: Mon Jan 30, 2012 2:09 pm
Location: London
Contact: Website

Missing packages

Sat May 19, 2012 11:53 pm

Hi everybody,

does anyone know what's happening or should be done about missing packages in the repositories for arch? People have mentioned this in other threads but there seems to be no public drive to fix this at the source.
There are a number of dependencies for browsers which give 404 when they get fetched, even from different mirrors.

So far I've seen,
- xulrunner
- something for gnome-settings-something (daemon?)
- midori

Anyone know anything?

Spider.007
Posts: 34
Joined: Sat May 19, 2012 11:24 am
Contact: Website

Re: Missing packages

Sun May 20, 2012 12:13 am

I think a better place for this question would be the archlinux forums @ http://archlinuxarm.org/ since missing dependencies are never supposed to happen? What packages (specific) are you missing?

User avatar
teh_orph
Posts: 346
Joined: Mon Jan 30, 2012 2:09 pm
Location: London
Contact: Website

Re: Missing packages

Sun May 20, 2012 8:10 am

xulrunner-1.9.2.15-2-arm.pkg.tar.xz
midori-0.4.5-1-arm.pkg.tar.xz
pulseaudio-1.1-4-arm.pkg.tar.xz

This is what I can confirm right now give 404.

pepedog
Posts: 1043
Joined: Fri Oct 07, 2011 9:55 am

Re: Missing packages

Sun May 20, 2012 8:20 am

Try pacman -Syy first, the the packages again
If that fails, report to https://github.com/archlinuxarm/PKGBUILDs/issues
There is a problem with xulrunner

User avatar
teh_orph
Posts: 346
Joined: Mon Jan 30, 2012 2:09 pm
Location: London
Contact: Website

Re: Missing packages

Sun May 20, 2012 10:56 am

Ah that made a difference - now everything bar xulrunner is a go. (openbox was also 404 too)
Something to note on the package browser on the arch site they only list xulrunner as ARMv7.

pepedog
Posts: 1043
Joined: Fri Oct 07, 2011 9:55 am

Re: Missing packages

Mon May 21, 2012 8:09 am

A lot of work went into xulrunner for arm7hf by Kevin our builder

Return to “Arch”