skiwithpete
Posts: 9
Joined: Sun Sep 25, 2011 8:09 am

text is too wide

Fri Jul 20, 2012 10:31 am

When I first boot Arch, the text is too wide for the screen.

I see:

"i login:"
"word:"

I'm not even at the point of installing X and the screen is too wide. How can I reduce it in size?

//edit: It's also too tall.

Cheers,

P

Notes:
Raspberry Pi
HDMI -> Panasonic TV

User avatar
joan
Posts: 14270
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: text is too wide

Fri Jul 20, 2012 11:13 am

I use composite output to a TV and had a similar problem.

Create a file called config.txt and put it into the /boot directory.

Mine contains
sdtv_mode=0
overscan_left=24
overscan_right=24
You'll need to experiment with the overscan figures.

config.txt is read during boot. If you search the forums you'll find lots of info.

Edited to add: I don't know if overscan is relevant to hdmi displays.

skiwithpete
Posts: 9
Joined: Sun Sep 25, 2011 8:09 am

Re: text is too wide

Fri Jul 20, 2012 11:39 am

Ok, this is what I had to do:

Code: Select all

/boot/config.txt
disable_overscan=0
I was able to open the file, but I couldn't see it. So, I popped out the SD card from the Raspi and stuck it back in my computer and edited it.

Perhaps someone can write a line to enter for users so they don't need to edit the file externally.

Also - it makes sense for future releases to have diasble_overscan=0 as the default setting.

// edit: still need to find a way to make it fit the screen properly, but at least I can see it now.

User avatar
ph0ng
Posts: 38
Joined: Tue Jul 17, 2012 9:37 am
Location: Sweden

Re: text is too wide

Fri Jul 20, 2012 11:41 am

Notes:
Raspberry Pi
HDMI -> Panasonic TV
I use these settings for my Panasonic TX-P50G30Y for perfect screen utilization:

Code: Select all

overscan_left=20
overscan_right=20
overscan_top=10
overscan_bottom=10
(source: http://www.raspberrypi.org/phpBB3/viewt ... 244#p66244)

EDIT: you already found the disable_overscan setting

Return to “Arch”