timl
Posts: 40
Joined: Sat May 04, 2013 3:41 am

freeze

Thu Jun 27, 2013 10:05 pm

Hi, I have configure my Pi as – Pi, powered HDD, LAN cable. Running pidora. I use this Pi solely as a bit torrent client running transmission. I don't have a monitor attached to the Pi so everything is done via SSH from my Fedora box.
I have 2 active sessions – one has “top” running all the time, one has transmission running
ssh -X tim@10.1.1.75 “transmission-gtk”
The Pi locks up sporadically, this means the sessions freeze and I can not access the Pi using “ssh”. I have been trying to isolate the source of the problem: this morning transmission was not up/downloading, I copied a torrent across and opened it in transmission – this caused the Pi to freeze as soon as downloading started. Sometimes though it happens in the middle of the night when transmission is just going about its business. I thought it might be a power issue so I swapped power supplies and I am still experiencing problems.

Any thoughts? dmesg isn't providing any clues?

thanks

portets
Posts: 186
Joined: Sat Oct 29, 2011 6:24 am

Re: freeze

Thu Jun 27, 2013 10:08 pm

I have this same issue. It's happened a couple times when running yum update.

sdjf
Posts: 1395
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: freeze

Mon Jul 01, 2013 1:52 pm

I am experience the same problem, although with a different distribution. Have you paid attention to what is going on with the LEDs? I am ssh'd in via ethernet, it only happens when am online, and the ACT light goes on and stays on, the Ethernet light stays on, but all usb devices and ethernet goes down. Logs in /var/log/ all stop abruptly at that moment. Woke up this morning and it had been frozen for over 5 hours, with the ACT light on and no entries in the logs during this period. Had to unplug everything and Pi finally reset and rebooted itself.
FORUM TIP: To view someone's posting history, sign in, click on their user name, then on "Search User's Posts." || Running ArchLinuxArm on Model 2B and 512MB Model B

timl
Posts: 40
Joined: Sat May 04, 2013 3:41 am

Re: freeze

Wed Jul 03, 2013 3:48 am

this happened again yesterday. I had just loaded up a 2GB torrent and the ssh session froze. I checked the LEDs but they were no different to normal operation. I had "top" running on another window and this looked normal as well.

This time I have connected the HDMI port into the back of a TV. When it freezes again I want to see whether I can still access the Pi directly.

sdjf
Posts: 1395
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: freeze

Thu Jul 04, 2013 5:02 pm

Try changing what is plugged into what port. It may be that some random moments, the power dips too low and some hardware configurations may lessen or increase the chances of that happening.

How many things are plugged in to your Pi? Ethernet does take significant power I think, and that torrent could have put power usage over the edge.

A friend suggested I install cpufreq utilities or something like that, in case this was a power usage issue.

Ah, forgot to mention that I solved my issue by changing what is plugged into what USB port on the Pi around!
FORUM TIP: To view someone's posting history, sign in, click on their user name, then on "Search User's Posts." || Running ArchLinuxArm on Model 2B and 512MB Model B

timl
Posts: 40
Joined: Sat May 04, 2013 3:41 am

Re: freeze

Thu Jul 04, 2013 11:52 pm

thanks sdjf. cpufreq looks a little daunting. I had a quick look on the website and I'll read more.

In my last post I mentioned that I attached the TV screen to the Pi. Anyway when the next "freeze" occurred, the TV screen was blank so I am now happy it is the whole Pi which freezes and not just the ethernet port.

Yesterday it locked up when I was trying to rsync files from my Pi to another PC on my network. Today it locked up downloading a torrent file. So I think your observation about the ethernet port is spot on.

Currently a powered HDD is plugged into the USB port. I am wondering how the balance of power is affected by the device connecting directly to the Pi? IE. Would the presence of a powered USB hub put a bit of a buffer between Pi & HDD?

Cheers

macemoneta
Posts: 59
Joined: Sun Oct 23, 2011 12:47 pm
Contact: Website

Re: freeze

Fri Jul 05, 2013 12:40 am

I have an external powered drive, and discovered that it draws power from the USB port as well. This happens in particular when the drive is spinning up from sleep (which it goes into with no intervention after a few minutes of being idle). I put a 2-Amp powered 4-port hub in between, and the problems I was having (with a desktop) stopped. You may have a similar situation.

timl
Posts: 40
Joined: Sat May 04, 2013 3:41 am

Re: freeze

Sun Jul 07, 2013 9:44 am

Stranger and stranger. I plugged the HDD into a powered USB hub and away we go. Let's be clear about the setup, powered USB HDD plugged into powered USB hub plugged into a USB port on the Pi. Power also being independently supplied to the Pi into the power socket.

After about 36 hours the Pi locked up this time I was using scp to copy a file to another PC while transmission was also running. Although not up/downloading anything. So it looks like the introduction of the USB hub is not solving the problem. :(

The strange bit is when I restarted the Pi. I did my usual trick of pulling out the power cable but it had no effect. Then I powered off the USB hub. Ah, the Pi loses power. Plugged the USB power back in. No power to the Pi, brushed the metal of the power cable against the socket and the Pi leaps into life. So it is getting the power through the USB port?

ogion76
Posts: 1
Joined: Wed Jul 17, 2013 4:22 am

Re: freeze

Wed Jul 17, 2013 8:10 am

I have the same problem. I use 2500 mA adapter to supply my RPi. I connect HDD through powered D-link 7-port USB Hub (it use 3A power supply). When I try to make repository mirror with rsync to USB HDD the system freezes after some time (from several minutes to several hours). I tried to limit download rate by 300 KB/s. After that freezes began to happen less often. But it still happens when large file are downloading. When downloading a large file on the SD card, freezes do not happen, it happens only while downloading on the HDD.

timl
Posts: 40
Joined: Sat May 04, 2013 3:41 am

Re: freeze

Fri Jul 26, 2013 1:27 am

What a difference a week makes. My Pi has now been up for 7 days straight. During this time I have run my torrent client almost constantly. If the client wasn't running it is probably because I was using scp to copy files to other nodes. And the Pi hasn't missed a beat. The only conscious difference is that I halt the client when I am copying files elsewhere. IE. I try to limit activity on the ethernet to one task only. Could this be relevant?

Although I can't remember exactly I think I powered down both Pi & USB Hub prior to restarting. Then restarted the hub then the Pi.

Long may this run continue.

bkeitch
Posts: 1
Joined: Thu Jan 23, 2014 10:30 am

Re: freeze

Thu Jan 23, 2014 10:51 am

Hi,

I am having the same problem. When I plug in the Ethernet cable on a running Pi, the system freezes. So it does seem to be Ethernet using too much power. The lights are flashing showing that the Ethernet is busy. I also had the same problem "hot swapping" USB devices.

I also note that the power regulator gets untouchably hot and stays this hot.

Unplugging the Ethernet and waiting allows the power regulators to return to a normal temperature, but the system is still locked up and requires a power-cycle to return to normal.

texy
Forum Moderator
Forum Moderator
Posts: 5156
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: freeze

Thu Jan 23, 2014 12:42 pm

Hi,
and welcome to the forum,
a fault with the pi can't be ruled out ,but what are you using to power the pi? What is its rating? Are you able to try another power source?

Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

Knightwolf6269
Posts: 1
Joined: Tue Apr 26, 2016 11:51 pm

Re: freeze

Tue Apr 26, 2016 11:55 pm

I to have been random seeing freeze ups from my pi. I'm using kodi to watch TV and movies. Output to my tv and a charger rated for the pi.

Return to “Pidora / Fedora”