Andre-W
Posts: 24
Joined: Fri Jun 01, 2012 1:56 pm

LXDE Keymap

Sat Jun 02, 2012 6:48 am

Hi all,

i have a strange issue with the keymapping within LXDE.
I've configured my keyboard with dpkg and so far everything works well - but only on console.
On console i can use my setuped keymapping (qwertz) and all keyboard keys are detected (including german umlauts) correctly.

But if i start LXDE i discovered an other keymapping (qwerty, german umlauts are not detected). I've googled a bit around but haven't found a working way for correcting this strange behaviour.

Thank you very much for every hint.

Best regards,

André

Stretchdude
Posts: 2
Joined: Wed Jul 11, 2012 8:54 pm

Re: LXDE Keymap

Wed Jul 11, 2012 9:12 pm

Hello,

same problem here with arch. i try to make it more clear
At least I do know now that changing to debian wouldn't help ;-)
With much trying and reading the arch wiki stuff now my keymap is german for some parts:
the symbols with shift+number key are the same as printed on my key.=>fine
but these are lost:
key pressed - sign printed in terminal
ö - ?
ä - ?
ü - ?
ß - ss
| - <
€ - e
@ - q
|, @ and € are done with altGr on german layout (don't know if us layout has that one?)
I can life without äöü but the pipe symbol is really missed.

some config:

Code: Select all

# cat /etc/xdg/lxsession/autostart
@setxkbmap -option -model -layout de -variant de

# cat /etc/lxsession/LXDE/autostart
@setxkbmap -model pc105
@setxkbmap -option 'grp:switch:alt_shift_toggle,grp_led:scroll,eurosign:e' 'de'
...
regards,
Ben

nadir
Posts: 112
Joined: Sun Jun 10, 2012 5:45 am

Re: LXDE Keymap

Wed Jul 11, 2012 11:27 pm

does

Code: Select all

setxkbmap de
help?

The pipe sign should be: shift + '
left to the ä on a German keyboard (ups, not left, right !. Sorry. Same key like #, + the shift).
There are tables at wikipedia, which sometimes help. https://en.wikipedia.org/wiki/Keyboard_layout

Stretchdude
Posts: 2
Joined: Wed Jul 11, 2012 8:54 pm

Re: LXDE Keymap

Thu Jul 12, 2012 6:36 pm

Hello again,
update: I started over again with a bigger sdcard. I'm still in Arch but this is more of a LXDE-Problem so it would not be better located in the Arch-Thread?!
The only line to config keyboard in X now is

Code: Select all

@setxkbmap de   # in /etc/xdg/lxsession/LXDE/autostart

and the stuff in rc.conf (should not care for X)

Code: Select all

LOCALE="de_DE.UTF-8"
...
TIMEZONE="Europa/Berlin"
KEYMAP="de"
...
rest is default
this works a little bit better. I can do @ and | but Ö Ä Ü are still lost and if i want to have thar euro sign i get "EUR" . It seems to me that it may be less of a keymap problem but rather something like the font does no include this creepy german characters?! can I check this in any way? does anyone have a similar problem with other languages?
@nadir: thank you for your answer. That would have only helped if I stay on the us keymap. most of the keys do exactly what they should to do on a german keyboard except the few i mentioned above.
regards,
Ben

johannbrown
Posts: 29
Joined: Sun Aug 05, 2012 4:50 am
Location: de-ffm

Re: LXDE Keymap

Fri Aug 24, 2012 11:52 pm

Since some hours ago I have the same problem with the latest Raspbian Wheezy: I finally managed to get a WLAN adapter to work (plugged into a powered hub and after buying a Belkin N150 because the Sitecom WL113 and the ASUS Wl167g didn't work, with a ****load of different problems) with a Logitech K400 (plugged in the Pi directly). But all of a sudden, the keyboard layout of LXDE isn't set to german anymore. I did NOT change anything! At the console it's still german and eveything works fine but I can't find a way to change it back to german for LXDE, making the whole thing absolutely useless for me. 'setxbkd' does nothing, whatever combination of parameters I use, I only get "Cannot open display "default display"". In the keyboard/mouse options GUI of LXDE there is no option to change the layout. Searching the web up and down doesn't help either, nothing useful.

Oh my, all this Pi hassle ist slowly starting to make me mad and more and more makes me want to crush the Pi under some heavy boots...

Binson
Posts: 8
Joined: Wed Jul 04, 2012 10:27 pm
Location: near Brussels, Belgium

Re: LXDE Keymap

Sat Sep 01, 2012 2:57 am

Hi All !

Am having the same problem as Johann : Belgian keymap (azerty iso qwerty, etc) is used in the console, but as soon as i use X lxde the mapping reverts to qwerty . This is on a fresh install of the official raspbian, with latest updates of firmware, software et al .

I also installed an sd card with pisces MATE R2, did all the updates and upgrades, and Bingo! Qwerty in the GUI . In MATE one can set the keymap in the preferences, but this shows the be(lgian) map duly set .

I can't recall having this problem when i first installed the official raspbian image, few hours after it came out, so it's got to be one of the upgrades to the x innards thats the culprit, hence this mayday call .

If you keep it up, you're going to turn me into a grumpy old man far too soon :mrgreen:

Regards

Binson
=

Binson
Posts: 8
Joined: Wed Jul 04, 2012 10:27 pm
Location: near Brussels, Belgium

Re: LXDE Keymap

Tue Sep 04, 2012 2:03 am

Hi All !

I posted a subject about this in the troubleshooting forum and got a good result . Have a look :

http://www.raspberrypi.org/phpBB3/viewt ... 20#p165520

Hope this helps .

Bye for now .

Binson
=

Return to “Debian”