Page 1 of 1

ROS on Raspberry PI?

Posted: Fri Jan 25, 2013 7:27 pm
by HizMama
Hey guys,

i was wondering if it is possible to run ROS with or w/out ubuntu on Raspberry PI. Thanks in advance! :lol:

Re: ROS on Raspberry PI?

Posted: Fri Jan 25, 2013 9:41 pm
by gritz
If you mean Robot Operating System then I think "Yeah, eventually, sort of..." is somewhere in the ballpark. :)

Some compilation instructions here: http://www.ros.org/wiki/groovy/Installa ... ian/Source

Whopping big thread about it all here: http://www.raspberrypi.org/phpBB3/viewt ... &start=100

Re: ROS on Raspberry PI?

Posted: Fri Jan 25, 2013 10:27 pm
by HizMama
Thanks for the input! I had Raspbian until today but I changed it to Debian since all the code online for installing ROS is for Debian, however, if i type in something like "sudo apt-get install python-rosinstall python-rosdep" the terminal is unable to locate the packages rosinstall and rosdep.

Re: ROS on Raspberry PI?

Posted: Fri Jan 25, 2013 10:35 pm
by HizMama
also, once i type in "sudo apt-get install build-essential python-yam1 cmake subverion wget python-setuptools mercurial git-core" the terminal reads "Unable to locate package python-yam1"

Re: ROS on Raspberry PI?

Posted: Fri Jan 25, 2013 11:00 pm
by gritz
Hi HizMama, I should point out that I know very little about ROS, so I can't really be much help. Perhaps it would be an idea to PM a moderator and ask them to move this thread to the "Automation, sensing and robotics" part of this forum so that knowledgeable folks can weigh in.

Hope this helps. :)

Re: ROS on Raspberry PI?

Posted: Fri Jan 25, 2013 11:24 pm
by Spid
Raspbian is Debian Whhezy 7 ARMv7 and compiled to work the PI ARMv6 architecture, it would be easier to install the latest 16-12-2012 Raspbian “wheezy” the latest version of Debian is seriously out-of-date and should not be used.

Anyway there is a mega-posting about ROS here: http://www.raspberrypi.org/phpBB3/viewt ... =37&t=6552