EverydayDiesel
Posts: 4
Joined: Tue Oct 06, 2015 4:03 am

Waveshare 7" touch screen not working

Tue Oct 06, 2015 4:12 am

Hello,

I have tried everything to get the touch screen part of this waveshare 7" screen to work. I used their image both raspbian and their ubuntu but the touch screen functionality just does not work.

I also tried the raspbian image and installing these drivers http://www.april1985.com/post/2015-06-2 ... uchscreen/ but I still have no luck with the touch functionality

What am I dont wrong here?

Thanks in advance

http://www.waveshare.com/wiki/7inch_HDMI_LCD_(B)

EspenHa
Posts: 4
Joined: Sat Oct 24, 2015 12:26 pm

Re: Waveshare 7" touch screen not working

Sat Oct 24, 2015 12:29 pm

I am considering the Waveshare touch screen. Did you get it to work in the end?

EverydayDiesel
Posts: 4
Joined: Tue Oct 06, 2015 4:03 am

Re: Waveshare 7" touch screen not working

Sat Oct 24, 2015 4:18 pm

working yes. if you are going to use this monitor all the time I would recommend a nicer one (cost about 120+) I will not use it that much so it suits my needs just fine

I used their iso on their disk which has a custom kernel which in turn means that I will not be able to upgrade the distro.
Sometimes the rpi boots and he touch screen part does not work, a reboot fixes it.

EspenHa
Posts: 4
Joined: Sat Oct 24, 2015 12:26 pm

Re: Waveshare 7" touch screen not working

Sun Oct 25, 2015 6:37 am

Ok, thanks for sharing.

pdayries
Posts: 3
Joined: Mon Nov 16, 2015 8:47 am

Re: Waveshare 7" touch screen not working

Mon Nov 16, 2015 8:54 am

Hi all,
I just purchased the 7 inch HDMI Waveshare display to connect to a rapsberry Pi 2. I do not plan to use the touchscreen feature, but only the display feature. The RP was working great on my TV using a HDMI cable (without changing anything in the system). Now when I connect the Waveshare display on the RP, I only get a gray screen after some fancy colored lines crossing slowly the screen. Is there anything to do on the RP? Thought HDMI would be automatically identified by the system (as it was the case for my TV).
Is the monitor faulty or am I doing something wrong? Thank you for your help!

EverydayDiesel
Posts: 4
Joined: Tue Oct 06, 2015 4:03 am

Re: Waveshare 7" touch screen not working

Mon Nov 16, 2015 2:31 pm

It is not faulty, you have to install the drivers that came with the cd for it to work. The touchscreen features (if you want them) will work once you install those drivers.

pdayries
Posts: 3
Joined: Mon Nov 16, 2015 8:47 am

Re: Waveshare 7" touch screen not working

Mon Nov 16, 2015 2:51 pm

Thank you for your reply. But do I have to install a driver just to make the display work?
Is it not supposed to be as simple as a PC monitor or a TV? I thought HDMI was something standard :?
When I plug the RP on my TV it just works!
And I don't need the touchscreen feature.

EverydayDiesel
Posts: 4
Joined: Tue Oct 06, 2015 4:03 am

Re: Waveshare 7" touch screen not working

Mon Nov 16, 2015 2:54 pm

yes you need to install the driver to set the resolution

pdayries
Posts: 3
Joined: Mon Nov 16, 2015 8:47 am

Re: Waveshare 7" touch screen not working

Tue Nov 17, 2015 6:12 pm

No need to install any driver if you just want to display without the touchscreen feature, just add the following lines in the config.txt file, it works:

# set current over USB to 1.2A
max_usb_current=1

# overscan to adjust image position
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0

# HDMI config
hdmi_drive=1
hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87

# 1024x600 display
hdmi_cvt=1024 600 60 3 0 0 0

IIR
Posts: 2
Joined: Tue Apr 19, 2016 5:05 pm

Re: Waveshare 7" touch screen not working

Tue Apr 19, 2016 5:19 pm

You can download and install this rather nice driver which enables the touchscreen functionality and works very well:

https://github.com/derekhe/waveshare-7i ... een-driver

I've found Waveshare's support to be awful, which is a shame as their displays are quite good.

sn4tch3r
Posts: 2
Joined: Mon Jun 24, 2013 11:01 am
Location: Mumbai,India

Re: Waveshare 7" touch screen not working

Fri May 20, 2016 9:58 am

IIR wrote:You can download and install this rather nice driver which enables the touchscreen functionality and works very well:
https://github.com/derekhe/waveshare-7i ... een-driver
Im using Waveshare 1024x600(C) rev1.1 on Raspberry Pi 3 with Raspbian jessie May 2016 build. I would want to know if this source code is compatible with the same.
Also could you provide me links how to build and upload this firmware to my RPi ???

Thanks

AJB2K3
Posts: 215
Joined: Sun Aug 11, 2013 3:25 pm

Re: Waveshare 7" touch screen not working

Sun Jun 12, 2016 7:59 pm

Does this work on the PiZero 1.3?
Back in the old days, we were smarter then the technology.
Nowadays technology makes us look like villages fools in front of the children!

johnnie_john
Posts: 1
Joined: Fri Jun 17, 2016 6:08 am

Re: Waveshare 7" touch screen not working

Fri Jun 17, 2016 6:18 am

Hello.
I have a problem with an waveshare lcd (c) 7 inch hdmi screen, for raspberry.
I am trying to use it with a panasonic gh2, in order to use it as a field monitor. Whatever i do, no image comes to my screen. That is curios, because the screen is advertised as a hdmi compatible product, so i thought that any hdmi device could be coupled without much issues. I do get some sort of signal (white bars and fragments) when i put my camera in playback mode, but other than this nothing.
So, is there a way to make it work? Maybe modifying some settings, stuff like that. Thank you in advance.

AJB2K3
Posts: 215
Joined: Sun Aug 11, 2013 3:25 pm

Re: Waveshare 7" touch screen not working

Fri Jun 17, 2016 7:21 pm

johnnie_john wrote:Hello.
I have a problem with an waveshare lcd (c) 7 inch hdmi screen, for raspberry.
I am trying to use it with a panasonic gh2, in order to use it as a field monitor. Whatever i do, no image comes to my screen. That is curios, because the screen is advertised as a hdmi compatible product, so i thought that any hdmi device could be coupled without much issues. I do get some sort of signal (white bars and fragments) when i put my camera in playback mode, but other than this nothing.
So, is there a way to make it work? Maybe modifying some settings, stuff like that. Thank you in advance.
ssh ing and check config.txt

Im getting this because the setting are screwing up

After editing config.txt using ssh and saving before exit send

sudo shutdown -r now to shut it down.
Wait a few minutes and the pi should restart and work.

now to get the touchscreen to work
so much to learn about ssh
Back in the old days, we were smarter then the technology.
Nowadays technology makes us look like villages fools in front of the children!

AJB2K3
Posts: 215
Joined: Sun Aug 11, 2013 3:25 pm

Re: Waveshare 7" touch screen not working

Sat Jun 18, 2016 8:12 am

Nevermind yup was the mouse.
All working now.



Stupid Question Warning:

Will having a mouse stop the touchscreen from working?

Since I used the driver guide here: https://github.com/derekhe/waveshare-7i ... een-driver

The touchscreen no longer works.
Back in the old days, we were smarter then the technology.
Nowadays technology makes us look like villages fools in front of the children!

wynn_katrina
Posts: 1
Joined: Tue Sep 13, 2016 4:15 am

Re: Waveshare 7" touch screen not working

Tue Sep 13, 2016 4:21 am

The stuff @pdayries posted above worked great. Waveshare 7" with RPi 2b. Thank you very much!

blackzoro
Posts: 24
Joined: Mon Feb 22, 2016 5:27 am

Re: Waveshare 7" touch screen not working

Mon Dec 05, 2016 1:29 am

Hi all,
I just use the 7 inch HDMI Waveshare display to connect to a rapsberry Pi 3.The wavesahre screen is not have any problem, but touch control is not possible normally.

I think that this symptom began to appear from the hit that installed software in various ways around three days ago, but am not sure.

movie
https://youtu.be/K2NBaOFcqeg


It is the contents of the /boot/config.txt

Code: Select all

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.

#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on
dtoverlay=spi1-3cs

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
max_usb_current=1
hdmi_group=2
#hdmi_mode=1
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0
#hdmi_cvt 800 480 60 6 0 0 0

I would like to know the solution to this phenomenon.


Thanks,

Stahl80
Posts: 3
Joined: Thu Dec 31, 2015 6:10 am

Re: Waveshare 7" touch screen not working

Mon Jan 02, 2017 10:23 am

I just installed a fresh copy of retro pie 4.1 and installed the drivers from the link above. The display works and shows the picture correct but touch is not working at all. In retropie 3.xx touch worked with this driver, has anyone got it working in 4.1?

brucef6
Posts: 3
Joined: Wed Dec 28, 2016 10:33 pm

Re: Waveshare 7" touch screen not working

Fri Jan 06, 2017 10:49 pm

Has anyone else had this problem - my Waveshare 7 inch screen turns ON and OFF at a rate of about every 5 to 10 seconds?

I suspect it is a screen hardware problem as it also happens when Raspberry Pi is not connected. I have contacted Waveshare and they are looking into it. Wondering if I am alone in this problem?
Thanks
Regards
Bruce Fisher
Qld, Australia

brucef6
Posts: 3
Joined: Wed Dec 28, 2016 10:33 pm

Re: Waveshare 7" touch screen not working

Sun Jan 08, 2017 8:23 pm

An update - the screen briefly turns on when starting then goes off and doesn't come on again. Seems to be a hardware problem I suspect. waiting response from Waveshare

infrared
Posts: 2
Joined: Tue Jan 10, 2017 6:26 pm

Re: Waveshare 7" touch screen not working

Thu Jan 12, 2017 9:58 pm

Bruce, you are not alone! I have experienced the same or similar problems. After running the WaveShare 7" touchscreen for nearly a week, the back light suddenly started turning off and on.

Like you, I am seeing the back lighting blink off and on when connected to nothing but a power cable. BUT...

After trying several 3A and 4A power supplies to feed the touchscreen and a PiZero, I convinced myself that the LCD panel had a hardware fault in its back light circuitry. I disassembled my project, and made arrangements to return the touchscreen. Just before packaging everything for return shipment, I decided to try the panel one last time. To my surprise, it worked flawlessly... for another 5 days... and then the back light started turning off and on again.

I have now been through this cycle 4 times. Each time, the touchscreen recovers and works flawlessly for 3 to 5 days before the back light begins turning off and on. Disconnecting/reconnecting power to the touchscreen does not help it to recover. The only time it recovers is when I disconnect/re-connect all cables (Pi power, touchscreen power, USB hub, and HDMI). The touchscreen seems to recover completely, and will function again for several days. Weird!

At least in my case, this appears to be a reproducable problem. It feels as though there's a floating ground or capacitance issue causing a charge to build somewhere up before the symptoms manifest. I have no idea how or why it could take several days. Whatever the cause, the unstable state of my back lighting circuitry takes days to develop. Once it develops, the back lighting starts turning off and on every 5 to 10 seconds.

I have tried replacing all the cables, replacing the power supply, replacing the PiZero, replacing the USB hub, and have wiggled everything to check for a mechanical failure. Using hacked USB cables, I have checked voltages and current throughout the USB portions of the circuit, and all readings are within spec. Nothing helps, other than a complete disconnection/re-connection of everything. To me, this implies a system-wide problem, because a complete disconnect of power and HDMI from the touchscreen alone does not help.

My next test will be to attach some 100Kohm resistors between ground and suspect portions of the circuit to see if I can bleed off a stray charge. I will also test for voltage differences between as many different ground points as I can find. Unfortunately, I currently need to wait a few days for the problem to reappear.

brucef6
Posts: 3
Joined: Wed Dec 28, 2016 10:33 pm

Re: Waveshare 7" touch screen not working

Thu Jan 12, 2017 11:00 pm

Thanks for the reply. My problems have become worse. When I apply power I get a screen for about 3 seconds then off forever - until I apply power again. Like you I have tried different power supplies and different cables etc. to no avail. Interestingly, if I touch the back of the screen (top LHS looking at the front, there is a place that when I touch it I get a screen response. Sometimes, when I continue holding the screen stays on - but a bit jumpy. Definitely a hardware problem. I purchased it from Banggood and they have asked me to return it for repair and they will pay the postage - so lets see what happens. In the meantime I have ordered another screen but not a Waveshare.
Regards
Bruce

edus
Posts: 2
Joined: Thu Mar 02, 2017 1:34 am

Re: Waveshare 7" touch screen not working

Thu Mar 02, 2017 1:43 am

Try to comment audio driver in config.txt:
# Enable audio (loads snd_bcm2835)
# dtparam=audio=on
:shock:
Thats works for me!

edus
Posts: 2
Joined: Thu Mar 02, 2017 1:34 am

Re: Waveshare 7" touch screen not working

Thu Mar 02, 2017 4:43 pm

On Raspbian: Unplug and plug in different usb port.
Use "lsusb" to check that "Bus 001 Device 010: ID 0eef:0005 D-WAV Scientific Co., Ltd" is present

atilgansesen
Posts: 1
Joined: Tue Mar 07, 2017 1:32 pm

Re: Waveshare 7" touch screen not working

Tue Mar 07, 2017 1:41 pm

Hello,

When I installed the drivers provided from waveshare, I encountered strange issues.

So I uninstalled the driver.

As described in the link: http://www.waveshare.com/wiki/7inch_HDMI_LCD_(C)

`Write the image to a TF card and append the following lines to the config.txt file which is located in the root of your TF card:

max_usb_current=1
hdmi_group=2
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0
`

Do not install the driver from the waveshare. This works fine for the `Rev2.1 ` this is the one I have.

The touch screen functionality works fine as well.

There is one thing I could not figure out yet.

Single click works fine, how do I do double click?

What do I need it for is that IÉ want to use the touch screen keyboard.

I followed the steps in viewtopic.php?t=14719

So to be able to open it with the touch screen, I created an icon on the desktop.

To open that short cut. How do I double click the icon?

I tap twice, hold it longer, nothing happens

Best Regards

Ati

Return to “HATs and other add-ons”