opiesche
Posts: 2
Joined: Mon Feb 03, 2014 7:45 pm

60/90FPS capture

Mon Feb 03, 2014 7:51 pm

Hi all,

I'm having trouble capturing at more than 30FPS with the regular camera module or the PiNoir hooked up to my Model A. Currently, I'm trying the following:

raspivid -o 60test.h264 -t 9999999 -fps 60 -w 640 -h 480 -b 500000

I've got the camera module pointed at a stopwatch running on my phone. When I play back the resulting video in MPlayer, I can step through frame by frame (by pressing .), and I only get 30 frames per second. If I pass -fps 5, I get a 5FPS video as expected, but it doesn't seem like anything over 30FPS is working. What am I doing wrong?

Thanks!

poing
Posts: 1131
Joined: Thu Mar 08, 2012 3:32 pm

Re: 60/90FPS capture

Mon Feb 03, 2014 8:31 pm

it's not implemented yet.

opiesche
Posts: 2
Joined: Mon Feb 03, 2014 7:45 pm

Re: 60/90FPS capture

Mon Feb 03, 2014 9:02 pm

That explains a lot :P

I hope it's coming soon... we may be able to replace some very expensive cumbersome hardware once that's working :)

Thanks for the reply!

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23366
Joined: Sat Jul 30, 2011 7:41 pm

Re: 60/90FPS capture

Mon Feb 03, 2014 9:08 pm

We are attempting to get it working at the moment - we need to get some information back from Omnivision as the sensor isn't doing what we expect.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

Return to “Camera board”