leofric
Posts: 8
Joined: Sat Jan 11, 2014 9:33 am

issue with raspistill (&vid) saving to mounted network drive

Fri Jan 17, 2014 10:57 am

Hi - been around computers for years but very new to raspberry pi and linux.

Help please - going in circles.

I have mounted the public folder on a wired network Windows PC as PiPics The folder has read/write access.

On the Pi I can browse the contents of the PC folder by cd /mmt/PiPics and see the contents ok.

Nano can write a text file to the windows folder with no problem.

I can't get raspistill to save to it.
Using raspistill -o //mnt/PiPics/test.jpg
or raspistill -o /mnt/PiPics/test.jpg from the root
or if I change to the mmt/PiPics directory and use the same or
raspistill -o test.jpg I get the same error
The error generated is;

mmal: main: error opening output file: test.jpg

Very odd as Nano saves to the drive and raspistill works great on the Pi.
I must be missing something very obvious.

Honsolgen
Posts: 20
Joined: Mon Nov 25, 2013 8:35 am
Location: Honsolgen - Germany
Contact: Website

Re: issue with raspistill (&vid) saving to mounted network d

Fri Jan 17, 2014 12:39 pm

two lines in a shell script
capture the image with raspistill locally
then copy the image to your mounted device

leofric
Posts: 8
Joined: Sat Jan 11, 2014 9:33 am

Re: issue with raspistill (&vid) saving to mounted network d

Fri Jan 17, 2014 4:03 pm

Thanks for the prompt reply.

I could do as you suggest but I don't understand why raspistill can't save directly to the drive as other apps can.

Honsolgen
Posts: 20
Joined: Mon Nov 25, 2013 8:35 am
Location: Honsolgen - Germany
Contact: Website

Re: issue with raspistill (&vid) saving to mounted network d

Fri Jan 17, 2014 4:43 pm

maybe it´s because accessing the user-space filesystem SMB is not implemented within raspistill.

At least I can tell:
I have an sshfs filesystem mounted on my pi. And I just tried it with raspistill.
Works flawless

leofric
Posts: 8
Joined: Sat Jan 11, 2014 9:33 am

Re: issue with raspistill (&vid) saving to mounted network d

Fri Jan 17, 2014 5:09 pm

problem solved .... !
:oops:
I thought I was at the root but wasn't.

sudo raspistill -o /mnt/PiPics/Testpic.jpg

works fine and saves the image directly to the mapped drive on the networked PC.

Return to “Camera board”