timhunderwood
Posts: 13
Joined: Fri Aug 31, 2012 10:42 am

Camera board hanging with red light on

Mon Oct 21, 2013 6:24 pm

Hello,

I set up my camera board and it was working well yesterday. When I tried again today (in a different room) I have run into the following error:

It hangs with the red LED on whenever I run a raspistill command.

Below is the output of raspistill -v. It just hangs at "closing down"

Code: Select all

pi@raspberrypi ~ $ raspistill -v

raspistill Camera App v1.3.4

Width 2592, Height 1944, quality 85, filename (null)
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera stills port to encoder input port
Closing down
Any idea what could be causing this? I wouldn't have thought it was static but I can't rule it out... The only other thing I changed was the power supply (which is now 5V 1000mA).

Help greatly appreciated as I don't know if the problem is with the pi or the camera module....

Thanks!

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23686
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera board hanging with red light on

Mon Oct 21, 2013 7:49 pm

Can you try the other power supply - the camera+pi might be getting close to 1A
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

SnowLeopard
Posts: 106
Joined: Sun Aug 18, 2013 6:10 am

Re: Camera board hanging with red light on

Mon Oct 21, 2013 8:20 pm

My guess is the connectors got loose. I use the camera and wifi on a 2600maH 1A USB battery successfully. The wired wallwart I use is also only 1A and still works adding wired network to wifi and camera.

timhunderwood
Posts: 13
Joined: Fri Aug 31, 2012 10:42 am

Re: Camera board hanging with red light on

Tue Oct 22, 2013 9:29 am

I've switched back to the original power supply and I'm still having the same issue... I've double checked the connections are secure.

Here is some more (similar output if it helps)

Code: Select all

pi@raspberrypi ~ $ raspistill -v -t 10 -o newimage.jpg

raspistill Camera App v1.3.4

Width 2592, Height 1944, quality 85, filename newimage.jpg
Time delay 10, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera stills port to encoder input port
Opening output file newimage.jpg
Enabling encoder output port
Starting capture 0
Is there anything else I should try?

Thanks

User avatar
RaTTuS
Posts: 10459
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Camera board hanging with red light on

Tue Oct 22, 2013 9:41 am

yes the connector is loose - try re-pluggin the cable in - also check the sunney connector
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

timhunderwood
Posts: 13
Joined: Fri Aug 31, 2012 10:42 am

Re: Camera board hanging with red light on

Thu Oct 24, 2013 7:59 am

I have checked the connections ( and reconnected them) to both the pi and the camera multiple times and they seem very secure....

Would anything else cause this error?

Thank you for your help so far.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23686
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera board hanging with red light on

Thu Oct 24, 2013 8:05 am

timhunderwood wrote:I have checked the connections ( and reconnected them) to both the pi and the camera multiple times and they seem very secure....

Would anything else cause this error?

Thank you for your help so far.
A dead camera would show those symptom, but perhaps also power supply. Have you changed the cable?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

kaos
Posts: 108
Joined: Mon Mar 26, 2012 8:14 pm

Re: Camera board hanging with red light on

Thu Oct 24, 2013 12:25 pm

timhunderwood wrote:I have checked the connections ( and reconnected them) to both the pi and the camera multiple times and they seem very secure....
Did you also check the little connector on the camera board itself (usually (always?) marked "sunny")?

dmurphydrtc
Posts: 30
Joined: Tue Jan 29, 2013 5:30 am

Re: Camera board hanging with red light on

Sat Nov 09, 2013 5:22 am

Having same fault myself (red led premanently on after i issue raspistill / vcgencmd get_camera till / . Fortunate that I have 2 Pi's and able to verify the problem was my Pi board and not camera.

Reseated cables , new images / new SD cards, different PSU all to no avail.

can_o_pi
Posts: 4
Joined: Sun Nov 10, 2013 5:26 am

Re: Camera board hanging with red light on

Sun Nov 10, 2013 5:39 am

Thanks for the confirmation, dmurphydrtc. I have the identical problem with my camera and pi, even after exchanging the camera. <Sigh.>

Just for curiosity's sake, what is the date stamp of your pi board with the fault? And timhunderwood, what is your pi date stamp? Mine is 1314... Perhaps this issue may be related to the particular edition/production run of the board?

dmurphydrtc
Posts: 30
Joined: Tue Jan 29, 2013 5:30 am

Re: Camera board hanging with red light on

Mon Nov 11, 2013 7:23 am

Made in the UK ....1312 with a white piece of paper beside SD card that has 15/04

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23686
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera board hanging with red light on

Mon Nov 11, 2013 9:02 am

can_o_pi wrote:Thanks for the confirmation, dmurphydrtc. I have the identical problem with my camera and pi, even after exchanging the camera. <Sigh.>

Just for curiosity's sake, what is the date stamp of your pi board with the fault? And timhunderwood, what is your pi date stamp? Mine is 1314... Perhaps this issue may be related to the particular edition/production run of the board?
There won't be an issue with a particular batch I don't expect - there are all exactly the same.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

can_o_pi
Posts: 4
Joined: Sun Nov 10, 2013 5:26 am

Re: Camera board hanging with red light on

Mon Nov 11, 2013 10:43 pm

Actually, there are plenty of differences between RPis, even within the Model B; see elinux.org/RaspberryPi_Boards, and the related discussion thread.
Of course, there aren't SUPPOSED to be any functional differences between the boards, but sometimes there are. I just thought this camera issue might be related to one of those kinds of differences.

BTW, my full board specs (as per the format in the above URL, because it doesn't appear to be listed on that page) are:

BS1314
RAM = Samsung 325 K4P4G324EB-AGC1 GKDA79ZZU
USB = SMSC LAN9512-JZX 81319-A1B17 31966UA CTI-TW
C6 = 220 CFP. 3G6
F1/F2 = ?/?
RG2 = 17-33G REC18
(SD date stamp = 23/08)
Newark/element14 (Canada)
Last edited by can_o_pi on Mon Nov 11, 2013 11:20 pm, edited 1 time in total.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23686
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera board hanging with red light on

Mon Nov 11, 2013 11:13 pm

can_o_pi wrote:Actually, there are plenty of differences between RPis, even within the Model B; see elinux.org/RaspberryPi_Boards, and the related discussion thread.
Of course, there aren't SUPPOSED to be any functional differences between the boards, but sometimes there are. I just thought this camera issue might be related to one of those kinds of differences.

BTW, my full board specs (as per the format in the above URL, because it doesn't appear to be listed on that page) are:

BS1314
RAM = Samsung 325 K4P4G324EB-AGC1 GKDA79ZZU
USB = SMSC LAN9512-JZX 81319-A1817 31966UA CTI-TW
C6 = 220 CFP. 3G6
F1/F2 = ?/?
RG2 = 17-33G REC18
(SD date stamp = 23/08)
Newark/element14 (Canada)
The only real difference would be ram manufacturer and that can not affect the camera. There are no other relevant differences.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

can_o_pi
Posts: 4
Joined: Sun Nov 10, 2013 5:26 am

Re: Camera board hanging with red light on

Mon Nov 11, 2013 11:24 pm

Have you got any other ideas what the problem might be, jamesh?

donde
Posts: 79
Joined: Sat Feb 18, 2012 3:57 am

Re: Camera board hanging with red light on

Tue Nov 12, 2013 12:18 am

My same trouble cleared when I put on a headband magnifier and reseated flexible ribbon cable and made sure the push down locks really locked. One or both locks can be pulled up easily just by pulling or twisting the cable slightly. This happened to me when I was trying to arrange the cable in certain position.

User avatar
red_mamba
Posts: 40
Joined: Wed Feb 22, 2012 8:49 am

Re: Camera board hanging with red light on

Tue Nov 19, 2013 11:45 am

I'm having the same issue. but only with one camera module. bought two some time back. One is working perfectly, second hangs at "Starting Capture 1" message when using -v parameter.

It hangs just before the preview video should be seen on screen. I will recheck the cable but I'm thinking that the camera module is somehow damaged?

andybirkett
Posts: 17
Joined: Sun Dec 16, 2012 2:13 pm
Location: Lincolnshire, UK
Contact: Website

Re: Camera board hanging with red light on

Tue Nov 19, 2013 12:27 pm

I have a camera that won't work on any Pi and a Pi that won't with any camera and they both show this exact symptom. The Pi that doesn't work is one of the first batch that was sent out by Farnell, I have heard of other early Pi that won't work with the camera module too.

My guess for the OP is that the camera board itself is broken.
--
Andy
http://blog.bitify.co.uk - Interfacing the Pi with various sensors
https://github.com/bitify/raspi - Simple IMU Python library

User avatar
red_mamba
Posts: 40
Joined: Wed Feb 22, 2012 8:49 am

Re: Camera board hanging with red light on

Mon Feb 24, 2014 9:19 am

Mine got replaced by RS where I bought it.

User avatar
theoB610
Posts: 233
Joined: Sat Jan 05, 2013 12:40 pm
Location: Devon

Re: Camera board hanging with red light on

Wed Feb 26, 2014 1:36 pm

I'd recommend you to buy a new camera. I managed to kill two by letting them flop onto the pi, exactly the same issues. Bit of an expensive mistake, so be careful!

Return to “Camera board”