bryanbailes
Posts: 6
Joined: Sat Jul 08, 2017 12:10 am
Contact: Website

Re: UV4L adds support for the TC358743 HDMI to MIPI converte

Sat Jul 08, 2017 12:15 am

I can't seem to get this to work with a B101 and a Pi3. I keep getting "Remote I/O Error". I have tried many different changes of the raspicam config file (but, most importantly setting -tc358743:yes). I have ensured that both the Camera and I2C are enabled. I am not sure what else to try.

RpiName
Posts: 713
Joined: Sat Jul 06, 2013 3:14 am

Re: UV4L adds support for the TC358743 HDMI to MIPI converte

Sat Jul 08, 2017 8:35 pm

bryanbailes wrote:I can't seem to get this to work with a B101 and a Pi3. I keep getting "Remote I/O Error". I have tried many different changes of the raspicam config file (but, most importantly setting -tc358743:yes). I have ensured that both the Camera and I2C are enabled. I am not sure what else to try.
Is the uv4l-raspicam-extras package installed as well? It's required. Furthermore, it's exactly "tc358743 = yes" in the config file or "--tc358743=yes" from command line (I suggest modifying the config file).

bryanbailes
Posts: 6
Joined: Sat Jul 08, 2017 12:10 am
Contact: Website

Re: UV4L adds support for the TC358743 HDMI to MIPI converte

Mon Jul 10, 2017 6:24 pm

Yes, uv4l-raspicam-extras is installed. I have tried both adding tc358743=yes to the config file as well as utilizing the command line argument. I have also been testing the kernel driver being developed by 6by9, and it worked with that, so I know it is not the device. The second I installed uv4l, it stopped working with the 'Remote I/O error'. I have also tried with a clean install of Jessie, with no success.

Code: Select all

pi@raspberrypi:/etc/uv4l $ sudo pkill uv4l
pi@raspberrypi:/etc/uv4l $ sudo apt-get install uv4l-raspicam-extras
Reading package lists... Done
Building dependency tree
Reading state information... Done
uv4l-raspicam-extras is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
pi@raspberrypi:/etc/uv4l $ uv4l --driver raspicam --auto-video_nr --width 720 --height 480 --encoding mjpeg --framerate 60 --tc358743=yes
<notice> [core] Trying driver 'raspicam' from built-in drivers...
<warning> [core] Driver 'raspicam' not found
<notice> [core] Trying driver 'raspicam' from external plug-in's...
<notice> [driver] Dual Raspicam Video4Linux2 Driver v1.9.50 built Jul  2 2017
<notice> [driver] Selected format: 720x480, encoding: mjpeg, JPEG Video Capture
<notice> [driver] Framerate max. 60 fps
<notice> [driver] ROI: 0, 0, 1, 1
<notice> [core] Device detected!
<notice> [core] Registering device node /dev/video0
pi@raspberrypi:/etc/uv4l $ dd if=/dev/video0 of=snapshot.jpeg bs=11M count=1
dd: failed to open ‘/dev/video0’: Remote I/O error

RpiName
Posts: 713
Joined: Sat Jul 06, 2013 3:14 am

Re: UV4L adds support for the TC358743 HDMI to MIPI converte

Mon Jul 10, 2017 11:32 pm

bryanbailes wrote:I installed uv4l, it stopped working with the 'Remote I/O error'. I have also tried with a clean install of Jessie, with no success.
There was a problem with the new debian packages. The following should fix everything:

Code: Select all

sudo apt-get update
sudo apt-get install uv4l-tc358743-extras
double check "tc358743=yes" is set in /etc/uv4l/uv4l-raspicam.conf . Reboot. Retry.


natxo
Posts: 29
Joined: Mon Sep 18, 2017 3:47 pm

Re: UV4L adds support for the TC358743 HDMI to MIPI converter

Tue Oct 31, 2017 6:53 pm

Im trying to use this but not working for me.

Im sure that the auvidea board its working as i can see it with raspivid.

I follow the instructions on https://www.linux-projects.org/uv4l/installation/ and i checked that tc358743=yes its in raspicam.conf.

I did

Code: Select all

dd if=/dev/video0 of=snapshot.jpeg bs=11M count=1
and always get a black 1920x1080 screen...

¿What im doing wrong?

RpiName
Posts: 713
Joined: Sat Jul 06, 2013 3:14 am

Re: UV4L adds support for the TC358743 HDMI to MIPI converter

Tue Oct 31, 2017 11:26 pm

natxo wrote:
Tue Oct 31, 2017 6:53 pm
I did

Code: Select all

dd if=/dev/video0 of=snapshot.jpeg bs=11M count=1
and always get a black 1920x1080 screen...
black? You might need to skip the first frames? Check if you get any video from the streaming server web page in the first place.

natxo
Posts: 29
Joined: Mon Sep 18, 2017 3:47 pm

Re: UV4L adds support for the TC358743 HDMI to MIPI converter

Wed Nov 01, 2017 3:09 pm

Thanks will try what you say and post results

almatthew
Posts: 3
Joined: Tue Mar 13, 2018 8:15 pm

Re: UV4L adds support for the TC358743 HDMI to MIPI converter

Tue Mar 13, 2018 8:19 pm

I'm also getting the "Remote I/O Error" with the tc358743 (B101):

Code: Select all

pi@raspberrypi:~ $ uv4l --driver raspicam --auto-video_nr --width 1280 --height 720 --encoding mjpeg --framerate 60 --tc358743=yes
<notice> [core] Trying to loading driver 'raspicam' from built-in drivers...
<notice> [core] Loading driver 'raspicam' from external plug-in's...
<notice> [driver] Dual Raspicam & TC358743 Video4Linux2 Driver v1.9.60 built Jan  6 2018
<notice> [driver] Selected format: 1280x720, encoding: mjpeg, JPEG Video Capture
<notice> [driver] Framerate max. 60 fps
<notice> [core] Device detected!
<notice> [core] Registering device node /dev/video0
pi@raspberrypi:~ $ dd if=/dev/video0 of=snapshot.jpeg bs=11M count=1
dd: failed to open '/dev/video0': Remote I/O error
I'm using Raspian stretch 2017-11-29 and uv4l is reporting v1.9.60. When not using uv4l (just raspivid) I'm able to get a 720p feed from the B101.

Return to “Camera board”