jacobspades
Posts: 2
Joined: Sat Oct 22, 2016 9:17 pm

Stop Motion

Sat Oct 22, 2016 9:32 pm

I bought the pi camera and followed the instructions for the stop motion animation. When it came time to build the animation from the images by entering the code "avconv -r 10 -qscale 2 -i animation/frame%03d.jpg animation.mp4", all I get is the error message "Option qscale (use fixed quality scale (VBR)) cannot be applied to input file animation/frame%03d.jpg -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to.
Error parsing options for input file animation/frame%03d.jpg.
Error opening input files: Invalid argument".
I've been fighting with it all day. Are these instructions broken? Very frustrated.

jacobspades
Posts: 2
Joined: Sat Oct 22, 2016 9:17 pm

Re: Stop Motion

Sun Oct 23, 2016 4:35 pm

I removed "-qscale 2" and now it works.

User avatar
MattHawkinsUK
Posts: 538
Joined: Tue Jan 10, 2012 8:48 pm
Location: UK
Contact: Website

Re: Stop Motion

Tue Dec 20, 2016 2:36 pm

Changes to avconv (and ffmpeg) can sometimes break previously working commands.

So the guide says :

Code: Select all

avconv -r 10 -qscale 2 -i animation/frame%03d.jpg animation.mp4
but throws the error about qscale. This seems to work on my laptop:

Code: Select all

avconv -r 10 -i animation/frame%03d.jpg -qscale 2 animation.mp4
The qscale setting is an encoder option so sits just before the output file that the encoder will create.

I'll see if I can get someone to update the guide.
My Raspberry Pi blog and home of the BerryClip Add-on board : http://www.raspberrypi-spy.co.uk/
Follow me on Google+, Facebook, Pinterest and Twitter (@RPiSpy)

Return to “Camera board”