grendes
Posts: 1
Joined: Thu Dec 06, 2018 12:39 am

Permission problems with Transmission

Thu Dec 06, 2018 12:41 am

**EDIT: I found a solution through NFS.**

On my Zyxel NAS326 I created a NFS share and gave right to access to it for my whole home network subnet (e.g. 192.168.1.0/24). Mounted the NFS share under /mnt/nfs/ and directed Transmission to download there. Works like charm.

For Plex server, which is running on my Pi 3, I used cifs to mount a share with movies. Cifs share was mounted under /mnt/samba/. I couldn’t be bothered to move all my movies to NFS share as take they up around 1TB.
This setup requires me to move files from share to share, but I have to do that either way, because PLEX separates movies from series and sometimes is very funky with the names.


My fstab looks like this:

nfs

192.168.1.180:/i-data/c12ab007/nfs/Downloads /mnt/nfs nfs user=jamesbond,atime,auto,rw,dev,exec,suid 0 0

cifs

//192.168.1.180/plex /mnt/samba cifs username=jamesbond,password=secretpassword 0 0


---------------------------------------------------------------------------------------------------------------


My goal is to get Transmission running on Pi 3 with VPN and it to use my ZyXel NAS326 as the storage. I’m having problems with permissions.

My main user that I’m using is called “focus” and it should have all permissions needed.
I’ve managed to mount NAS share with no problems. I can create folders there from Pi and access the files already stored there.
Here is proof:
https://i.imgur.com/qw09WY0.png

My fstab line looks like this.

//192.168.1.180/plex/ /mnt/samba cifs username=focus,password=password123 0 0


My NAS also has identical user called “focus” with identical password. That user is an administrator on the NAS and has read/write permissions on “//192.168.1.180/plex/” share.
https://i.imgur.com/GNit8Ap.png


I used this guide to install Transmission:
https://pimylifeup.com/raspberry-pi-torrentbox/

I did couple things differently. I did not set up incomplete directory as I don’t feel like I need it. I also pointed the download directory to my mounted NAS share. As seen here:
https://i.imgur.com/LXrp354.png

Whenever I try start a torrent download I get this error:
https://i.imgur.com/PgUuJl4.png

What I’ve tried (with no results, sadly):

-Adding “uid=1000” to end of fstab entry

-Adding “file_mode=0644,dir_mode=0755” to end of fstab entry

-Adding debian-transmission user to NAS and giving it permissions to “PLEX” folder, even though Transmissions is running under “focus” or atleast I think so. Found this after entering “ps -ef”
https://i.imgur.com/vjRHNVI.png

-Changing share permissions through windows as I have the same share mounted on my PC, but I get permissions denied when I try changing the permissions.


Please help me ☹

Return to “Other projects”