ahsanraza
Posts: 14
Joined: Tue Mar 31, 2015 4:43 pm

VIdeo Streaming using Gstreamer

Tue Dec 08, 2015 6:26 pm

I'm trying to do video streaming over wi-fi network via raspberry pi camera and B+ board. Everything has been setup correctly (finally). but the problem I m facing is I DON'T SEE A VIDEO STREAM :(
these are the responses shown up on the raspberry pi after initiating the gst-launch:

Code: Select all

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
/GstPipeline:pipeline0/GstH264Parse:h264parse0.GstPad:src: caps = video/x-h264, width=(int)960, height=(int)720, parsed=(boolean)true, stream-format=(string)avc, alignment=(string)au, codec_data=(buffer)01640028ffe1000e27640028ac2b40780b7403c489a801000528ee025cb0
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0.GstPad:src: caps = application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, sprop-parameter-sets=(string)"J2QAKKwrQHgLdAPEiag\=\,KO4CXLA\=", payload=(int)96, ssrc=(uint)4067559926, timestamp-offset=(uint)576302327, seqnum-offset=(uint)9900
/GstPipeline:pipeline0/GstUDPSink:udpsink0.GstPad:sink: caps = application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, sprop-parameter-sets=(string)"J2QAKKwrQHgLdAPEiag\=\,KO4CXLA\=", payload=(int)96, ssrc=(uint)4067559926, timestamp-offset=(uint)576302327, seqnum-offset=(uint)9900
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0.GstPad:sink: caps = video/x-h264, width=(int)960, height=(int)720, parsed=(boolean)true, stream-format=(string)avc, alignment=(string)au, codec_data=(buffer)01640028ffe1000e27640028ac2b40780b7403c489a801000528ee025cb0
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0: timestamp = 576302327
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0: seqnum = 9900
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

and this is what I get on windows side after running the receiving command:

Code: Select all

Pipeline is live and does not need a PREROLL ....
Setting pipeline to PLAYING ...
New clock: GstSystemClock


Can anyone tell me where is the issue ? please help I m very much new to Raspberry pi
Tell me and I forget. Teach me and I remember. Involve me and I learn.

User avatar
Defiant
Posts: 179
Joined: Tue Oct 30, 2012 6:17 pm
Location: Hamburg, Germany

Re: VIdeo Streaming using Gstreamer

Thu Dec 10, 2015 5:59 am

Start by posting your pipeline

Return to “Graphics, sound and multimedia”