papous
Posts: 72
Joined: Fri Jan 05, 2018 5:50 am

Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 12:11 pm

Untill a couple of days ago my py 3B was running my robot car module perfectly using pigpio. It would even display the pin status on pyscope.
I then suffered from poor (low) voltage supply to the pi and since then when running the module I get no response from the pins and ESC controller and pyscope does not show any activity on the pins. In fact, running pyscope gives the following errors:
(piscope:902): Gdk-CRITICAL **: gdk_window_create_similar_surface: assertion 'GDK_IS_WINDOW (window)' failed
(piscope:888): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWidget'
(piscope:888): Gtk-CRITICAL **: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed
(piscope:872): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWidget'
(piscope:872): Gtk-CRITICAL **: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed
(piscope:902): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWidget'
(piscope:902): Gtk-CRITICAL **: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed
Is it possible that the pi is destroyed as far as the pins are concerned while my module runs and reports actions OK?
I should note that the pi has its own 5v stable power supply and so does the ESC
How can I further investigate the issue?
Many thanks for taking the time to read and hopefully reply

pcmanbob
Posts: 6451
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 12:30 pm

Its possible that the low voltage condition has resulted in a corruption of your SD card.

I would try flashing another SD card with a fresh copy of raspbian and then reload all your project files or flash the backup copy of the project SD that your made for just such an occurrence to another SD card, then try that and see if your project works ok.

I don't see how a low supply voltage could cause hardware damage.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

papous
Posts: 72
Joined: Fri Jan 05, 2018 5:50 am

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 12:44 pm

Thank you pcmanbob for this very quick reply.
I will do what you suggest but, just out of curiosity, could the card be corrupted and still run the module without problems? And why pyscope does not show pin activity?
Some more info:
I use pigpio throughout the module. Now, from command line I set a pin to high and then I read this pin. Surprisingly I get a LOW reading.
Many thanks again

pcmanbob
Posts: 6451
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 1:31 pm

papous wrote:
Tue Jan 15, 2019 12:44 pm
Thank you pcmanbob for this very quick reply.
I will do what you suggest but, just out of curiosity, could the card be corrupted and still run the module without problems? And why pyscope does not show pin activity?
Some more info:
I use pigpio throughout the module. Now, from command line I set a pin to high and then I read this pin. Surprisingly I get a LOW reading.
Many thanks again
AS we don't know what might be corrupted we don't know how it might affect the system.

I suggested a fresh start or a start from a back up on another SD card because that would eliminate it being a corrupt SD card problem.

You could of course just use a fresh image and write a simple bit of code to change some gpio and watch the output with pyscope to see if your gpio is working.

We need to start some were and as SD card corruption is always a possibility in low voltage situations I suggested that as a first test, if using a fresh copy on another SD card produces the same results then that would eliminate the SD card as being the problem and point to a hardware failure and when problem solving starting from a known good start point is always the way to go.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

papous
Posts: 72
Joined: Fri Jan 05, 2018 5:50 am

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 5:08 pm

I have just realised that the Broadcom chip gets very hot (too hot to touch).
Is it supposed to?

User avatar
DarkPlatinum
Posts: 839
Joined: Thu Nov 02, 2017 2:30 pm
Location: Unknown
Contact: Website YouTube

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 5:14 pm

papous wrote:
Tue Jan 15, 2019 5:08 pm
I have just realised that the Broadcom chip gets very hot (too hot to touch).
Is it supposed to?
It depends. If it is processing a lot of information, it will get hot. Reflash the Raspbian and check to see if you have any problems.
1 * Raspberry Pi Zero W, 1 * Raspberry Pi 2, 1 * Raspberry Pi 3 1 * Raspberry Pi 3B + :mrgreen:

Check Out My Raspberry Site (Run on a Raspberry Pi 3B :) ): https://html.dynu.net

pcmanbob
Posts: 6451
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 5:57 pm

papous wrote:
Tue Jan 15, 2019 5:08 pm
I have just realised that the Broadcom chip gets very hot (too hot to touch).
Is it supposed to?
Try powering your pi with no SD card installed does the chip still get to hot to touch ?

If so then your pi has been damaged probably by some thing you had connected to the gpio.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

papous
Posts: 72
Joined: Fri Jan 05, 2018 5:50 am

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 7:59 pm

Thank you for your replies.
I am for a new pi tomorrow

Brandon92
Posts: 773
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 8:11 pm

papous wrote:
Tue Jan 15, 2019 7:59 pm
Thank you for your replies.
I am for a new pi tomorrow
How did you connect everything to each other. Because, if you connect it not in a good way. Your next Rpi will have the same future
as your old one.

pcmanbob
Posts: 6451
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 8:14 pm

If you pi is faulty then I would check all the external circuits you had connected to the gpio to make sure you are not putting more than 3.3v on to any of the gpio pins, as this would damage your pi gpio and cause the Broadcom chip to get very hot.

Connecting the external circuits to the new pi without checking first could lead to your new pi being damaged in the same way.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

papous
Posts: 72
Joined: Fri Jan 05, 2018 5:50 am

Re: Have I destroyed my pi / my ESC from low voltage?

Tue Jan 15, 2019 8:17 pm

Thank you for the sound advice. I know now what when wrong with my soldering on a proto board. I will try not to repeat that

Return to “Automation, sensing and robotics”