Sonny_Jim
Posts: 45
Joined: Tue Oct 23, 2012 4:15 pm

Setting monitor mode on a wireless device

Mon Sep 16, 2013 5:36 pm

I've ran into a problem trying to get my wireless dongle into monitor mode. It turns out that the problem was due to ifplugd forcing the interface up immediately after I had issued the ifconfig down wlan0 command.

The solution was to disable ifplugd for the interface before trying to enable monitor mode:

Code: Select all

sudo ifplugd -S -i wlan0
sudo ifconfig wlan0 down
sudo iw dev wlan0 set monitor none
Hope this helps.

p.s Reaver 1.4 compiles on the Pi but I've not had a chance to test it fully yet.

robertoprs
Posts: 2
Joined: Sun May 04, 2014 6:01 pm

Re: Setting monitor mode on a wireless device

Mon Aug 18, 2014 5:28 pm

How did you find out ifplugd was turning on the interface? Just curious.

Return to “Networking and servers”