PeterWientjes
Posts: 12
Joined: Mon May 13, 2019 1:33 pm

[SOLVED] PiServer Client (Raspberry Pi 3 model B+) Won't Boot

Mon May 13, 2019 1:53 pm

Hello everyone,

I am working on a school project with some other students. And we are trying to setup a PiServer according to this blog: https://www.raspberrypi.org/blog/piserver/

We have setup a virtual machine in VMWare with the OS "Debian Stretch with Raspberry Pi Desktop" as our PiServer. Connected with a ethernet cable is our Raspberry Pi 3 model B+ which functions as our Client.

We have configured the Client accordingly with the following command:

Code: Select all

echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt
Setting up the PiServer also goes well, the server sees the client with the mac address and gives it an IP address (See images below).

But the problem is that Raspberry Pi 3 model B+ Client is not booting. I Don't see any flickering lights of the ethernet cable or any activity on the Raspberry. Does know the issue and can help us?

Image
Image
Last edited by PeterWientjes on Tue May 14, 2019 8:27 am, edited 1 time in total.

incognitum
Posts: 239
Joined: Tue Oct 30, 2018 3:34 pm

Re: PiServer Client (Raspberry Pi 3 model B+) Won't Boot

Mon May 13, 2019 7:40 pm

1) Your computer seems to have two network cards, eth0 and eth1. Are you sure you selected the right one during Piserver installation?
If not sure, try if selecting the different one under "settings" works better.

The code that is used to detect your Pi when adding it to Piserver listens on all network interfaces, so that part would work even if you accidentally selected the wrong one.

2) Does /var/log/syslog show any messages about dnsmasq failing to start?


BTW the program_usb_boot_mode=1 part is no longer needed for Pi 3+, only for the older Pi 3.

PeterWientjes
Posts: 12
Joined: Mon May 13, 2019 1:33 pm

Re: PiServer Client (Raspberry Pi 3 model B+) Won't Boot

Tue May 14, 2019 8:08 am

First thank you for your reply.

1) eth0 is my WiFi card for having internet on the PiServer and eth1 is bridged to my ethernet port. I have tried both and both are not working.

2) I am getting the following lines in the log file (The first line is repeating).
Image

PeterWientjes
Posts: 12
Joined: Mon May 13, 2019 1:33 pm

Re: PiServer Client (Raspberry Pi 3 model B+) Won't Boot

Tue May 14, 2019 8:27 am

It is solved!! Thank you very much!

The eth1 didn't had a static IP address so the dhcp could not find the raspberrypi.

I have set the eth1 to a static IP address and adjusted the range in the PiServer settings.

Now it will boot thank you!

Return to “Networking and servers”