vatolin
Posts: 17
Joined: Sun Apr 28, 2019 2:56 pm

PHP

Sat May 11, 2019 9:47 am

I've told my Raspi to install the current version of PHP:

Code: Select all

sudo apt-get update && sudo apt-get upgrade php
But as a result now PHP 7.0.33-0+deb9u3 has been installed. That's a really deprecated version. Why apt-get has not installed the current version?

fruitoftheloom
Posts: 19541
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: PHP

Sat May 11, 2019 10:22 am

vatolin wrote:
Sat May 11, 2019 9:47 am
I've told my Raspi to install the current version of PHP:

Code: Select all

sudo apt-get update && sudo apt-get upgrade php
But as a result now PHP 7.0.33-0+deb9u3 has been installed. That's a really deprecated version. Why apt-get has not installed the current version?

Raspbian being a fork of Debian ARMHF follows Debian's Policy of stable packages with security updates, not latest and greatest.

Though Raspbian Buster will have newer packages when eventually released.


viewtopic.php?f=66&t=237868
adieu

My other Computer is an Asus CS10 ChromeBit running Chrome Operating System.
HP Envy 4500 Wireless Printer supported by HPLIP software in Raspbian Buster.
Raspberry Pi Model 2B v1.1

Return to “Networking and servers”