xXAzazelXx
Posts: 131
Joined: Tue Sep 18, 2012 8:32 am
Location: Australia
Contact: Website

Openvpn - openvpn@server.service: Main process exited, code=killed, status=9/KILL

Wed Dec 05, 2018 7:18 am

Hey Guys,

Is anyone else having issues with Openvpn not starting?

It appears that service "openvpn" starts with no issues but "openvpn@server.service" fails.

openvpn@server.service:

Code: Select all

pi@RaspberryPi:~ $ systemctl status openvpn@server.service
● openvpn@server.service - OpenVPN connection to server
   Loaded: loaded (/lib/systemd/system/openvpn@.service; disabled; vendor preset: enabled)
   Active: failed (Result: signal) since Wed 2018-12-05 18:06:24 AEDT; 10min ago
     Docs: man:openvpn(8)
           https://community.openvpn.net/openvpn/wiki/Openvpn23ManPage
           https://community.openvpn.net/openvpn/wiki/HOWTO
  Process: 484 ExecStart=/usr/sbin/openvpn --daemon ovpn-server --status /run/openvpn/server.status 10 --cd /etc/openvpn --config /etc/openvpn/server.conf --writepid /run/openvpn/server.pid (code=exited, status=0/SUCCESS)
 Main PID: 545 (code=killed, signal=KILL)

Dec 05 18:06:10 RaspberryPi ovpn-server[545]: UDPv4 link local (bound): [AF_INET][undef]:1194
Dec 05 18:06:10 RaspberryPi ovpn-server[545]: UDPv4 link remote: [AF_UNSPEC]
Dec 05 18:06:10 RaspberryPi ovpn-server[545]: GID set to nogroup
Dec 05 18:06:10 RaspberryPi ovpn-server[545]: UID set to nobody
Dec 05 18:06:10 RaspberryPi ovpn-server[545]: MULTI: multi_init called, r=256 v=256
Dec 05 18:06:10 RaspberryPi ovpn-server[545]: IFCONFIG POOL: base=10.8.0.2 size=252, ipv6=0
Dec 05 18:06:10 RaspberryPi ovpn-server[545]: Initialization Sequence Completed
Dec 05 18:06:24 RaspberryPi systemd[1]: openvpn@server.service: Main process exited, code=killed, status=9/KILL
Dec 05 18:06:24 RaspberryPi systemd[1]: openvpn@server.service: Unit entered failed state.
Dec 05 18:06:24 RaspberryPi systemd[1]: openvpn@server.service: Failed with result 'signal'.
openvpn

Code: Select all

pi@RaspberryPi:~ $ systemctl status openvpn
● openvpn.service - OpenVPN service
   Loaded: loaded (/lib/systemd/system/openvpn.service; enabled; vendor preset: enabled)
   Active: active (exited) since Wed 2018-12-05 18:06:14 AEDT; 11min ago
  Process: 677 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 677 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/openvpn.service

Dec 05 18:06:14 RaspberryPi systemd[1]: Starting OpenVPN service...
Dec 05 18:06:14 RaspberryPi systemd[1]: Started OpenVPN service.

I can manually start it after, but I would like it to automatically startup :( Do i need to make a cronjob?

Return to “Networking and servers”