Page 1 of 1

Pi 0w usb to LAN failure

Posted: Wed Oct 31, 2018 7:00 am
by 100xyz
Hi,

I have a Pi W0 and connected a USB to RJ45 cable, which then connects to LAN. Things were working very well.

Then I created another image. In this one the LAN is not found by the system at all. How would I go about debugging this or narrowing it down.

Thanks.

Re: Pi 0w usb to LAN failure

Posted: Wed Oct 31, 2018 7:26 am
by rpdom
Did you use the same image file for both cards?

Have you got keyboard and screen access to the Pi? If so, what does lsusb show? (that's lower case LSUSB). It should show if your network device is recognised by Raspbian.

For example, on one of my 0's:

Code: Select all

pi@raspi10:~ $ lsusb
Bus 001 Device 004: ID 0fe6:9700 Kontron (Industrial Computer Source / ICS Advent) DM9601 Fast Ethernet Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
As you can see, on that Pi I am using a dodgy DM9601 adapter (no hub or keyboard, purely headless).

Re: Pi 0w usb to LAN failure

Posted: Wed Oct 31, 2018 7:49 am
by 100xyz
Used almost the same image. Im changing some dnsmasq configuration, but other than that, its the same.

The wifi comes up, so I am able to ssh into it.

lsusb gives me only one entry:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Re: Pi 0w usb to LAN failure

Posted: Wed Oct 31, 2018 8:00 am
by 100xyz
The image was created in a Raspberry Pi 3 and then used in a Pi 0W. Would that affect it somehow?

Re: Pi 0w usb to LAN failure

Posted: Wed Oct 31, 2018 8:17 am
by 100xyz
Having the following errors in syslog:

Oct 31 02:28:13 100 kernel: [ 1.842957] usb 1-1: device descriptor read/64, error -71
Oct 31 02:28:13 100 kernel: [ 1.963119] Indeed it is in host mode hprt0 = 00001101
Oct 31 02:28:13 100 kernel: [ 2.172999] usb 1-1: new high-speed USB device number 3 using dwc_otg
Oct 31 02:28:13 100 kernel: [ 2.181370] Indeed it is in host mode hprt0 = 00001101
Oct 31 02:28:13 100 kernel: [ 2.402947] usb 1-1: device descriptor read/64, error -71
Oct 31 02:28:13 100 kernel: [ 2.523498] Indeed it is in host mode hprt0 = 00001101
Oct 31 02:28:13 100 kernel: [ 2.732955] usb 1-1: device descriptor read/64, error -71

Re: Pi 0w usb to LAN failure

Posted: Wed Oct 31, 2018 9:47 pm
by 100xyz
Hi,
Looks like its a hardware failure. The same image works on another Pi0W.
Thanks for looking.