Hexark
Posts: 12
Joined: Sat Jul 28, 2012 4:03 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Sun Feb 17, 2013 2:43 am

Now, create a new patch file, e.g. nx_3.5.0.patch with the following context:

how do you create a new patch file? Tried googling, but i dun uds.

SoliDeoGloria
Posts: 5
Joined: Mon Jan 28, 2013 4:24 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Sun Feb 17, 2013 8:04 pm

Can't remember exactly what I did, as I had trouble here too, but here are a few commands from my pi history. Pretty sure these did something useful:

patch < gentoo-nomachine.diff
patch --ignore-whitespace < nx_3.5.0.patch

The ignore whitespace bit was necessary for me. It would fail to patch without it. Hope this helps!

Giddeon
Posts: 3
Joined: Thu Feb 21, 2013 12:37 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Thu Feb 21, 2013 12:47 am

Hi,

I have followed the instructions to the letter and seem to have installed all of those NX-11 components and the freenx thing itself. The problem I'm having is that I cannot tell if anything is running on the Pi or if i need to run something. No idea where to look for that.
It does seem to be running because from the windows client it will connect, authenticate (I'm using 'pi:raspberry' as my login credentials) and seems to start but a command window briefly pops up and disappears and then a red window appears for just a moment (seems to have the logo on it) and then it's just gone!

I've changed the setting to 'KDE' and found and edited the config file to "startlkde" like someone else suggested, although my config file isn't in the same place i think. Still nothing. I tried to run the keymaker thing in the freenx directory thinking it might be a security thing but it says it isnt there! I used the 'default' key when I 'installed' the thing and it seems to authenticate so that doesnt matter?

As you can tell, i'm very new and very confused. I know very few linux conventions it seems and i'm pulling my hair out. I thought if i just followed the instructions it would work and it doesn't. Does anyone feel like helping me out at all?

LowOnPancakes
Posts: 4
Joined: Mon Feb 11, 2013 12:54 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Sat Mar 02, 2013 6:00 pm

SoliDeoGloria wrote:I think I may have had the same problem as you at some point, but I can't remember what I did to rectify the situation. Try this and tell me how it works. In the connection setting in the area mark desktop choose unix in the first list box, custom in the second and then hit the setting button in the same area. Then in the application area choose "Run the following command" and for the command put "/usr/bin/lxterminal" (without quotes). In the same window make sure the "floating window" option is checked. Hit okay on everything and try connecting.

Hope this helps!
Thanks SoliDeoGloria. I just tried it and it looks like I'm almost there now. I now get a window to open, but after playing around with it looks like it is missing a font package (I think). There are what appear to be 4 menu buttons in the upper left, though they look like different length underscores. When I click on them, I get drop down menus that have some symbols next to them, like what I think are copy, paste, forward and back arrows, and a star. Unfortunately, the desktop itself just appears black.

Thanks for the help. Do you have any other suggestions for what I think is a missing font package?

I've attached an image of the window that now opens.
Attachments
NX_client_problem.jpg
NX_client_problem.jpg (19.36 KiB) Viewed 4558 times

evberghe
Posts: 2
Joined: Mon Mar 04, 2013 4:08 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Mon Mar 04, 2013 4:28 pm

I seem to have successfully compiled the nx components and freenx; I can run nxsetup for example. nxsetup --test returns, after warnings that some session types will not be available, a 'Fatal error: could not connect to NX server. Please check your ssh setup', followed by a list of suggestions of what to check. As far as I can see, ssh is doing fine, and I can log in as nx from a remote console (using PuTTy), using a key pair generated using nxkeygen to authenticate. When I am trying to run the NoMachine client, I am getting the following output:

NX> 203 NXSSH running with pid: 5452
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.1.5 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Apparently user nx can't authenticate with its key pair here?

Higher up in this conversation, people referred to the need for 'copying a key'. Which key, to where? Did I miss something here?

Help would be greatly appreciated!

SoliDeoGloria
Posts: 5
Joined: Mon Jan 28, 2013 4:24 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Mon Mar 04, 2013 7:37 pm

LowOnPancakes wrote:
SoliDeoGloria wrote:I think I may have had the same problem as you at some point, but I can't remember what I did to rectify the situation. Try this and tell me how it works. In the connection setting in the area mark desktop choose unix in the first list box, custom in the second and then hit the setting button in the same area. Then in the application area choose "Run the following command" and for the command put "/usr/bin/lxterminal" (without quotes). In the same window make sure the "floating window" option is checked. Hit okay on everything and try connecting.

Hope this helps!
Thanks SoliDeoGloria. I just tried it and it looks like I'm almost there now. I now get a window to open, but after playing around with it looks like it is missing a font package (I think). There are what appear to be 4 menu buttons in the upper left, though they look like different length underscores. When I click on them, I get drop down menus that have some symbols next to them, like what I think are copy, paste, forward and back arrows, and a star. Unfortunately, the desktop itself just appears black.

Thanks for the help. Do you have any other suggestions for what I think is a missing font package?

I've attached an image of the window that now opens.
Unfortunately, you are now experiencing the same problem as others and myself. I can tell you the problem has something to do with libcairo and gtk applications. The problem goes away if you connect with a linux client. If you use a desktop that isn't dependant upon gtk it also works, but the one I tried using was super slow. I wish someone with more knowledge than me would provide input, but it seems this thread is flying under the radar.

LowOnPancakes
Posts: 4
Joined: Mon Feb 11, 2013 12:54 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Tue Mar 05, 2013 5:13 am

SoliDeoGloria wrote:
LowOnPancakes wrote:
SoliDeoGloria wrote:I think I may have had the same problem as you at some point, but I can't remember what I did to rectify the situation. Try this and tell me how it works. In the connection setting in the area mark desktop choose unix in the first list box, custom in the second and then hit the setting button in the same area. Then in the application area choose "Run the following command" and for the command put "/usr/bin/lxterminal" (without quotes). In the same window make sure the "floating window" option is checked. Hit okay on everything and try connecting.

Hope this helps!
Thanks SoliDeoGloria. I just tried it and it looks like I'm almost there now. I now get a window to open, but after playing around with it looks like it is missing a font package (I think). There are what appear to be 4 menu buttons in the upper left, though they look like different length underscores. When I click on them, I get drop down menus that have some symbols next to them, like what I think are copy, paste, forward and back arrows, and a star. Unfortunately, the desktop itself just appears black.

Thanks for the help. Do you have any other suggestions for what I think is a missing font package?

I've attached an image of the window that now opens.
Unfortunately, you are now experiencing the same problem as others and myself. I can tell you the problem has something to do with libcairo and gtk applications. The problem goes away if you connect with a linux client. If you use a desktop that isn't dependant upon gtk it also works, but the one I tried using was super slow. I wish someone with more knowledge than me would provide input, but it seems this thread is flying under the radar.
Well, thanks SoliDeoGloria for at least confirming that I have things setup per the install steps.

LowOnPancakes
Posts: 4
Joined: Mon Feb 11, 2013 12:54 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Tue Mar 05, 2013 5:17 am

evberghe wrote:I seem to have successfully compiled the nx components and freenx; I can run nxsetup for example. nxsetup --test returns, after warnings that some session types will not be available, a 'Fatal error: could not connect to NX server. Please check your ssh setup', followed by a list of suggestions of what to check. As far as I can see, ssh is doing fine, and I can log in as nx from a remote console (using PuTTy), using a key pair generated using nxkeygen to authenticate. When I am trying to run the NoMachine client, I am getting the following output:

NX> 203 NXSSH running with pid: 5452
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.1.5 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Apparently user nx can't authenticate with its key pair here?

Higher up in this conversation, people referred to the need for 'copying a key'. Which key, to where? Did I miss something here?

Help would be greatly appreciated!
I am trying to use the No Machine client. In the "configure..." menu, under the general tab, there is a "key..." button. I used the default option and it seemed to work for me.

evberghe
Posts: 2
Joined: Mon Mar 04, 2013 4:08 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Tue Mar 05, 2013 1:01 pm

LowOnPancakes wrote:
evberghe wrote:I seem to have successfully compiled the nx components and freenx; I can run nxsetup for example. nxsetup --test returns, after warnings that some session types will not be available, a 'Fatal error: could not connect to NX server. Please check your ssh setup', followed by a list of suggestions of what to check. As far as I can see, ssh is doing fine, and I can log in as nx from a remote console (using PuTTy), using a key pair generated using nxkeygen to authenticate. When I am trying to run the NoMachine client, I am getting the following output:

NX> 203 NXSSH running with pid: 5452
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.1.5 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Apparently user nx can't authenticate with its key pair here?

Higher up in this conversation, people referred to the need for 'copying a key'. Which key, to where? Did I miss something here?

Help would be greatly appreciated!
I am trying to use the No Machine client. In the "configure..." menu, under the general tab, there is a "key..." button. I used the default option and it seemed to work for me.
Thanks!
I'm also using the NoMachine client. From the way the form is organised, I assumed the key was the key of the nx client, not of the nx server. Adding the server key solves the authentication problems. Unfortunately, I seem to be now in the same situation as others who have commented here: I get a nice GUI, but with all the text missing.

sjoerd
Posts: 2
Joined: Mon Feb 25, 2013 8:08 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Fri Apr 19, 2013 11:27 am

mdroberts1243 wrote:Thank-you Caldimerda!
After the installation, my clients - nomachine or openNX - did not work using the xdm or custom options. As far as I can see the freenx server can't find an appropriate X window manager corresponding with these session options, no matter what I did on either client or server (I wonder if the OP has installed xdm?) Anyway - after a *lot* of searching and not finding an answer, I simply changed the kde start command in /var/NX/etc/node.conf from startkde to startlxde and then told my client to use kde. It works so far.
Worked for me too!
-mark.
Worked for me too :)

-sjoerd

markgutel
Posts: 4
Joined: Sun Apr 28, 2013 9:10 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Sun Apr 28, 2013 9:47 pm

I got it working. I am typing this from an OpenNX client on a windows machine on my Pi server.

First I followed the advice from the first post:

http://www.tiaowiki.com/w/Install_NX_Se ... spberry_Pi

I did the update command as listed, but after that I added

sudo apt-get upgrade

this one takes a while, and I can't say it's necessary, but I did it.

from there I followed the directions as written. When it came to making the nxcompext file though, I got weird errors about defined variables.

I saw the earlier advice from this thread about just skipping to make World, and did that, skipping compiling any other individual packages.

The first patch went fine, the second, however, I only got a error at 606 or something. So I skipped it.

I began to copy the various files to their various locations and got a missing file error copying nxproxy. Turns out it hadn't been compiled, so I did so. Then I copied the file to the right location.

From then I followed the instructions. I did get an extra error about version numbers during the middle of the install.

I changed the node.conf file in two ways. 1. the md5sum change from the instructions. 2. I changed the kde command to lxde as given in the thread above.

From there I tried to connect. The OpenNX client brought up a window for a second and it went off. Of course I configured it to use xdmcp as pictured.

Then I tried the nomachine client selecting kde. It connected but I didn't get any text like others have mentioned.

All I did was change the font in Openbox configuration manager from sans to serif. I kept the point size and bold settings the same.

Then I got no desktop with the nomachine client just an error. I tried OpenNX again, and it's working now. I went back to nomachine client and it connected again, but still with no fonts. But OpenNX is still good. I guess we'll see if it keeps working.

Think of this as a case study rather than definite instructions, but it's currently working for me.

ps. to the poster above complaining about vnc or rdp not going through port 22, you can setup port forwarding in your ssh client and tunnel vnc or rdp traffic through ssh.

skinlee78
Posts: 2
Joined: Mon Apr 29, 2013 1:57 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Sun May 05, 2013 9:34 am

Why you all edit some config file while it is possible to simply change the start command within the nomachine client itself.

Configure > (Desktop) Unix | Custom > (Desktop) Settings > Select: Run the following command > startlxde and your ready to go.

trevorjharris
Posts: 8
Joined: Thu May 30, 2013 10:55 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Thu May 30, 2013 11:07 pm

I suddenly found that my nxserver stopped working. This was due to a Debian update which removed _XGetRequest from libXfixes.so* causing nxagent to crash. A simple fix is to copy the nx-X11/lib/Xfixes/libXfixes.so* built during the nx build to /usr/NX/lib.

I also had the font problem with nxclient but opennx works ok.

alexlittle
Posts: 3
Joined: Tue Jan 15, 2013 10:37 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Mon Jun 17, 2013 7:22 pm

Hi,

I'm having some issues getting this up and running on my Raspberry Pi. I can get everything installed ok, but then when I try to connect, after authenticating etc and after the "Established the display connection" message, I then get the message "The connection with the remote server was shut down. Please check the state of your network connection" - but no other detail/info as to exactly what is going wrong.

Does anyone have any ideas what I should look at (log files etc?) to see where the problem is? I'm connected via wireless to my Pi and the network connection seems fine - so I wonder if this message is masking something else?

Any help much appreciated,
Alex

alexlittle
Posts: 3
Joined: Tue Jan 15, 2013 10:37 pm

Re: Remote Desktop to Pi - How to install NXServer on Pi

Mon Jun 17, 2013 9:53 pm

Ah - got it now. I had to copy over the nx-X11/lib/Xfixes/libXfixes.so* files as suggested above: http://www.raspberrypi.org/phpBB3/viewt ... 06#p360706

Seems to be working well,

A

slm
Posts: 1
Joined: Thu Aug 22, 2013 9:50 am

Re: Remote Desktop to Pi - How to install NXServer on Pi

Thu Aug 22, 2013 9:55 am

I found I also had to put a libXcomposite.so that lacked XGetReq into /usr/NX/lib as well.

You can dpkg -x <filename.deb> . to get them from the old rapsbian wheezy libxcomposite1_0.4.3-2_armhf.deb and libxfixes3_5.0-4_armhf.deb worked for me (now running jessie) if you don't your nx source tree handy.

Return to “Networking and servers”