ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

XBMC Reboots When Playing Movie

Tue Jun 10, 2014 10:54 pm

Hello,
I've been trying to play a m4v movie from iTunes but as soon as I press play, XBMC reboots. I have tried this with other movies from iTunes but they all act the same. I've tried this on RaspBMC and OpenELEC versions Frodo and Gotham. I have also googled it but I still can't get it working.
Please help me!

HiroProtagonist
Posts: 212
Joined: Sat Jun 29, 2013 9:45 am

Re: XBMC Reboots When Playing Movie

Wed Jun 11, 2014 5:19 am

ejj28 wrote:Please help me!
There's a good chance this is a power supply problem, which you should find has been covered in detail in a lot of threads.
Short version: Get a good PSU that gives you at least 5.0V [measured at TP1 & TP2 under load]. Power all peripherals via a powered USB hub. There are a lot of rubbish power supplies out there.

ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

Re: XBMC Reboots When Playing Movie

Thu Jun 12, 2014 11:01 pm

There's a good chance this is a power supply problem, which you should find has been covered in detail in a lot of threads.
Short version: Get a good PSU that gives you at least 5.0V [measured at TP1 & TP2 under load]. Power all peripherals via a powered USB hub. There are a lot of rubbish power supplies out there.
Thanks,
I tried again with a power supply than had 5V 700mA but I still had the same problems.
If it helps, the movie size is 1.54 Gigabytes.

masterluke
Posts: 200
Joined: Tue Apr 17, 2012 4:10 pm

Re: XBMC Reboots When Playing Movie

Fri Jun 13, 2014 2:47 pm

700mA is a bit tight particularly if you have anything connected by USB. I use a 1500mA.

ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

Re: XBMC Reboots When Playing Movie

Thu Jun 19, 2014 5:34 pm

Ok,
I got ahold of an 2100 mA PSU.
I'll try again.

ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

Re: XBMC Reboots When Playing Movie

Thu Jun 19, 2014 6:04 pm

Tried it with the 2100 mA PSU, still reboots.
Since masterluke recommended 1500 mA and I'm way above that, I don't think that the problem is the PSU.
Any other ideas?
Thanks!

User avatar
GTR2Fan
Posts: 1601
Joined: Sun Feb 23, 2014 9:20 pm
Location: South East UK

Re: XBMC Reboots When Playing Movie

Thu Jun 19, 2014 6:19 pm

There's no way of knowing whether the higher current rated PSU is providing 5V or not without actually measuring it with the Pi running.
Pi2B Mini-PC/Media Centre: ARM=1GHz (+3), Core=500MHz, v3d=500MHz, h264=333MHz, RAM=DDR2-1200 (+6/+4/+4+schmoo). Sandisk Ultra HC-I 32GB microSD card on '50=100' OCed slot (42MB/s read) running Raspbian/KODI16, Seagate 3.5" 1.5TB HDD mass storage.

ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

Re: XBMC Reboots When Playing Movie

Thu Jun 19, 2014 10:51 pm

Hi,
How do you measure it with the pi running?

HiroProtagonist
Posts: 212
Joined: Sat Jun 29, 2013 9:45 am

Re: XBMC Reboots When Playing Movie

Fri Jun 20, 2014 12:04 am

ejj28 wrote:Hi,
How do you measure it with the pi running?
Use a digital voltmeter & measure the voltage between TP1 & TP2 while the pi is running. This is the only way of being 100% sure your power is good.
Also make sure you're not powering USB devices via the pi.

ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

Re: XBMC Reboots When Playing Movie

Wed Jul 30, 2014 2:55 pm

Hi,
I am trying to run the movie off a flash drive, so I tried copying the movie over to the SD card, however I cannot figure out how to copy/paste the file from the flash drive to the filesystem.
I also tried running Raspbian and copying the file to the SD card so I could run it in omxplayer, but it gave me an error saying that "There wasn't enough memory" to copy it over.
My SD card is 8 gigabytes so I don't understand why it won't copy.
Does anyone know why this is? :?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25020
Joined: Sat Jul 30, 2011 7:41 pm

Re: XBMC Reboots When Playing Movie

Wed Jul 30, 2014 3:08 pm

Once Raspbian is installed, use

sudo raspi-setup

and select the expand filesystem option to use the whole SD card.]

If using NOOBS, there is an option to expand at some point in the install - cannot remember where.

Although your problem might be a bad USB power lead - even a good power supply can still result in power problems if the USB cable is rubbish,
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

drgeoff
Posts: 10231
Joined: Wed Jan 25, 2012 6:39 pm

Re: XBMC Reboots When Playing Movie

Wed Jul 30, 2014 4:28 pm

ejj28 wrote:Hi,
I also tried running Raspbian and copying the file to the SD card so I could run it in omxplayer, but it gave me an error saying that "There wasn't enough memory" to copy it over.
My SD card is 8 gigabytes so I don't understand why it won't copy.
Does anyone know why this is? :?
Almost all (and Raspbian is definitely one of them) RPi SD cards have more than one partition. There is a boot partition of size around 60 Mbytes and the boot files in there use use about half of that. The main Linux files are in the remainder of the card. The boot partition uses a FAT filing system. The large partition(s) use an ext type favoured by Linux.

MS Windows can only see into the FAT partition. It doesn't understand the file system in the other partition(s) of the SD card. It may even offer to "repair" the SD card when you plug it in to a Windows PC.

So when you tried to copy files to the SD card, your PC reckoned there was only a few Mbytes of free space on the card.

ejj28
Posts: 19
Joined: Tue Jun 10, 2014 10:28 pm

Re: XBMC Reboots When Playing Movie

Wed Feb 25, 2015 12:17 am

Okay,
I got a PiHub for Christmas and used it to plug in a external hdd with my movies on it.
The movies still wouldn't play, so I googled it and found out that my movies (which are from the iTunes store) are protected and won't play on anything not authorized by apple.
I guess there's nothing I can do to fix that.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5398
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: XBMC Reboots When Playing Movie

Wed Feb 25, 2015 1:12 pm

ejj28 wrote: I got a PiHub for Christmas and used it to plug in a external hdd with my movies on it.
The movies still wouldn't play, so I googled it and found out that my movies (which are from the iTunes store) are protected and won't play on anything not authorized by apple.
I guess there's nothing I can do to fix that.
You can petition Apple to remove DRM on their videos (they used to apply it to music, and no longer do).
But no, you'll never play DRM videos on a non-Apple product.

There do exist tools for DRM removal, which will produce a playable video, but legality of this is questionable, so best to not discuss it here.

Return to “Media centres”