User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Sat May 28, 2016 10:03 pm

Some install and start, others don't. I have not really been able to test them since I don't have PVR stuff.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

Skyway
Posts: 19
Joined: Sun Dec 27, 2015 8:26 pm

Re: Kodi on Ubuntu MATE 15.10

Sat Jun 11, 2016 9:47 am

I just installed it, so far so good, worked just as you said. But one question still, when i exit Kodi the black screen appears. Is there a way that when i exit kodi, to show background?
Thanks for your work! Niiice:D

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 13, 2016 2:02 pm

Did you follow the whole guide? Especially the part that says:
After running Kodi, you will notice that it will display an ugly black screen instead of your desktop. We need to do a few things to fix this. Instructions:

1. Create a startkodi script

Code: Select all

sudo nano startkodi
2. Paste this into it:

Code: Select all

#!/bin/bash
fbset_bin=`which fbset`
xset_bin=`which xset`
xrefresh_bin=`which xrefresh`
if [ ! -z $fbset_bin ]; then
  DEPTH2=`$fbset_bin | head -3 | tail -1 | cut -d " " -f 10`
fi
kodi "$@"
if [ ! -z $fbset_bin ]; then
  if [ "$DEPTH2" == "8" ]; then
    DEPTH1=16
  else
    DEPTH1=8
  fi
  $fbset_bin -depth $DEPTH1 > /dev/null 2>&1
  $fbset_bin -depth $DEPTH2 > /dev/null 2>&1
fi
if [ ! -z $xset_bin ] && [ ! -z $xrefresh_bin ]; then
  if [ -z $DISPLAY ]; then
    DISPLAY=":0"
  fi

  $xset_bin -display $DISPLAY -q > /dev/null 2>&1
    if [ "$?" == "0" ]; then
      $xrefresh_bin -display $DISPLAY > /dev/null 2>&1
    fi
fi
VT="$(fgconsole)"
if [ "$VT" ]; then
  sudo chvt 7
  sudo chvt "$VT"
fi
3. Make it executable:

Code: Select all

sudo chmod +x startkodi
4. Copy to /usr/local/bin

Code: Select all

sudo cp startkodi /usr/local/bin
5. Make runnable:

Code: Select all

sudo chmod 777 /usr/local/bin/startkodi
1. Create a desktop file:

Code: Select all

sudo nano Desktop/kodi.desktop
2. Paste this into it:

Code: Select all

[Desktop Entry]
Version=1.0
Name=Kodi Media Center
GenericName=Media Center
Comment=Manage and view your media
Exec=startkodi
Icon=kodi
Terminal=false
Type=Application
Categories=AudioVideo;Video;Player;TV;
3. Copy to applications:

Code: Select all

sudo cp Desktop/kodi.desktop /usr/share/applications
Cheers!

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

Skyway
Posts: 19
Joined: Sun Dec 27, 2015 8:26 pm

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 13, 2016 4:14 pm

Exactly. Copy/paste. But anyway, i gave up since playing movies was sluggish..

gkreidl
Posts: 6128
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 13, 2016 4:57 pm

Skyway wrote:Exactly. Copy/paste. But anyway, i gave up since playing movies was sluggish..
Wrong settings.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Skyway
Posts: 19
Joined: Sun Dec 27, 2015 8:26 pm

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 13, 2016 4:59 pm

Maybe, but i installed OSMC, and all is good now. :lol:
Thanks anyway guys!

jsmeigs
Posts: 3
Joined: Sun Jun 19, 2016 4:58 am

Re: Kodi on Raspian Pi3

Sun Jun 19, 2016 5:16 am

This whole script to run Kodi seems to work pretty well except I'm not sure why when I double click on a newly downloaded mp4 directly within the downloads folder, it opens Kodi, plays fine and on exit I get the black screen again :evil:

I can double click the desktop Kodi shortcut we created and run anything and exit fabulously. It really seems that the system isn't using the .desktop script for Kodi whenever I just click directly on the mp4.

If I manually change the "open with" on each downloaded mp4 then I can double click on them and it's perfect but that seems ridiculous.

Is there a way to double click on a newly downloaded mp4, have it open Kodi, play the video and then close without the freezing black screen?

Btw, if you are stuck on the black screen you can hit Ctrl+Alt+F1 and type in 'reboot' which has to be better than pulling the plug.

Thanks for any help with this, I'm a linux/Pi noob.

Snze
Posts: 37
Joined: Tue May 10, 2016 6:46 am

Re: Kodi on Ubuntu MATE 15.10

Sun Jun 19, 2016 4:07 pm

Hi jsmeigs - this should just be a case of directing the os to use the startkodi script for all video files… have you looked for 'default applications' settings?

Can't be much more help than that as I don't have my pi any more, but you can avoid the need to reboot by doing ctrl+alt+f1 then ctrl+alt+f7 to get you back to the desktop.

jsmeigs
Posts: 3
Joined: Sun Jun 19, 2016 4:58 am

Re: Kodi on Ubuntu MATE 15.10

Sun Jun 19, 2016 8:19 pm

That's what I would have thought but I can't seem to locate a "default applications".

I tried right clicking the mp4 and selecting "Open With.." >Custom Command Line> Browsing to startkodi script AND checking the "Set selected application as default action for this file type". This works for the item I have done this on but anything new I download still hangs up when exiting kodi. It's like the checkbox for this file type isn't going into effect and I have to do it on every mp4 downloaded.

I figured there was a config or something to set the default applications and I might be able to make it point to the startkodi script but haven't found it so far. I thought the setup with all the cut pasting would have done this as well but either I missed something or it doesn't quite work.

Interestingly, I can open kodi using the .desktop referencing the startkodi script and play anything I have downloaded and then exit just fine. :?

Snze
Posts: 37
Joined: Tue May 10, 2016 6:46 am

Re: Kodi on Ubuntu MATE 15.10

Sun Jun 19, 2016 8:35 pm

It's a bit odd the setting doesn't 'stick'… changing the defaults.list might help?

jsmeigs
Posts: 3
Joined: Sun Jun 19, 2016 4:58 am

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 20, 2016 4:48 am

I know, right? I've got a 2nd Pi and I'll try to set that up the same way, maybe I miffed something. Thanks for the link, I'll read up on that as well.

For now I can deal with it since the only need I have is to download mp4's then open kodi and play them I can just make sure the desktop icon is my startkodi. It's only going to matter if someone tries to use it like windows and run it from the folder that there could be problem.

I'm going to be busy for a few days but I'll try that 2nd Pi and see if I have the same issue. This was my first Pi attempt :)

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 20, 2016 2:02 pm

I believe I figured the black screen bug out. Just did some testing on a fresh install of Ubuntu MATE, so give the original instructions the very first post of this topic) a shot.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Mon Jun 20, 2016 2:11 pm

jsmeigs wrote:I know, right? I've got a 2nd Pi and I'll try to set that up the same way, maybe I miffed something. Thanks for the link, I'll read up on that as well.

For now I can deal with it since the only need I have is to download mp4's then open kodi and play them I can just make sure the desktop icon is my startkodi. It's only going to matter if someone tries to use it like windows and run it from the folder that there could be problem.

I'm going to be busy for a few days but I'll try that 2nd Pi and see if I have the same issue. This was my first Pi attempt :)
Might it be easier, if you are just wanting to play mp4 files quickly, to use omxplayer?

I will see if I can figure out how to make the startkodi thing work across the system.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Tue Jul 26, 2016 1:39 pm

Kodi 17.0-ALPHA3 is compiling as I type! Will update guide soon... :D

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Tue Jul 26, 2016 10:54 pm

Does anyone know if windowed mode for Kodi on a Pi is possible? A quick Google search revealed that some drivers needed for windowed mode do not exist for the Pi. Do they now exist?

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

gkreidl
Posts: 6128
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi on Ubuntu MATE 15.10

Tue Jul 26, 2016 11:06 pm

Kratos wrote:Does anyone know if windowed mode for Kodi on a Pi is possible? A quick Google search revealed that some drivers needed for windowed mode do not exist for the Pi. Do they now exist?

Kratos
Some day perhaps, if the OpenGL driver is ready for general usage (and not using too much memory)..
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Thu Aug 04, 2016 3:27 pm

My latest build still has the crashing problem when trying to add items to the library. Sorry folks! I hope to have things smoothed out by tomorrow.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Thu Aug 04, 2016 5:40 pm

Unfortunatly, after running this command:

Code: Select all

sudo CFLAGS="-I/opt/vc/include/ -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -mfloat-abi=hard -mcpu=cortex-a7 -mfpu=neon-vfpv4" CXXFLAGS="-I/opt/vc/include/ -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -mfloat-abi=hard -mcpu=cortex-a7 -mfpu=neon-vfpv4" LDFLAGS="-L/opt/vc/lib" FFMPEG_OPTS="--cpu=cortex-a7" CXXFLAGS_FOR_BUILD="-g -O2 --disable-libstdcxx-dual-abi" ./configure --disable-gl --enable-gles --with-platform=raspberry-pi --disable-x11 --disable-vaapi --disable-vdpau --disable-avahi --enable-libcec --disable-pulse --enable-optical-drive --enable-libusb --disable-vtbdecoder --enable-alsa --enable-player=omxplayer --enable-libbluray
It exits with this message:

Code: Select all

checking for TAGLIB... no
configure: error: Could not find a required library. Please see the README for your platform.
Any Ideas?

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Thu Aug 04, 2016 10:23 pm

Successfully compiled libtag, Kodi is now cooking!

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Fri Aug 05, 2016 1:54 pm

Ran into a few more library issues. Kodi is hopefully cooking successfully now!

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

Rememo
Posts: 1
Joined: Sat Aug 06, 2016 4:56 pm

Re: Kodi on Ubuntu MATE 15.10

Sat Aug 06, 2016 4:57 pm

How do I remove kratos? It's really annoying

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Tue Aug 09, 2016 2:20 pm

To remove, simply type:

Code: Select all

sudo apt-get remove kodi* -y
Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Tue Aug 09, 2016 2:24 pm

I have got more problems with the library, unfortunatly. I willl try a build later using a version of gcc other than 5.3. The last lines of the crashlog read:

Code: Select all

20:47:31 T:1928290304   DEBUG: ------ Window Deinit (Settings.xml) ------
20:47:31 T:1928290304   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
20:47:31 T:1928290304   DEBUG: ------ Window Init (Home.xml) ------
20:47:31 T:1928290304   DEBUG: Window Home.xml was already loaded
20:47:31 T:1928290304   DEBUG: Alloc resources: 28.19ms
20:47:31 T:1754264560   DEBUG: CurlFile::Open(0x3f30d78) http://image.tmdb.org/t/p/original/nQ9jciRkjzuWvbdyP36hfeWxsOj.jpg
20:47:31 T:1745875952   DEBUG: CRecentlyAddedJob::UpdateVideos() - Running RecentlyAdded home screen update
20:47:31 T:1928290304   DEBUG: Keyboard: scancode: 0x01, sym: 0x001b, unicode: 0x0000, modifier: 0x0
20:47:31 T:1754264560 WARNING: COMXImageFile::GetCodingType progressive images not supported by decoder
20:47:31 T:1754264560   DEBUG: COMXImageFile::ReadFile http://image.tmdb.org/t/p/original/nQ9jciRkjzuWvbdyP36hfeWxsOj.jpg GetCodingType=0x7fffffff (300x450)
20:47:31 T:1928290304   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.image_decode input port 320 output port 321 m_handle 0x4074ce8
20:47:31 T:1928290304   DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.image_decode) - port(320), nBufferCountMin(2), nBufferCountActual(2), nBufferSize(267520), nBufferAlignmen(16)
20:47:31 T:1928290304   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.resize input port 60 output port 61 m_handle 0x409fa10
20:47:31 T:1928290304   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.egl_render input port 220 output port 221 m_handle 0x408a7d8
20:47:31 T:1928290304   DEBUG: COMXCoreComponent::UseEGLImage component(OMX.broadcom.egl_render) - port(221), nBufferCountMin(1), nBufferCountActual(1), nBufferSize(15360) nBufferAlignmen(16)
20:47:31 T:1745875952   DEBUG: RunQuery took 15 ms for 10 items query: select * from movie_view  ORDER BY dateAdded desc, idMovie desc LIMIT 10
What is the problem? All the movies were on a hard drive, so was it simply taking to long to query movies, as indicated by the last line?

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Thu Aug 11, 2016 7:19 pm

It seems that gcc 5.3 is making it impossible to add things to the library. I tried a build of Kodi 17 on Raspbian Jessie, which uses gcc 4.9, and I had no trouble at all adding files to the library.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Kodi on Ubuntu MATE 15.10

Mon Aug 15, 2016 1:40 pm

I wasn't sure what it was in the end, but, I fixed the library issue by not upgrading a stock install of Ubuntu MATE. Kodi is now updated to 17 Beta 1. I included the startkodi script in the build, so manually patching will be easier.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

Return to “Media centres”