Page 2 of 4

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sat Feb 28, 2015 8:12 am
by truehl
k0smik0 wrote:Hi,in first post truehl recommends "iqaudio pi-dac+" as dac, and mentions raspberry (of course) as well as odroid u3 and c1 as SoC.. so my question is: iqaudio pi-dac+ is supported by odroid c1?
No, its not, only Pi.
k0smik0 wrote:I'm interested to build a bit-perfect box with a i2s dac, not using a raspberry* card, but a powerful one, as odroid c1 or any cubieboard, or any udoo.. any model equipped with a gigabit lan and a two different buses for ethernet and usb (you know, raspberry* has a shared bus for those ports).
I understand that! We are cooperating with a producer of such a device, but right now it's to early to speak about. For now the Pi with iqaudio pi-dac+ is the best you can get. I've visited a audiophile friend this week an he was very impressed about the sound.
k0smik0 wrote:Of course, if you know about other i2s dacs compatible with odroid*/cubieboard*/bananapi/orangepi/any_soc_with_a_better_architecture_than_raspberry*, tell me ;D !
Not right now, but I hope to have one till summer!

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sat Feb 28, 2015 1:11 pm
by Man in a van
k0smik0 wrote:Hi,

in first post truehl recommends "iqaudio pi-dac+" as dac, and mentions raspberry (of course) as well as odroid u3 and c1 as SoC.. so my question is: iqaudio pi-dac+ is supported by odroid c1?

I'm interested to build a bit-perfect box with a i2s dac, not using a raspberry* card, but a powerful one, as odroid c1 or any cubieboard, or any udoo.. any model equipped with a gigabit lan and a two different buses for ethernet and usb (you know, raspberry* has a shared bus for those ports).

Of course, if you know about other i2s dacs compatible with odroid*/cubieboard*/bananapi/orangepi/any_soc_with_a_better_architecture_than_raspberry*, tell me ;D !

Thanks,
Best regards
Better you look elsewhere then for non-pi information. You ain't gona find it here!!

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sat Feb 28, 2015 5:25 pm
by Verulamius
Thomas,

Thanks for your reply on my USB drive problems. The RPI was not recognising the drives at all, so lsusb was no showing anything. By adding an intermedite USB hub with a power source, solved the problem.

In addition, by doing this, my internet connection problems have also disapeared. So I think that there must have been something strange in the RPI set up.

My next complication is that whilst my drives are now recognised in the SAMBA set up and I can access them via my networked computers and via putty, when I am trying to set up LMS is not recognising the folders on my drive so that I can not point it to my music library to scan.

Any thoughts?

Thanks for all your assistance on this.

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sat Feb 28, 2015 6:38 pm
by truehl
Verulamius wrote:My next complication is that whilst my drives are now recognised in the SAMBA set up and I can access them via my networked computers and via putty, when I am trying to set up LMS is not recognising the folders on my drive so that I can not point it to my music library to scan.
Hm, so only the LMS does not see the USB HD attached to the Pi? If so, reboot the Pi and if you can't see it either, try to install LMS again and use the latest nightly version. Please tell me if you can't solve the problem!

Greetings,
Thomas

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sun Mar 01, 2015 3:03 pm
by truehl
truehl wrote:
Verulamius wrote:My next complication is that whilst my drives are now recognised in the SAMBA set up and I can access them via my networked computers and via putty, when I am trying to set up LMS is not recognising the folders on my drive so that I can not point it to my music library to scan.
Hm, so only the LMS does not see the USB HD attached to the Pi? If so, reboot the Pi and if you can't see it either, try to install LMS again and use the latest nightly version. Please tell me if you can't solve the problem!

Greetings,
Thomas
How is Your drive drive formatted? FAT, NTFS ore something else?

Greetings, Thomas

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Mon Mar 02, 2015 10:36 am
by Verulamius
Thomas,

My drive was a NTFS. I followed your instructions on the slimdevices forum to install ntfs -3g and it now works.

It only took about 20 mins to scan my 11k of flacs.

Thanks very much for your help, it is appreciated. Now I just need to understand the ffmpeg/HLS/BBC iplayer issues...

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Mon Mar 02, 2015 2:34 pm
by truehl
Verulamius wrote:My drive was a NTFS. I followed your instructions on the slimdevices forum to install ntfs -3g and it now works. It only took about 20 mins to scan my 11k of flacs...
Nice to here! We will provide an update the next days, sorry for that bug. Yes, scanning is very fast with a Pi 2!

Greetings,
Thomas

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Mon Mar 02, 2015 9:05 pm
by Trixster
How does the speed of this compare to the speed of SqueezePlug 7.5 on an Rpi2?

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Mon Mar 02, 2015 9:17 pm
by truehl
Trixster wrote:How does the speed of this compare to the speed of SqueezePlug 7.5 on an Rpi2?
Do you mean SqueezePlug 7.5 on Rpi2 to SqueezeBox & MAX2Play on Rpi2? There is no difference in speed, because both images uses the same Raspbian base. The advantage of SqueezePlug & MAX2Play is the web-interface and some improvements e.g. all players are working together, Kodi is integrated ...)

Greetings,
Thomas

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 05, 2015 3:34 am
by jfass
Hi,

First off I have to say this is a great package!

This may be a stupid question, but I can't seem to find how to configure my USB wifi as an Access Point within the web interface. Am I missing something? Should I go in through SSH? While doing some digging, it looks like that feature was added in 7.04
http://www.squeezeplug.eu/?p=417

Can someone help me out with this?

Thanks,
Jfass

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Fri Mar 06, 2015 11:35 am
by trondis23
My search for the perfect music/mediaplayer is over. Four players and three servers in one is fantastic, and then other extras on top of it. Plus it's very easy to install and control. The only thing that wasn't quite "out of the box" is that my remote for Kodi couldn't connect - I had to connect a mouse to set up Kodi first.

I didn't install the Logitech media server through Max2Play, since I already had it running on a Banana Pi. I also have Minimserver and BubbleUPnP server on the same Pi. I use Minimserver instead of Logitech because it is a lot faster and easier to maintain with a large library. Otherwise the Logitech server is fine, and faster than XBMC. So I use Minimserver for my own rips, Logitech for Wimp and web radio, and XBMC for 5.1 sound files and videos. And no more swapping of SD cards, as I did before.

Thank you!

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sat Mar 07, 2015 11:48 am
by truehl
jfass wrote:Hi,

First off I have to say this is a great package!

This may be a stupid question, but I can't seem to find how to configure my USB wifi as an Access Point within the web interface. Am I missing something? Should I go in through SSH? While doing some digging, it looks like that feature was added in 7.04
http://www.squeezeplug.eu/?p=417

Can someone help me out with this?

Thanks,
Jfass
The Access Point function is not implemented in SqueezePlug & MAX2Play right now. It's on the list for updates!

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Sun Mar 08, 2015 12:44 am
by jfass
truehl wrote:
jfass wrote:Hi,

First off I have to say this is a great package!

This may be a stupid question, but I can't seem to find how to configure my USB wifi as an Access Point within the web interface. Am I missing something? Should I go in through SSH? While doing some digging, it looks like that feature was added in 7.04
http://www.squeezeplug.eu/?p=417

Can someone help me out with this?

Thanks,
Jfass
The Access Point function is not implemented in SqueezePlug & MAX2Play right now. It's on the list for updates!
That is great news! Thanks for the update!

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Wed Mar 11, 2015 4:51 am
by twiddlepie
Hi,

I have a hifiberry Digi sound card, but it is not obvious on the Squeezelite settings page how I set this card up - I want to play out of the SPDIF electrical plug (not optical). Any suggestions on how I do this, or does it play out of there automatically?

Thanks,
Adrian

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Wed Mar 11, 2015 10:54 pm
by Man in a van
twiddlepie wrote:Hi,

I have a hifiberry Digi sound card, but it is not obvious on the Squeezelite settings page how I set this card up - I want to play out of the SPDIF electrical plug (not optical). Any suggestions on how I do this, or does it play out of there automatically?

Thanks,
Adrian

They both work at the same time.

This might be useful to you if you have a problem

https://www.hifiberry.com/guides/config ... ux-3-18-x/

atb

Ronnie

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 12, 2015 12:41 am
by twiddlepie
Man in a van wrote:
twiddlepie wrote:Hi,

I have a hifiberry Digi sound card, but it is not obvious on the Squeezelite settings page how I set this card up - I want to play out of the SPDIF electrical plug (not optical). Any suggestions on how I do this, or does it play out of there automatically?

Thanks,
Adrian

They both work at the same time.

This might be useful to you if you have a problem

https://www.hifiberry.com/guides/config ... ux-3-18-x/

atb

Ronnie
Ok, thanks for that, good to know. I was just trying to follow the Squeezeplug Max2Play instructions, and it says to configure the soundcard via the web interface. Just to be clear, is it not actually possible currently to configure the hifiberry digi card from the web interface?

Thanks,
Adrian

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 12, 2015 1:42 am
by twiddlepie
twiddlepie wrote:
Man in a van wrote:
twiddlepie wrote:Hi,

I have a hifiberry Digi sound card, but it is not obvious on the Squeezelite settings page how I set this card up - I want to play out of the SPDIF electrical plug (not optical). Any suggestions on how I do this, or does it play out of there automatically?

Thanks,
Adrian

They both work at the same time.

This might be useful to you if you have a problem

https://www.hifiberry.com/guides/config ... ux-3-18-x/

atb

Ronnie
Ok, thanks for that, good to know. I was just trying to follow the Squeezeplug Max2Play instructions, and it says to configure the soundcard via the web interface. Just to be clear, is it not actually possible currently to configure the hifiberry digi card from the web interface?

Thanks,
Adrian
Specifically, in Step 10 "Please configure the appropriate soundcard for your system." - how do I do that?

Thanks,
Adrian

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 12, 2015 10:41 am
by Man in a van
Ok, thanks for that, good to know. I was just trying to follow the Squeezeplug Max2Play instructions, and it says to configure the soundcard via the web interface. Just to be clear, is it not actually possible currently to configure the hifiberry digi card from the web interface?

Thanks,
Adrian[/quote]

Specifically, in Step 10 "Please configure the appropriate soundcard for your system." - how do I do that?

Thanks,
Adrian[/quote]


Adrian i have posted before but that seems to have got lost.

On the Audio Player page, scroll down to the Squeezelite settings.
Click on advanced settings and your player should show in the drop down box.
Select it and save.
Click on the save autostart button.
then either restart squeezelite or reboot (I prefer reboot this time)

atb

Ronnie

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 12, 2015 6:42 pm
by twiddlepie
Man in a van wrote:Ok, thanks for that, good to know. I was just trying to follow the Squeezeplug Max2Play instructions, and it says to configure the soundcard via the web interface. Just to be clear, is it not actually possible currently to configure the hifiberry digi card from the web interface?

Thanks,
Adrian
Specifically, in Step 10 "Please configure the appropriate soundcard for your system." - how do I do that?

Thanks,
Adrian[/quote]


Adrian i have posted before but that seems to have got lost.

On the Audio Player page, scroll down to the Squeezelite settings.
Click on advanced settings and your player should show in the drop down box.
Select it and save.
Click on the save autostart button.
then either restart squeezelite or reboot (I prefer reboot this time)

atb

Ronnie[/quote]

Hi,

I tried with those settings, and none of them worked. I can hear sound out of the headphone jack of the pi, but it never seems to come out of the hifiberry outputs.

In the squeezelite settings I have 3 options (sorry, I don't have access to it right now, so it's from memory). The first one I think ends in "equaliser", the second one starts with "default" and the third on is "sysdefault", so none of them are obviously for the hifiberry. Am I missing something here? I can be more exact with what the options are when I get home tonight.

As a side note, the new system seems very unstable (Squeezeplug & Max2Play, Pi B 2, hifiberry). If I flick from internet radio to playing stuff of my network drive, both streams keep playing (in fact I had 3 songs playing simultaneously at one stage). I never had this issue with the old system (Squeezeplug 7.09, Pi B, Wolfson audio card).

Cheers,
Adrian

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 12, 2015 9:09 pm
by Man in a van
Adrian, can you SSH in to the pi using root as user and max2play as password.

Then type squeezelite -l (that is letter L lower case)

This should give a list of output devices, there should be one (at least) for the hifiberry dac.

atb

Ronnie.

ps. are you in the UK (timewise)?

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Thu Mar 12, 2015 11:21 pm
by Man in a van
Adrian, you can try this:- (post is from another thread on this forum).

Also, do you have a good power supply for the pi, look over on the crazy audio forums, but try this below first.

atb

ronnie


by [IDC]Dragon » Fri Feb 06, 2015 5:42 pm
Hi Richard, thanks for the pointer.

Today my Raspberry Pi 2 arrived, and wasn't working out of the box. My distro was freshly upgraded, but still it woudn't boot from the old card. I had to prepare a new one, used Noobs for that.

To summarize the device tree business:
As far as I understand, a device tree is a set of dependencies for drivers. It is defined by a binary file called overlay, placed into /boot. Since this is the FAT32 part of the card, it's now even possible to prepare that on the card under Windows. The overlay file is referenced in a to-be-added line in config.txt.
Overlays and some documentation can be found here, we need the file "hifiberry-digi-overlay.dtb" from it:
https://github.com/raspberrypi/firmware ... t/overlays
In config.txt you need to add a line:
dtoverlay=hifiberry-digi

It can be done live on the board as well, with e.g. the following:

Code: Select all
sudo su
cd /boot
wget https://github.com/raspberrypi/firmware ... verlay.dtb
echo "dtoverlay=hifiberry-digi" >> config.txt


Jörg

Posts: 18
Joined: Mon Dec 16, 2013 9:47 pm

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Mon Mar 16, 2015 8:26 am
by atinkler
Sorry i have posted this on a few threads about squeezeplug but no answer on those (maybe it's a stupid question but I'm not sure why)

Hi I'm trying to get alsaequal to work But i can't find this file /usr/local/bin/squeezelite_settings.sh
can you help me find it please? Thanks

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Tue Mar 17, 2015 3:13 pm
by Cardman
Hi Thomas, Stephan,

thank you guys a lot for this fine work. The intuitive web-interface will certainly boost popularity of SqueezePlug.

I am currently struggling with Squeezebox playback. I have to add that I am using the Logitech Server plugin on my Synology NAS, not on one of my Raspberries. Not sure if that may cause this. However, i have issues in getting multiple players (issues actually start with 2 players) to play simultaneously (i.e. setting them up as a group). If I do so, LS server will show me that both are playing, but only one actually is.
Also, sometimes while playing music on only one player, skipping to the next song will lead to the next song starting with the current song still playing (cross-fading... is deactivated). At this point the old playlist will keep playing no matter what I do and all controls (play, pause, skip...) only affect the newly started song/playlist. No matter what I do the old playlist keeps playing (except of course killing the player task or resetting the LS server).

Any ideas what may cause these issues? I still have a spare Pi lying around and I am willing to install LS server on it to test whether this may be caused by the Synology LS plugin, but I have my doubts.

Any suggestions on what to try are welcome.
Thanks in advance.

PS: I also tried iPeng as "remote" - same issues.

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Wed Apr 01, 2015 11:36 am
by B. Marcelis
Hello Rpi experts,

For about 2/3 weeks i have a Rpi 2B that i use with the Max2Play software. The Rpi 2 is fitted with a Hifiberry DAC+ and connected to LAN. I use the 2B as a Music Mediaserver and a player. Installed: LMS 7.8 en the Hifiberry DAC+. Works great with Spotify Premium and also my other (multiroom) player a Rpi B+ with Wifi and a Hiffiberry AMP+ .

The issue is that i can't get both of mine USB drive's to work with the Rpi2. When i connect them via USB they just make a 'clicking' sound and won't be able to spin up. I have a WB 1TB and a WB 160GB both 2,5'' smal external drives.
I read a lot of posts about the power issue's with USB devices. If i connect the USB HD with an special Y-cable it still doesn't work!

Just like this:
USB Y-cable.jpg
Y cable
USB Y-cable.jpg (28.11 KiB) Viewed 5478 times
I have an NTFS drive and a exFAT drive, both do the same 'clicking' thing.....

I also tried to instal autofs with this as result. Can someone plz help me further with this? Great thanks in advance!!
install%20autofs.jpg
Autofs
install%20autofs.jpg (55.16 KiB) Viewed 5494 times

Re: New Complete Web-Based SqueezePlug Version Available

Posted: Wed Apr 01, 2015 12:00 pm
by gkreidl
Remove the second power supply.
add
max_usb_current=1
to /boot/config.txt
Connect your HD (only one at a time)