vector
Posts: 3
Joined: Mon May 21, 2012 9:31 pm

Perl 5.8.3 or later and perl modules?

Mon Jan 28, 2013 4:17 am

Hi,
does anybody know how I can get on my pi perl 5.8.3 or later and perl modules? :?

Thanks

User avatar
rpdom
Posts: 15584
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Perl 5.8.3 or later and perl modules?

Mon Jan 28, 2013 4:48 am

You haven't said which Operating System version you are using.

If you have installed the Raspbian version, you should have perl and perl-modules 5.14 already installed.

You can check this in a terminal with "dpkg -l perl perl-modules" (That's a lower-case "L", not a capital "i" or number "1")

My system reports

Code: Select all

pi@raspi:~$ dpkg -l perl perl-modules
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name               Version        Architecture   Description
+++-==================-==============-==============-=========================================
ii  perl               5.14.2-16+rpi1 armhf          Larry Wall's Practical Extraction and Rep
ii  perl-modules       5.14.2-16+rpi1 all            Core Perl modules

pi@raspi:~$

vector
Posts: 3
Joined: Mon May 21, 2012 9:31 pm

Re: Perl 5.8.3 or later and perl modules?

Tue Jan 29, 2013 1:15 am

What about Perl 5.8.3 higher?

User avatar
jojopi
Posts: 3086
Joined: Tue Oct 11, 2011 8:38 pm

Re: Perl 5.8.3 or later and perl modules?

Tue Jan 29, 2013 3:19 am

In case it is not obvious, five.fourteen.two is higher than five.eight.three. In fact, 5.8.3 is a rather old version, released in January 2004.

Perhaps it would be better to explain what you are trying to do, and how it is not working.

technion
Posts: 238
Joined: Sun Dec 02, 2012 9:49 am

Re: Perl 5.8.3 or later and perl modules?

Sun Feb 10, 2013 4:26 am

vector wrote:What about Perl 5.8.3 higher?
The CentOS 5 (with their reputation of being behind versions on everything) server I built roughly two years ago is running a more recent version than that. You would struggle to find something lower.

Return to “Other programming languages”