Timco
Posts: 1
Joined: Wed Aug 08, 2012 9:27 pm

Rails + Javascript

Wed Aug 08, 2012 9:30 pm

Hi all,

I'm just starting with my fantastic RaspberryPi.
I've managed to install successfully Rails but ..
I can't install therubyracer, nor libv8 (error with "Target architecture ia32")

Is anyone working with rubyracer here ? How can I install it ?

Thanks

Danny72
Posts: 1
Joined: Fri Aug 17, 2012 11:44 pm

Re: Rails + Javascript

Fri Aug 17, 2012 11:48 pm

The current build isn't setup for ARM.

https://github.com/cowboyd/therubyracer/issues/186

Until the implementation is fixed, you can get around it using another javascript package like Node.js

oniram
Posts: 1
Joined: Thu Aug 23, 2012 12:42 pm

Re: Rails + Javascript

Thu Aug 23, 2012 1:49 pm

how can i make this: "Until the implementation is fixed, you can get around it using another javascript package like Node.js"

User avatar
mellett68
Posts: 6
Joined: Tue Aug 28, 2012 6:24 pm
Location: Cornwall, UK

Re: Rails + Javascript

Tue Aug 28, 2012 8:52 pm

Depends on your OS, but for Ubuntu (so probably Debian too) you can simply

Code: Select all

sudo apt-get install nodejs
You don't need anything specific in your Gemfile. (At least, I never put anything in mine)

There's also a nodejs package for Arch, so

Code: Select all

Pacman -S nodejs

Return to “Other programming languages”