skiddaw
Posts: 9
Joined: Sat Oct 29, 2011 6:19 pm

Load SD Card Image using camera

Sun Feb 24, 2013 3:57 am

My first 'Pi software update quit in the middle leaving me a corrupted SD card. It was likely due to an overloaded keyboard interface. I have no SD Card read/write sockets on any of my PCs, unlike what I saw in Europe where maybe it is standard. My solution was to plug my 4G SD card into my camera and plug that into the laptop. I then followed the instructions online for loading a 'Pi image. This failed twice, at 51% and then 5% before I replaced the camera batteries! After that it happily loaded 100% and worked just fine in the 'Pi. I'm now hoping to load the Beez 4th.....

jehan60188
Posts: 10
Joined: Tue Jul 17, 2012 8:49 pm

Re: Load SD Card Image using camera

Sun Feb 24, 2013 1:54 pm

nice workaround
does your O/S treat your camera as just a hard drive, or as a media device?
is it worth making a how-to for others?

skiddaw
Posts: 9
Joined: Sat Oct 29, 2011 6:19 pm

Re: Load SD Card Image using camera

Mon Feb 25, 2013 1:35 am

The camera opens as a drive.

On my laptop the Camera (Samsung S760) opens in AutoPlay as Removable Disk (E:) with options to Open Folder to View Files (using Windows Explorer). I closed AutoPlay and ran Win32 Disk Imager, with Image Field: 2013-02-09-wheezy-raspbian.img and Device Field: [E:\] (if it wasn't already there). After that I selected Write and headed upstairs to make a cup of tea! The resulting 4G SD Card worked fine in my 'Pi.

-rst-
Posts: 1316
Joined: Thu Nov 01, 2012 12:12 pm
Location: Dublin, Ireland

Re: Load SD Card Image using camera

Mon Feb 25, 2013 2:09 pm

Pretty sure I read on this forum someone else doing the same - so it has been proven now (or do we need a third one) ;)
http://raspberrycompote.blogspot.com/ - Low-level graphics and 'Coding Gold Dust'

Return to “General programming discussion”