User avatar
antiriad
Posts: 143
Joined: Sun Nov 17, 2013 7:38 pm
Location: Italy
Contact: Twitter

Can't manually enable experimental OpenGL driver on "clean" installation

Thu Aug 23, 2018 3:30 pm

Hello,

I'm trying to get a clean installation of Raspian Stretch with hardware acceleration.
Starting from latest release of Raspbian LITE, I updated everything (apt-get update, dist-upgrade etc.).

I installed Xorg Display Server and Xinit

Code: Select all

sudo apt-get install --no-install-recommends xserver-xorg xinit

...then Raspbian Desktop (RPD)

Code: Select all

sudo apt-get install raspberrypi-ui-mods

... the experimental OpenGL driver

Code: Select all

sudo apt-get install xcompmgr libgl1-mesa-dri

...but when I activate OpenGL driver in raspi-config, I get very low performance on glxgears, as if driver it's not activated (or however as if it's much much slower than default Raspbian image available for download).

So it's seems that something is missing... any help?
THANKS

MORE DETAILS:
- memory split is set to 128Mb
- firmware is updated via rpi-update
- I launched apt-get update / upgrade also after the OpenGL driver activation
- color (or "shading") of glxgears is strangely different than that in the default Raspbian (non-Lite) ISO publicly available
- after compiling chocolate-doom (V3 with SDL2-dev etc.) in both contexts, I get 60fps on default Raspbian (non-Lite) ISO and 1 (one!) FPS on custom Raspbian Lite + RPD + OpenGL driver.

User avatar
Imperf3kt
Posts: 2898
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Thu Aug 23, 2018 10:01 pm

Which model Pi are you using?
55:55:44:44:4C
52:4C:52:42:41

User avatar
antiriad
Posts: 143
Joined: Sun Nov 17, 2013 7:38 pm
Location: Italy
Contact: Twitter

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Fri Aug 24, 2018 5:05 am

Hello, I'm using a Raspberry Pi 3.

User avatar
antiriad
Posts: 143
Joined: Sun Nov 17, 2013 7:38 pm
Location: Italy
Contact: Twitter

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Fri Aug 24, 2018 11:27 am

Found this old comment by Simon Long...
https://www.raspberrypi.org/blog/anothe ... nt-1252967

Perhaps the reason why the driver is not activated depends on one of these factors...

User avatar
PeterO
Posts: 5086
Joined: Sun Jul 22, 2012 4:14 pm

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Fri Aug 24, 2018 11:33 am

antiriad wrote:
Fri Aug 24, 2018 11:27 am
Found this old comment by Simon Long...
https://www.raspberrypi.org/blog/anothe ... nt-1252967

Perhaps the reason why the driver is not activated depends on one of these factors...
Maybe , but that is over 2 years ago and many things have changed in that time...... I don't know anything more I'm afraid.
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

User avatar
antiriad
Posts: 143
Joined: Sun Nov 17, 2013 7:38 pm
Location: Italy
Contact: Twitter

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Fri Aug 24, 2018 12:10 pm

Thank you for your feedback.

Maybe there is a way to forward this to someone of the Staff (or Simon Long himself) without "stalking"? It would be extremely useful to put on a "clean" Raspbian installation with hardware acceleration.

User avatar
antiriad
Posts: 143
Joined: Sun Nov 17, 2013 7:38 pm
Location: Italy
Contact: Twitter

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Mon Sep 03, 2018 11:50 am

I've done it! 8-)

After enabling the experimental OpenGL driver in raspi-config, manually delete /usr/share/X11/xorg.conf.d/99-fbturbo.conf and reboot.

Return to “Advanced users”