pranita
Posts: 11
Joined: Mon Aug 11, 2014 1:03 pm

wlan interface not up coming up on raspberry pi 3 model

Tue Aug 02, 2016 1:09 pm

I have created custom Linux build from Jessie repository. My PI 3 model is successfully booted with the custom build. I want to connect my device (PI 3) through Wi-Fi. But unfortunately, wlan0 interface is neither coming up under "ip link" command nor in "sudo iwconfig"
This is what I am getting as a result on my custom build -
1. $ sudo iwconfig
lo no wireless extensions.
eth0 no wireless extensions.


2. $ sudo ifup wlan0

Warning: Fake start-stop-daemon called, doing nothing
wpa_supplicant: timed out waiting for creation of /run/wpa_supplicant.wlan0.pid
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.


I have wireless-tools, wpasupplicant, wireless-regdb and iw packages pre-installed on my custom build.
Can anyone help me to identify the actual root cause for this scenario?

Thanks in advance :)

pranita
Posts: 11
Joined: Mon Aug 11, 2014 1:03 pm

Re: wlan interface not up coming up on raspberry pi 3 model

Fri Aug 12, 2016 10:15 am

Hello,

Is there anyone who can help me in this?

Your help will really appreciated :)

SonOfAMotherlessGoat
Posts: 690
Joined: Tue Jun 16, 2015 6:01 am

Re: wlan interface not up coming up on raspberry pi 3 model

Fri Aug 12, 2016 5:40 pm

Well it looks like your custom build has not fully satisfied the needs of an operating system. What did you do to create this custom build of Jessie?

The error message "Fake start-stop-daemon" is basically saying that the call to start wpa-supplicant isn't working, as noted by the lack of .pid file. So the rest of the turn-up process fails. Fix the daemon error and you'll be closer to a solution. (Search the web for solutions, since you've built custom and aren't running stock it's going to be very difficult to troubleshoot the process and you'll probably do better to search for that fix yourself.)
Account Inactive

Return to “Advanced users”