rmtucker
Posts: 3
Joined: Thu Feb 12, 2015 11:05 am

Epiphany Disappointment

Thu Feb 12, 2015 11:11 am

After tinkering with the RPI2 in the last few days,i am a little disappointed in Epiphany.
It seems a little faster when loading web pages opposed to iceweasel but playing video on youtube etc is very poor.
I have set the memory split to 512mb,but this is a guess as there does not seem to be any info on the pi2.
If i set the video to fullscreen it is appalling.
Is there no web browsers using video acceleration?

ghans
Posts: 7880
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Epiphany Disappointment

Thu Feb 12, 2015 11:44 am

Try kweb instead. Read the manual , it' extensive.

http://www.raspberrypi.org/forums/viewt ... 66&t=40860

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

rmtucker
Posts: 3
Joined: Thu Feb 12, 2015 11:05 am

Re: Epiphany Disappointment

Thu Feb 12, 2015 3:26 pm

100% Better.
A little complicated but the video is much better through omxplayer.
Thank You.
Why is epiphany not like this??????

gkreidl
Posts: 6166
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Epiphany Disappointment

Thu Feb 12, 2015 4:19 pm

rmtucker wrote:100% Better.
A little complicated but the video is much better through omxplayer.
Thank You.
Why is epiphany not like this??????
Epiphany and kweb3 use gstreamer-1.x, which is less efficient than omxplayer. And the HW accelerated video (using the GPU) has to be copied back to the X frame buffer and that is not very efficient. Fill screen video is almost impossible with this method.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

semtex
Posts: 63
Joined: Sat Mar 03, 2012 4:54 am

Re: Epiphany Disappointment

Fri Feb 13, 2015 5:48 am

That's very odd. I've been watching YouTube, full screen 1920x1080 and no problems whatsoever with Epiphany.

In the preferences do you have "Allow advertisements" checked? It should be.

My memory split is the default 128GB... though I do use the RP2 overclock option.

Regards

gkreidl
Posts: 6166
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Epiphany Disappointment

Fri Feb 13, 2015 8:08 am

semtex wrote:That's very odd. I've been watching YouTube, full screen 1920x1080 and no problems whatsoever with Epiphany.

In the preferences do you have "Allow advertisements" checked? It should be.

My memory split is the default 128GB... though I do use the RP2 overclock option.

Regards
If you call that "watching a video".
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

rmtucker
Posts: 3
Joined: Thu Feb 12, 2015 11:05 am

Re: Epiphany Disappointment

Fri Feb 13, 2015 11:36 am

Well There is no way i can get epiphany to show a hd film fullscreen????
It will play but very poor quality and stuttering.
Where when i play it in Kweb via omxplayer it is perfect and at full hd?
Kweb is very cumbersome but plays video perfect when you get used to it.
Why can epiphany not have this option to play video like this??

ghans
Posts: 7880
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Epiphany Disappointment

Fri Feb 13, 2015 11:46 am

Look at it this way : kweb is better than Epiphany because it is different. Epiphany can not work the exact same way like kweb
and simultaneously be worse than it , thats logically impossible. Some people propably even like things you consider as Epiphanys drawbacks.

The "real" technical reason has been explained by gkreidl himself just a few posts before this one.

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

Return to “Troubleshooting”