benryu
Posts: 26
Joined: Sat Sep 27, 2014 1:11 pm

Automouting HDD

Sat Dec 27, 2014 4:46 pm

So I have setup my b+ with transmission and pyLoad along with automounting my hdd.

I am using this powered hub - http://www.transcend-info.com/Products/No-402 to power my seagate 500gb portable hdd.

The issue I am facing is that when i power the setup the hdd isn't getting powered. I have to separately turn it on and then connect the USB to the pi.

When pi is running with hdd automounted and i reboot the hdd works properly

My fstab file:

Code: Select all

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults          0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
UUID=A65054F65054CEA5 /mnt ntfs-3g uid=1000,gid=1000,umask=007 0 2
I have tried using sda1 as well as the UUID setting still i have this issue. How do i fix this?

User avatar
DougieLawson
Posts: 36829
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Automouting HDD

Sun Dec 28, 2014 11:28 am

You need to enable the high power mode on the B+ USB. sudo nano /boot/config.txt add this

Code: Select all

max_usb_current=1
BTW, reformat that external drive as ext4 rather than NTFS and it will run three times faster.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

benryu
Posts: 26
Joined: Sat Sep 27, 2014 1:11 pm

Re: Automouting HDD

Tue Dec 30, 2014 4:43 pm

Ok have added the line. But still not working. I think its not getting auto mounted. When i type sudo blkid i cannot see the drive listed.

Return to “Troubleshooting”