Preator
Posts: 21
Joined: Sat Jun 21, 2014 11:48 am

[Solved] No sound with usb audio card

Sat Dec 27, 2014 2:03 pm

Hello,

I am hardly trying to have sound with a USB audio card with my raspberry pi model B+. I have followed this tutorial : http://computers.tutsplus.com/articles/ ... -mac-55876 but I still have no sound. I've got a X-Mini II speaker with this usb audio card. I have tested the speaker on my windows and it works correctly.

What should I do to have sound on my pi mobel B+?
Last edited by Preator on Sun Dec 28, 2014 8:43 am, edited 1 time in total.

User avatar
Paul Webster
Posts: 815
Joined: Sat Jul 30, 2011 4:49 am
Location: London, UK
Contact: Twitter

Re: No sound with usb audio card

Sat Dec 27, 2014 3:47 pm

I assume that since you said that you followed the guide but did not report any problems then everything appeared to work as shown in that guide.
So, apart from a mistake like not plugging in the cable enough then it could be that the volume was not set high enough via alsamixer (last step in the guide) or not enough electrical power (could try connecting via a powered hib if you have one).

Preator
Posts: 21
Joined: Sat Jun 21, 2014 11:48 am

Re: No sound with usb audio card

Sat Dec 27, 2014 4:34 pm

Ok I tried with sonic pi and I do have sound. But when I try a command like espeak, or to read a wav file with VLC, I have no sound.

User avatar
Paul Webster
Posts: 815
Joined: Sat Jul 30, 2011 4:49 am
Location: London, UK
Contact: Twitter

Re: No sound with usb audio card

Sat Dec 27, 2014 10:47 pm

They might be sending their sound via the analogue socket - try plugging mini headphones or power speakers into it and see if you hear anything there.

Preator
Posts: 21
Joined: Sat Jun 21, 2014 11:48 am

Re: No sound with usb audio card

Sun Dec 28, 2014 8:42 am

I've solved the problem by removing pulseaudio (sudo apt-get --purge remove pulseaudio).

Thanks for the help

Return to “Troubleshooting”