oaksboard
Posts: 7
Joined: Sun Sep 14, 2014 8:42 pm

raspberry pi b+ hidef audio issue

Sun Sep 14, 2014 9:18 pm

hello everyone,

i am experiencing audio playback issues with my new b+, mpd and high definition flac audio files. everything above 48khz does play back at 2-3 times the normal speed with lots of bumps and clicks. other users at volumio forum are talking about the same issue here: http://volumio.org/forum/volumio-for-ra ... 74-20.html

distros tested: raspbian (latest kernel, wheezy - all pkgs up to date), volumio 1.41
audio devices tested: hifiberry digi+, generic usb dac (capable of 192k/24bit), onboard audio

onboard audio (plug and hdmi) does not show the issue, because samplerate is reduced to 48khz on playback (probably the hardware isn't capable of more).
the workaround when using hifiberry or usb dac is adding

Code: Select all

format "48000:16:2"
to the output device section in mpd.conf, but i don't like that really much.

some remark:
- the generic usb dac does work flawlessly on an old raspberry pi b model with raspbian installed, playing back 96k/24bit flac files without any glitch. can't test the hifiberry digi+ on older hardware because it is specifically made for the b+.
- when using mplayer instead of mpd, the files play back without an issue..
- with both players output parameters are the same, except for period_size. this is mplayer playing:

Code: Select all

cat /proc/asound/card1/pcm0p/sub0/hw_params 
access: RW_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 96000 (96000/1)
period_size: 3000
buffer_size: 48000
and this is mpd:

Code: Select all

cat /proc/asound/card1/pcm0p/sub0/hw_params 
access: RW_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 96000 (96000/1)
period_size: 12000
buffer_size: 48000
any idea?

bye,
oskar

olefrank
Posts: 5
Joined: Thu Sep 26, 2013 3:44 pm

Re: raspberry pi b+ hidef audio issue

Sun Nov 02, 2014 5:25 pm

I have the same problem. When playing mp3 and flac 44.1 kHz it’s good. When playing high res, the playback speed is reduced.

Did you find a solution yet?

Setup:
RPi B+
Digi+
Benchmark DAC1
Raspbmbc (newest)

oaksboard
Posts: 7
Joined: Sun Sep 14, 2014 8:42 pm

Re: raspberry pi b+ hidef audio issue

Tue Nov 04, 2014 12:49 pm

update: seems to be a kernel issue with all kernels newer than 3.12.26.

on the volumio forum there is a test in progress (did work for me): http://volumio.org/forum/testing-needed ... t1958.html

bye,
oskar

Return to “Troubleshooting”