User avatar
alittlebitdifferent
Posts: 9
Joined: Wed May 30, 2012 8:10 am

USB error attempting to boot using Fedora 17

Mon Jun 11, 2012 3:48 pm

Anyone know what this means?

Smsc95xx ... usb net get endpoints failed -19

I used xzdec to place the nightly f17 pi build on my card.

The SD card is an SD Extreme 32GB 45mb/s

Given the Linux starts to boot I make the assumption the card is good. I don't have keyboard or mouse plugged in whilst booting.

Connected a keyboard and mouse just incase but didn't make a difference.

Does anyone have ideas as to the cause?

Genius23008
Posts: 54
Joined: Sun Jun 03, 2012 6:50 am

Re: USB error attempting to boot using Fedora 17

Tue Jun 12, 2012 9:17 pm

I used to have this issue but I don't anymore. I simply just stuck my finger on the USB contacts and pushed down (GENTLY!) on the ports. It got past the USB error but froze at login. Reflashed the card and bam, back into action.

User avatar
alittlebitdifferent
Posts: 9
Joined: Wed May 30, 2012 8:10 am

Re: USB error attempting to boot using Fedora 17(PHOTOS of P

Wed Jun 13, 2012 3:34 pm

After looking through those with simlar issues it seems most people have focused on the power and the X1 crystal for USB related issues on boot.

I have tested both...

Power seems acceptable
TP1-to-TP2&Scope_web.jpg
Photo of probe and scope when connected to TP1 and TP2
TP1-to-TP2&Scope_web.jpg (62.77 KiB) Viewed 1199 times
Crystal seems good
Pi_X1_Ground&Scope_web.jpg
Photo of probe and scope when connected to X1 Crystal and Ground
Pi_X1_Ground&Scope_web.jpg (60.33 KiB) Viewed 1199 times
So for me...same USB issue (shown below) but no obvious reason.
Odd-Output-Resolution_web.jpg
Shows the problematic USB debug that repeats at boot - Also shows that the output resolution is wierd.
Odd-Output-Resolution_web.jpg (51.05 KiB) Viewed 1199 times
I will re-flashing a totally different SD Card. PErhaps this SD Card - Although brand new..doesn't work so well *Fingers Crossed*

texy
Forum Moderator
Forum Moderator
Posts: 5156
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: USB error attempting to boot using Fedora 17

Wed Jun 13, 2012 3:45 pm

Thats a fast SD card. have you tried the latest kernel image? It has fixes for faster cards. Not sure if it applies to Fedora, but I,m sure an expert will
pip in ;)

Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

Zero
Posts: 7
Joined: Thu Jul 05, 2012 9:03 pm

Re: USB error attempting to boot using Fedora 17

Sun Jul 08, 2012 11:10 pm

Sorry for bringing back an old topic, but was this problem ever solved?
I have the exact same error and can for the life of me not find a solution.

texy
Forum Moderator
Forum Moderator
Posts: 5156
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: USB error attempting to boot using Fedora 17

Mon Jul 09, 2012 8:57 am

Yeah - don't use fedora ;-)

T.
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

Return to “Troubleshooting”