lossofworth
Posts: 2
Joined: Thu Jan 23, 2014 7:58 pm

Orico USB Hub not working

Thu Jan 23, 2014 11:21 pm

Hello,

I am trying to setup a raspberry pi to run a bit coin mining operation. (If everything works it will be many raspberry pi's). Everything is setup and running except I am unable to use the Orico H7928-U3 hub. It appears that the hub is detected, but the klondike miners are not detected. As another note, a mouse or keyboard is not detected either, but a flash drive is. I have tried everything listed here http://www.raspberrypi.org/forums/viewt ... 28&t=53832 with no luck. I have also searched everywhere and have come up dry. I keep seeing the error -71 that I take to mean it's not receiving enough power, but the hub has it's own power supply and to be safe I'm running the raspberry pi from a separate laptop. It sounds like the hub is simply not compatible but my boss is insisting on using them as we have a lot. Is there some way I can make them work? I have lsusb, lsusb -t, and dmesg outputs if that would help. Thank you in advance for any help!

Best Regards,

Zach G.

Tarcas
Posts: 740
Joined: Thu Jan 09, 2014 5:38 am
Location: USA

Re: Orico USB Hub not working

Mon Jan 27, 2014 10:28 pm

Although the Pi is powered through USB, it is NOT designed to be powered through another computer's USB port. It just needs more juice than can be provided.

If you're powering it from a laptop, no wonder you don't have enough power. Try plugging it in using at least a 1A wall wart power adapter (you can even plug it into the hub that's plugged into it, if the power adapter has enough juice for it AND its peripherals) and you should be fine.

lossofworth
Posts: 2
Joined: Thu Jan 23, 2014 7:58 pm

Re: Orico USB Hub not working

Mon Jan 27, 2014 10:33 pm

I was able to get it working. I did end up powering it through the USB hub itself, but what fixed it was adding dwc_otg.speed=1 to the cmdline.txt file. I don't understand enough about linux/raspbian to explain why but all I know is it works.

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2035
Joined: Thu Jul 11, 2013 2:37 pm

Re: Orico USB Hub not working

Tue Jan 28, 2014 3:32 pm

USB1.1 devices downstream of USB3.0 hubs don't work. The hubs themselves should be enumerated successfully though.

Post your log outputs and lsusb as I would like to know which chipset it uses.
Rockets are loud.
https://astro-pi.org

vallieres
Posts: 8
Joined: Mon May 05, 2014 1:51 pm

Re: Orico USB Hub not working

Tue May 06, 2014 5:03 pm

Confirmed to be working with the Orico 10-port USB 3.0 hub and latest RPi and firmware.

Thireus
Posts: 5
Joined: Sun Nov 23, 2014 8:48 pm

Re: Orico USB Hub not working

Sun Nov 23, 2014 8:59 pm

vallieres wrote:Confirmed to be working with the Orico 10-port USB 3.0 hub and latest RPi and firmware.
Hi vallieres!

I'm struggling to find a USB 3.0 Hub for my RPI B+. Would you mind sharing more details about what is working exactly and the Orico 10-port model that you bought?

- Are you able to plug USB 1.1 devices such as mouse keyboard as well?
- Are you able to power the RPI directly from one of the Orico ports? (Any backfeeding issue?)
- Which firmware did you use to flash your RPI that makes 3.0 hubs compatible?

Thanks a lot in advance!

Tarcas
Posts: 740
Joined: Thu Jan 09, 2014 5:38 am
Location: USA

Re: Orico USB Hub not working

Mon Nov 24, 2014 1:36 am

Thireus wrote: I'm struggling to find a USB 3.0 Hub for my RPI B+.
...
- Which firmware did you use to flash your RPI that makes 3.0 hubs compatible?
The Raspberry Pi only has USB 2.0 onboard. 3.0 hubs and devices will work with no special firmware, but at 2.0 speeds. I'm not familiar with the incompatibility between 3.0 and 1.1, so I'd have to suggest googling that if you need to know. Personally I'd recommend a USB 2.0 hub instead of 3.0 if it will only be used with the Pi. Much cheaper, and you don't get any more benefit from the 3.0 since the Pi won't go any faster than 2.0.

Thireus
Posts: 5
Joined: Sun Nov 23, 2014 8:48 pm

Re: Orico USB Hub not working

Mon Nov 24, 2014 2:33 am

Actually I've found what I needed on this thread: https://github.com/raspberrypi/firmware/issues/64

Thank you, I'm aware that the Raspberry Pi has 2.0 USB ports. I want to take advantage of the 0.9A USB 3.0 ports instead of 0.5A (USB 2.0 specs), which is very helpful when it comes to Bitcoin mining ;). And it is also always better to invest in a 3.0 USB hub than 2.0 USB hub in case I want to use that Hub for other purposes in the future.

Thireus
Posts: 5
Joined: Sun Nov 23, 2014 8:48 pm

Re: Orico USB Hub not working

Tue Nov 25, 2014 6:55 pm

Just bought a Anker 7-port with VIA812-B2 chipset.
rpi-update was not enough; Adding dwc_otg.speed=1 to /boot/cmdline.txt works :)

I can confirm USB 3.0 hubs (VIA812-B2 chipset) are working with the RPI B+ with this little hack.

Return to “Troubleshooting”