steffo
Posts: 25
Joined: Sat Jan 18, 2014 12:43 pm

Port forwarding to Wheezy

Sat Jan 18, 2014 12:54 pm

Hello all,
I am usin my Pi for logging data from my Tellstic temp sensors.
I installed the default package from www.raspberrypi.org/downloads only 10 days ago.

My problem is that I cannot portforward port 8081 (my apache listening port) to read my temp graphs from the internet.
All other "servers" I have in my network I can portforward to, liks SSH - works to the TV-box but if i terminate that port to raspberry it does not work..

Obviously I have a setting somewhere that makes my Pi not accept prort forwarding from my modem/router.. anyone that can suggest a solution?
Works perfect on the internal 192.168.1.xx network but after Dyn-dns and portforwarding I cannot connect and this goes only for the Pi. All other servers and equipment like my TV box works fine from the internet.

Anyone has any idea?

User avatar
Richard-TX
Posts: 1549
Joined: Tue May 28, 2013 3:24 pm
Location: North Texas

Re: Port forwarding to Wheezy

Sat Jan 18, 2014 1:03 pm

I would install wireshark and look at some packets.

apt-get install wireshark

tcpdump also works.
Richard
Doing Unix since 1985.
The 9-25-2013 image of Wheezy can be found at:
http://downloads.raspberrypi.org/raspbian/images/raspbian-2013-09-27/2013-09-25-wheezy-raspbian.zip

User avatar
DougieLawson
Posts: 37482
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Port forwarding to Wheezy

Sat Jan 18, 2014 6:05 pm

Is Apache listening on inaddr_any (address 0.0.0.0)?
Have you got any restrictive rules in your webserver config?
Have a look with netstat -tln and in your /etc/apache2/*.conf files.

Is there a firewall?

Can http://www.yougetsignal.com/tools/open-ports/ see your open port?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

steffo
Posts: 25
Joined: Sat Jan 18, 2014 12:43 pm

Re: Port forwarding to Wheezy

Mon Jan 20, 2014 3:32 pm

Tried tcpdump and I could not see any activities on eth0 related to my port forwarded requests..
I see that the ports I am forwarding to are bound to tcp6.. - could that be related to the problem?
IPv6 is turned off in my router... - but then again the port 8080 does not work either from outside the firewal after port forward so it's a long shot..

pi@raspbmc:/etc/default$ netstat -ltn

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:9090 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:4713 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:36666 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:36667 0.0.0.0:* LISTEN
tcp6 0 0 :::80 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 :::36666 :::* LISTEN

steffo
Posts: 25
Joined: Sat Jan 18, 2014 12:43 pm

Re: Port forwarding to Wheezy

Sun Jan 26, 2014 8:27 am

Hello,
I re-installed a raw image instead of the "noobs" network install.
Port forwarding worked directly - on any port.
I am still very interested in what was wrong when I used the "noobs network" install alternative.
thanks for help!

User avatar
bingindo
Posts: 5
Joined: Wed Jan 29, 2014 7:19 am
Location: Indonesia

Re: Port forwarding to Wheezy

Mon Feb 03, 2014 2:51 pm

Hi Steffo,

May I know from what link did you get that raw image which you re-intalled the raspberry?
Seems I have same problem and I'm still stuck, many thanks.

Bing

steffo
Posts: 25
Joined: Sat Jan 18, 2014 12:43 pm

Re: Port forwarding to Wheezy

Sat Feb 08, 2014 10:06 am

I just got the raw image from here:
http://www.raspberrypi.org/downloads
I still dont know why the port forwarding dont woork with the "noob" install procedure...
with the 2014-01-07-wheezy-raspbian.zip it worked with no problems, however on this dist I can not install XBMC :(

Return to “Troubleshooting”