Posts: 3
Joined: Sat May 04, 2013 11:53 pm

Qemu on pi and read disk errors

Thu Jun 20, 2013 3:18 am

I've setup a virtual machine on a windows 7 with qemu-manager... runsfine, exporting on other computers runs nicely etc...
it's a lightweight xp... so the image is .qcow2 that should be read as ntfs.
I don't need anything for it but to run... no screen, no feedback, just network and it will consume only nothing in cpu, it just need to be awake as much as possible... so the pi seemed like a good idea.
when I use the command : qemu /pathtomyimage/image.qcow2 -some options
I obtain a read disk error...
but, when i use the same command on linux or my windows, it works....
So help, please... thank you for reading.

Posts: 11
Joined: Tue Aug 20, 2013 7:12 pm
Location: Vancouver, BC

Re: Qemu on pi and read disk errors

Wed Sep 04, 2013 4:56 am

I have this EXACT issue! Has anyone been able to figure it out? I tried booting from usb and on the SD card, and both times get the same error. I even tried running the windows setup on the device instead of setting it up on another (faster) machine first, and I get the Disk read error when it goes to boot the copied setup files off the virtual drive. Really annoying!

User avatar
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: Qemu on pi and read disk errors

Wed Sep 04, 2013 2:24 pm

Errr, you do realise that the Pi has an ARM CPU, whereas Windows only runs on x86 CPUs? So even if this did work correctly, it'd be incredibly slow (with qemu emulating the x86 CPU).
http://www.raspberrypi.org/phpBB3/viewt ... 62&t=10635 might get you going in the right direction.

Return to “Troubleshooting”