Blast
Posts: 20
Joined: Wed Mar 28, 2012 1:57 pm

booting up pi but nothing showing up on screen

Mon Mar 11, 2013 4:46 am

when i power on my rpi, nothing comes on screen... i see a solid red light with a green light flickering for awhile but nothing comes up on the screen, any help?

i am using the latest 2013-02-09-wheezy-raspbian

sd card: Patriot SDHC 16 10 LX Series (PSF16GSDHC10) 19.3MB/s read, 9.3MB/s write

i checked the checksum to make sure it's correct and it was.

reformatted the sd card and copied the image over again using win32 disk imager and still no luck...

is something wrong with my rpi?

MaxK1
Posts: 1043
Joined: Sun Aug 26, 2012 11:34 pm

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 9:29 am

And your screen is a?
You are in a maze of twisty little passages, all alike.
When General Failure and Major Disaster get together, Private Parts usually suffers.

User avatar
rpdom
Posts: 14790
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 11:15 am

It sounds like your Pi is booting up correctly (green light flickering for some seconds), but the display output is incorrect.

The first place you should look is http://elinux.org/R-Pi_Troubleshooting#Display

As MaxK1 said, what sort of display do you have HDMI, Composite/RCA or something else connected via an adaptor?

Blast
Posts: 20
Joined: Wed Mar 28, 2012 1:57 pm

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 3:06 pm

HDMI

how do I access the config file ?

also

do i have to change all this ?

hdmi_safe=1

config_hdmi_boost=4

hdmi_force_hotplug=1

or just the hdmi_safe=1 ???

MaxK1
Posts: 1043
Joined: Sun Aug 26, 2012 11:34 pm

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 3:34 pm

It's in /boot/config.txt

You may not need all of them - I'd try config_hdmi_boost=4

Also (And this may sound weird) try reversing your HDMI cable! I have one (And others have reported this as well) that only works one way. It also needs to be pushed in _very_ firmly - a fraction of a mm may make contact. My other HDMI cables "just work"...
You are in a maze of twisty little passages, all alike.
When General Failure and Major Disaster get together, Private Parts usually suffers.

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 3:47 pm

Make sure your TV is switched on and ready before the Pi. The Pi detects the existence of a HDMI device, and if it isn't there it switches to composite.

Blast
Posts: 20
Joined: Wed Mar 28, 2012 1:57 pm

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 6:37 pm

couldn't get it to output any video using hdmi

tried with rca and it worked

the tv is pretty old, from 2006... it's the Toshiba 32HL66

here are the full specs of the tv http://reviews.cnet.com/flat-panel-tvs/ ... 91740.html

if anybody can take a look at the specs and show me what to change in the config file it would be great to get it to work with the hdmi

drgeoff
Posts: 9636
Joined: Wed Jan 25, 2012 6:39 pm

Re: booting up pi but nothing showing up on screen

Mon Mar 11, 2013 6:55 pm

MaxK1 wrote:It's in /boot/config.txt
... only when accessing it on the RPi. Which is a bit tricky without a working display. :)

If the OP can put the SD card in a card reader on a Windows PC, the config.txt file will be visible in the only 'drive' that Windows sees on the card. (Don't be concerned that the drive is only about 60 Mbyte.)

Return to “Troubleshooting”