alborz
Posts: 3
Joined: Thu Feb 16, 2017 5:44 am

Scanning for BLE devices on Raspberry Pi 4 Model B

Thu Feb 13, 2020 10:02 pm

Hi,

I am using a Raspberry Pi 4 model B (with 2 GB), using the latest release of buster.
I wanted to experiment with Bluetooth Low Energi but scanning for BLE devices does not work (scanning for regular bluetooth devices works).
See the output below.
I have been searching all over the internet. (I have tested rebooting the raspberry, even hci0 but nothing seems to do the trick)

Code: Select all

pi@raspberrypi:~/Scripts $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

Code: Select all

pi@raspberrypi:~/Scripts $ sudo hcitool scan
Scanning ...
        C4:93:D9:2D:87:EC       Galaxy S9+

pi@raspberrypi:~/Scripts $ sudo hcitool lescan
Set scan parameters failed: Input/output error

Code: Select all

pi@raspberrypi:~ $ sudo hcitool --help
hcitool - HCI Tool ver 5.50

The device seems properly installed and running:

Code: Select all

pi@raspberrypi:~/Scripts $ hciconfig -a
hci0:   Type: Primary  Bus: UART
        BD Address: DC:A6:32:2A:F6:A9  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING
        RX bytes:9386 acl:0 sco:0 events:458 errors:0
        TX bytes:15700 acl:0 sco:0 commands:358 errors:0
        Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy: RSWITCH SNIFF
        Link mode: SLAVE ACCEPT
        Name: 'raspberrypi'
        Class: 0x480000
        Service Classes: Capturing, Telephony
        Device Class: Miscellaneous,
        HCI Version: 5.0 (0x9)  Revision: 0x122
        LMP Version: 5.0 (0x9)  Subversion: 0x6119
        Manufacturer: Cypress Semiconductor Corporation (305)

Return to “Troubleshooting”