milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Omxplayer not working properly on Raspberry Pi 4

Sat Sep 21, 2019 2:08 pm

Hello,

i recently got my new Raspberry Pi 4 and as i wanted to play my .mp4 file on omxplayer, all he said was the usual information (e.g. resolution etc), but he wont show me the video. After the end of the video he also tells me that i should 'have a nice day ;)', which tells me that he finished playing it. I used an Raspberry Pi 3 before and if i use the same SD card on my Pi3 it works fine. Does anyone know why that problem occurs?

Best regards and thanks for the help in advance,

Max

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23876
Joined: Sat Jul 30, 2011 7:41 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sat Sep 21, 2019 4:14 pm

What format is the video inside the MP container?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Tue Sep 24, 2019 8:06 am

I wanted to play an .mp4 file. Are there differences in between mp4 formats?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23876
Joined: Sat Jul 30, 2011 7:41 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Tue Sep 24, 2019 9:00 am

milanbeck22 wrote:
Tue Sep 24, 2019 8:06 am
I wanted to play an .mp4 file. Are there differences in between mp4 formats?
MP4 is a container, it doesn't specify what encoding scheme is used for the video INSIDE the container. WHich is the bit we really need to know. On the command line try `file <filename to play>`, I think that might tell you what is inside.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Tue Sep 24, 2019 9:53 am

Ah thanks didnt know about that, and thanks for the fast replies!

I used the command suggested and it gives me following information: ISO Media, MP4 v2 [ISO 14496-14]

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23876
Joined: Sat Jul 30, 2011 7:41 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Tue Sep 24, 2019 9:57 am

OK, not quite enough information.

Try ffprobe instead of file. Somewhere near the bottom of the results with be a couple of lines starting with "Stream", which should indicate the contained stream information - video and audio.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Tue Sep 24, 2019 10:06 am

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Video_01.mp4':
Metadata:
major_brand : mp42
minor_version : 1
compatible_brands: mp41mp42isom
creation_time : 2018-11-16T22:34:26.000000Z
Duration: 00:01:12.24, start: 0.000000, bitrate: 6653 kb/s
Stream #0:0(deu): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 251 kb/s (default)
Metadata:
creation_time : 2018-11-16T22:34:26.000000Z
handler_name : Core Media Audio
Stream #0:1(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709, progressive), 1920x1080 [SAR 1:1 DAR 16:9], 6395 kb/s, 29.97 fps, 29.97 tbr, 30k tbn, 60k tbc (default)
Metadata:
creation_time : 2018-11-16T22:34:26.000000Z
handler_name : Core Media Video

Thats the outcome of the command

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sat Oct 12, 2019 10:36 am

So is there anything i need to change, so that it works? :)

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sat Oct 12, 2019 11:06 am

I tested it with VLC player and there it worked. But when i put the Video in fullscreen on vlc player, it plays the video, but theres a black screen until i double click on the screen and it goes into windowed mode. To determine that it isnt just a problem with fullscreen, i put the omxplayer in a 50x50 pixel window and it also starts and ends the Video, but it doesnt show it

gkreidl
Posts: 6114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Omxplayer not working properly on Raspberry Pi 4

Sat Oct 12, 2019 11:48 am

Are you using the legacy driver or the 3D driver?

I've had a simlar problem with my 1080p TV recordings, but only when I was using the Legacy driver. With the 3D driver they all work, both in omxplayer(GUI) and VLC.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sun Oct 13, 2019 7:34 am

Thanks fo the fast reply! I must say im pretry new to Raspberry Pi, im sorry :(
Is there a way to check which driver i am currently using?

RossDv8
Posts: 148
Joined: Thu Jan 21, 2016 12:35 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sun Oct 13, 2019 7:50 am

Are you using omxplayer, or omxplayerGUI ?
I have been using omxplayerGUI (part of the kweb Minimal Kiosk Browser suite) for years. It allows you to easily modify lots of settings, and has an excellent manual.

Also, I noticed that while it plays most videos up to 1080p more smoothly than VLC etc., it does not like to play my 2160p videos.
Pi 4B 4GB - system on WD 240G SSD ( but /boot on Sandisk microSD)

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sun Oct 13, 2019 8:10 am

Up to now i am starting the omxplayer with popen "omxplayer". So im not using the GUI version currently. I'm gonna try and set up the GUI version and see if it works there, thanks!

milanbeck22
Posts: 9
Joined: Fri Sep 20, 2019 3:23 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sun Oct 13, 2019 8:14 am

Im starting it within a python script, that information was missing*

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23876
Joined: Sat Jul 30, 2011 7:41 pm

Re: Omxplayer not working properly on Raspberry Pi 4

Sun Oct 13, 2019 8:53 am

RossDv8 wrote:
Sun Oct 13, 2019 7:50 am
Are you using omxplayer, or omxplayerGUI ?
I have been using omxplayerGUI (part of the kweb Minimal Kiosk Browser suite) for years. It allows you to easily modify lots of settings, and has an excellent manual.

Also, I noticed that while it plays most videos up to 1080p more smoothly than sVLC etc., it does not like to play my 2160p videos.

The underlying HW used by omxplayer is limited to 1080p60
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

Return to “Troubleshooting”