Psychlist
Posts: 4
Joined: Wed Nov 21, 2018 11:41 am

RPi4 Buster Kernel Mismatch Error

Fri Aug 16, 2019 3:07 pm

I'm getting a repeated "Pending kernel upgrade!" message during updates that is not resolved by rebooting. The output of needrestart is as follows:

Code: Select all

pwt@raspberrypi-4:~ $ needrestart -k
Scanning linux images...                                                                                                         

Pending kernel upgrade!

Running kernel version:
  4.19.58-v7l+

Diagnostics:
  The currently running kernel version is not the expected kernel version 4.19.58-v7+.

Restarting the system to load the new kernel will not be handled automatically, so you should consider rebooting. [Return]
I'm running a fully updated Raspbian Buster on a 4GB RPi 4. Any ideas?

Thanks!

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5880
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: RPi4 Buster Kernel Mismatch Error

Mon Aug 19, 2019 9:37 am

Whatever is giving you that message, it's not installed by default. I don't know where it's getting its information from, but it probably expects a standard debian kernel setup, which is not something we use.

Psychlist
Posts: 4
Joined: Wed Nov 21, 2018 11:41 am

Re: RPi4 Buster Kernel Mismatch Error

Thu Aug 29, 2019 5:50 pm

Thanks for the response. FWIW, this was a standard Raspbian Desktop install, downloaded from the standard place. The problem emerged at some point after a normal update.

Return to “Troubleshooting”