STAUK
Posts: 1
Joined: Mon Aug 12, 2019 5:22 pm

Raspberry Pi4 use with an Onkyo Audio Receiver

Mon Aug 12, 2019 5:30 pm

Hello,
i've been using Pi1, 2, 3 with my Onkyo 608 receiver for many many years over HDMI and had no problem. The audio receiver acts as a pass through so i can get surround sound from the Pi running KODI/NAS.
Ive upgraded to the PI4 this weekend, installed LibreELEC 9.1 running 18.3 KODI for the Pi4 and connected to my Onkyo receiver. No signal detected. I connected the PI4 directly to the TV with HDMI, i saw a signal. Tried connecting again through the onkyo using 4 different HDMI inputs and several different cables and all resulted in no signal output. Am i missing something?

TLDR; PI4 connected directly to TV via HDMI = Signal
PI4 connected via HDMI to TV through Onkyo A/V receiver = No signal
A/V receiver/TV combo works with PI3, PI2, PI1 over HDMI

Any help appreciated,
Cheers
Bill

Galerion
Posts: 1
Joined: Tue Oct 08, 2019 7:21 pm

Re: Raspberry Pi4 use with an Onkyo Audio Receiver

Tue Oct 08, 2019 7:25 pm

I have the same problem with a yamaha receiver.

When the rasbian desktop boots the outpt goes black when I run it though the receiver, when running directly to TV it works ok. I've been fiddling with screen resolution settings in the desktop but no luck.

The output did work as expected up until some update that came maybe a month or two ago.

Please let me know if you found a solution.

Rascas
Posts: 544
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Raspberry Pi4 use with an Onkyo Audio Receiver

Tue Oct 08, 2019 7:47 pm

Did you tried with hdmi_drive=2 in config.txt ?

mechwarrior
Posts: 5
Joined: Sat Mar 14, 2015 8:53 am

Re: Raspberry Pi4 use with an Onkyo Audio Receiver

Sat Oct 26, 2019 6:20 am

did you find a solution to this?

jubarim
Posts: 2
Joined: Sat Oct 26, 2019 1:02 pm

Re: Raspberry Pi4 use with an Onkyo Audio Receiver

Sat Oct 26, 2019 1:46 pm

I found a solution!

I have the Pi4 4gb version and I could not make it work using the Onkyo 608 receiver. Connecting the board directly on the TV worked.

Raspbian and Libreelec were not working. So I tried to fix Raspbian first. I used noobs to install both SOs on it, so connect your SD card to your pc and change the config.txt of the drive name "boot":

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#cdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=9

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

# NOOBS Auto-generated Settings:
I think what I changed were:
  • disable_overscan=1
    hdmi_force_hotplug=1
    config_hdmi_boost=9
Raspian started booting correctly on my receiver!

=====

To fix libreelec I tried the following with no success:

https://forum.libreelec.tv/thread/20238 ... elec-logo/
(running the command in a SSH terminal "tvservice -m CEA" caused freezing, no response).

Well I tough libreelec might have the same config.txt file and it does! I added the same lines I used for Raspbian in the drive named "System"
  • disable_overscan=1
    hdmi_force_hotplug=1
    config_hdmi_boost=9
See the complete file:

Code: Select all

# SPDX-License-Identifier: GPL-2.0-or-later
# Copyright (C) 2009-2014 Stephan Raue (stephan@openelec.tv)
# Copyright (C) 2016-present Team LibreELEC (https://libreelec.tv)
################################################################################
# Bootloader configuration - config.txt
################################################################################

## JM - juba - got this from raspbian que funcionou ##
disable_overscan=1
hdmi_force_hotplug=1
config_hdmi_boost=9

################################################################################
# Memory (System/GPU configuration )
################################################################################

# Default GPU memory split - at least 288M is needed for some 4k HEVC files
gpu_mem=320

################################################################################
# For overclocking and various other settings, see:
# https://www.raspberrypi.org/documentation/configuration/config-txt.md
################################################################################
# Set 'force_turbo=1' to disable dynamic overclocking and enable overclocking always.
force_turbo=0

# Force HDMI even if unplugged or powered off
# hdmi_force_hotplug=1

# Doesn't sent initial active source message.
# Avoids bringing CEC (enabled TV) out of standby and channel switch when
# rebooting.
hdmi_ignore_cec_init=1

################################################################################
# End of default configuration
################################################################################

################################################################################
# Include distribution specific config file if it exists.
################################################################################
[all]
include distroconfig.txt

# NOOBS Auto-generated Settings:
Saved, booted Libreelec with success!

One more issue I noticed: when I started playing a video, my TV (an old Full HD Samsung) changed to another input. I remembering seeing some posts of people saying CEC might be the problem - so I disabled it on my TV and now it works!
hdmi-cec.jpg
hdmi-cec.jpg (69.56 KiB) Viewed 160 times

Sorry about the long posts and I hope it can help you guys. Let me know if you need more details or have any doubts.

:-D
Raspberry PI 4 - 4gb
Onkyo SR608 receiver

jubarim
Posts: 2
Joined: Sat Oct 26, 2019 1:02 pm

Re: Raspberry Pi4 use with an Onkyo Audio Receiver

Sat Oct 26, 2019 3:04 pm

I found a solution, posted here, but it is still under revision by the administrators...
Raspberry PI 4 - 4gb
Onkyo SR608 receiver

Return to “Troubleshooting”