Powershell
Posts: 41
Joined: Fri Apr 08, 2016 10:24 am

Kodi on Raspbian shows the desktop from underneath

Sun Jul 21, 2019 5:48 pm

Hi everyone!

I use Kodi 18 on Raspbian, GPU mem set to 256 mb.

When Kodi dims the screen (after a few minutes), the actual desktop bleeds through it - parts of browser windows etc.

Can anyone (more knowledgeable than I am) tell me how exactly it maps the video memory? Maybe there's some switch to separate the X desktop from Kodi ?

Rascas
Posts: 563
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi on Raspbian shows the desktop from underneath

Sun Jul 21, 2019 6:17 pm

Please post your kodi log:
https://kodi.wiki/view/Log_file

Powershell
Posts: 41
Joined: Fri Apr 08, 2016 10:24 am

Re: Kodi on Raspbian shows the desktop from underneath

Sun Jul 21, 2019 9:00 pm

The log output is too big, would you elaborate what lines are the most relevant?

Actually, after checking it more closely, the problem stems from the boot sequence.
I had Kodi to autostart through systemctl. And it starts prior to other desktop programs (Pidgin etc).
Thats when the desktop background bleeds through.

If I disable the Kodi autostart, the apps get loaded as usual, and then when I manually start Kodi, there's no any graphic artifacts.

I think they somehow fight with each other for the GPU.

So far I've just disabled Kodi autostart and it SOLVED the prob.

Rascas
Posts: 563
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi on Raspbian shows the desktop from underneath

Sun Jul 21, 2019 9:32 pm

A full log is needed for debug. Post it on any other sharing site, or just autostart it, do nothing and wait for the screen to idle, it should be small enough for paste sites.

Rascas
Posts: 563
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi on Raspbian shows the desktop from underneath

Sun Jul 21, 2019 9:38 pm

But yes, it can be a race condition in the boot sequence. A "sleep 5" in the systemd script may solve your problem. Or better, if you want to autostart Kodi and keep the desktop on the background, is to do the option number 2 as explained here:
https://www.raspberrypi.org/forums/view ... 6&t=192499

Return to “Troubleshooting”