sybaseguru
Posts: 4
Joined: Sat Jun 30, 2012 11:08 am

CIFS mount not working on Buster

Fri Jul 12, 2019 3:43 pm

New install.

pi@pi3b:~ $ uname -a
Linux pi3b 4.19.50-v7+ #896 SMP Thu Jun 20 16:11:44 BST 2019 armv7l GNU/Linux

/etc/fstab entry to access share on old Synology server:
//192.168.1.110/RaspberryPi /home/RaspberryPi cifs vers=1.0,credentials=/home/pi/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

pi@pi3b:~ $ sudo apt-get install samba-client
Note, selecting 'smbclient' instead of 'samba-client'
smbclient is already the newest version (2:4.9.5+dfsg-5).

pi@pi3b:~ $ sudo apt-get install samba-common
samba-common is already the newest version (2:4.9.5+dfsg-5).

pi@pi3b:~ $ sudo modprobe cifs
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.19.50-v7+/modules.dep.bin'
modprobe: FATAL: Module cifs not found in directory /lib/modules/4.19.50-v7+

pi@pi3b:~ $ cat /proc/filesystems
returns everything but CIFS

pi@pi3b:~ $ find /lib/modules/ -name cifs.ko
/lib/modules/4.19.57+/kernel/fs/cifs/cifs.ko
/lib/modules/4.19.57-v7+/kernel/fs/cifs/cifs.ko
/lib/modules/4.19.57-v7l+/kernel/fs/cifs/cifs.ko

pi@pi3b:~ $ sudo depmod -a
depmod: ERROR: could not open directory /lib/modules/4.19.50-v7+: No such file or directory
depmod: FATAL: could not search modules: No such file or directory

Any suggestions?

Peter

DirkS
Posts: 9876
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: CIFS mount not working on Buster

Fri Jul 12, 2019 4:53 pm

Any suggestions?
reboot your Pi.

Notice that you're still running 4.19.50 but the 'find' sees the files in 4.19.57
I think new kernel was installed in the last update/upgrade and you did not boot your Pi after that.

Return to “Troubleshooting”