Page 1 of 1

Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 9:38 am
by bpehrson
I created a sd-card with the buster image and added an empty file named ssh in the boot partition.
I can login via ssh but not via the desktop gui using the same cerdentials, whether I require a password or select auto-login in raspi-config
I see some posts tat may have similar problems but no reply.
What could be wrong?

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 9:43 am
by pcmanbob
Are you trying to connect to the GUI remotely via VNC on directly on the pi using a screen and keyboard ?

Have you changed the password for user pi if so have you rebooted ?

yet again to little information supplied to give a meaning full answer, we can only provide help on the information you provide.

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 1:22 pm
by bpehrson
Yes, I have rebooted every time after using raspi-config. and I have done this many times tryong all the different boot options.
It seems to me that there are severl users that report almost the same problem and a common denominator could be that there is a problem loggin in via the gui, whetjer you do it directly, via vnc or whatever

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 1:34 pm
by bpehrson
I have also created another user with another password, but no luck. I still can login via ssh but not via the gui, with any of the credentials.
Personally, I am logging in via the hgui directly with a keyboard having a mousepad and a 7" hdmi screen.
Could it be a serial interfacing boot option problem Should there be any .xsession files to check? how to trouble shoot?

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 1:38 pm
by pcmanbob
If this is a fresh install of raspbian buster with desktop(GUI) by flashing the img directly to the SD card using etch or some other means then once the pi has rebooted the first time to expanded the image it should just automatically run the desktop no need to log in.

once you have used raspi-config to enable VNC and change your password , again following the reboot you should just be logged straight back in to the desktop.

there is no need to change any boot options regarding the desktop or logging in.

to log in via VNC you just enter the IP address of the pi in VNC viewer on your pc, then change the user to pi and then enter your password in the credentials window.

So if your pi is not doing this please explain what changes you have made to prevent this automatic login to the desktop, or access via VNC

EDIT.

if you have added another user then I don't know because I have not idea how you created the user or what access the user has.
I would suggest you start over flashing your SD card with a fresh copy of raspbian with desktop and try again, only this time only change your password and enable VNC don't change anything else.

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 1:45 pm
by bpehrson
I get the login screen alright, input username first and then password and push login. What happens is that the scŕeen goes black for a while then the prompter comes back and then the login screen again.
I am not sure exactly what I have done but I should perhaps start all over and do nothing, not even add a the ssh file on the boot partition.

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 1:46 pm
by DirkS
What size is your SD card?

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 3:33 pm
by bpehrson
The size of my SD card is 16 GB. I started all over and did nothing before the desktop came up and that worked. Thanks.
So now the qiestion is what I dare to do using CLI in a terminal window without jeopardizing the gui login. I would like to create another user and disable remote login for the user pi, to make unauthorized remote login harder, but I could not find any way to create a new user in the GUI. So, could I use adduser in the cli or not? I also want to add an openvpn tunnel, setup a dns server, add an RTC, etc. Any advice is welcome.

Re: Desktop (gui) login does not work in buster?

Posted: Thu Jul 11, 2019 4:14 pm
by HawaiianPi
To add a new user, sudo adduser works for me. You should also join your new user to all the same groups as the pi user, and then add it to the 010_pi-nopasswd file in /etc/sudoers.d/ (or you can add your own file there for the new user, and configure it how you like).

To disable pi logins you can sudo passwd --lock pi (or just delete the pi user).


EDIT:
For those who are using the desktop version, set it to not automatically login.